Call connector for Dynamics CRM - No dial button

Unanswered Question
Sep 7th, 2009

Hi,

I've set up a UC520 with Call Connector for Dynamics CRM and am having a few teething problems.

I've got it installed, the searching an dialing from the system menu is working fine. The problems I've got firstly is that there is no Dial button appearing on any of the CRM forms. ISV Integrations are enabled, there just doesn't seem to be any changes made during installation. I have run the installer again.

Secondly I am having trouble getting the phones to lookup from the CRM database. This is mostly due to my lack of knowledge of setting up an IP Phone Lookup Service, if you could point me in the direction of some documentation I'd be grateful.

Thanks,

Adam

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
apedder123 Wed, 09/09/2009 - 01:53

I have sorted this - details in case any one else has this problem are:

If buttons do not appear on CRM forms, firstly check that ISV Integrations are active - details for this are in the installer PDF.

Export customizations by logging on to CRM as an Administrator user and Selecting Settings, and then Customization from left menu. Click Export Customizations from the workpane and export ISV Config.

Extract the customizations.xml file and edit it to insert the following code into the Account, Lead and Contact Tool bars, obeying normal MSCRM rules and placement.

            http://servername:5556/CUCCdial.aspx" PassParams="1" WinParams="" WinMode="0">
             
               
             
             
               
             
           

Adam

ronlewis Tue, 09/08/2009 - 21:16

Make sure you read the install guide in the zip file with the installers on how to setup the XML application to show CRM Contacts on the phones.

The Dial button shows up on CRM pages, as an add on, as long as the server piece was installed correctly with admin rights.

The install guide on CCO, under CallConnectors for CRM is out of date for setting up the XML app on the phones, so make sure you use the admin guide in the zip file instead.

Ron Lewis

Cisco

ra_jeshkalra_2 Fri, 06/04/2010 - 07:58

Hi,

1.Could you finally get the IP Phone lookup service working. If yes can you send me the steps?

2.I am havig issue with outbound dial(click to dial), which I think is due to the TAPI configuration:

Questions:

1.Do I need to install Cisco TAPI TSP Driver?

2. Do I need to manually create CTI ports in CCM?

3.Is CTI Route point also needed?

Any other thing to check?

Thanks

ra_jeshkalra_2 Fri, 06/04/2010 - 08:03

Hi,

1.Finally could you get the Cisco IP Phone lookup service working? If yes can you send me the steps pls.

2.I can't get click to dial work with outgoing calls. I think this is due to TAPI installation/settings.

Questions:

1.Do I need to install cisco wave driver for Windows XP on client PC.

2. Do I need to manually create CTI ports in CCM?

Anything else is needed?

Thanks

Ted Haubein Thu, 01/06/2011 - 19:21

The TSP driver is necessary for the TAPI configuration.  Without the TSP driver the Cisco Client will not be see the line or lines configured on the Phone. Furthermore without the TSP driver it impossible to make a call simply by doing a Click To Dial. You can find the TSP driver on Cisco site. Be sure to download the appropriate driver for your version of CME.  If you are running Full Blown Call Manager then simply download the TSP from the Call Manager Server.

Actions

This Discussion

Related Content