mpls traffic-eng reoptimization.

Answered Question
Sep 7th, 2009

!

interface Tunnel1211

ip unnumbered Loopback0

load-interval 30

tunnel destination 1.1.1.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng bandwidth 1000

tunnel mpls traffic-eng path-option 1 explicit name hj

tunnel mpls traffic-eng path-option 2 dynamic

tunnel mpls traffic-eng fast-reroute

!

mpls traffic-eng reoptimize timers frequency 5

mpls traffic-eng reoptimize timers delay installation 5

mpls traffic-eng reoptimize timers delay cleanup 5

mpls traffic-eng reoptimize events link-up

Our mpls configuration is like above log.

We configured the path option1, path option2 in the tunnel interface.

when the explicit path failed, the path option2 comes up.

Our plan is that when the path option 1 is failed, and the core running the FRR

We do not want to switch over th path option2 dynamically

How can I do that? Any thought?

and next...

there is mpls traffic-eng reoptimize in our configuration. If I remove that, Can I make it like above?

I have this problem too.
0 votes
Correct Answer by jcozzupoli about 7 years 2 months ago

Has your question been answer sufficiently? If so, can you please vote and advise Author's question has been answered?

Thanks.

Joe.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
jcozzupoli Mon, 09/07/2009 - 16:46

I think the best way is to have 2 TE GRE Tunnels configured. Both with explicit paths with one the direct path and the other one having the backup path. See below:

interface Tunnel100

description DIRECT LSP

ip unnumbered Loopback0

tunnel destination 1.1.1.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng path-option 1 explicit name TE_PRIMARY

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng bandwidth 1000

tunnel mpls traffic-eng fast-reroute

interface Tunnel200

description BACKUP LSP

ip unnumbered Loopback0

tunnel destination 1.1.1.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng path-option 1 explicit name TE_SECONDARY

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng bandwidth 1000

interface X

mpls traffic-eng backup-path Tunnel200

-----

Also, depending on your IGP (IS-IS is faster for FRR convergence) you could tweak the spf timers and if you are running BFD then tie RSVP to BFD for even better convergence (but this depends on hardware platforms used).

syjeon Mon, 09/07/2009 - 17:22

Thank a lot..

I understood your comment.

but I have a question within your config.

the interface X...

When We are config explcit path, we point hop-by-hop.

I think that your interface x is Physical interface. Right?

if so. if the interface x didn't goes to down, the backup-path tunnel 200 didn't activate..Right? the reason is the physical link still up.

if I can configure to make backup tunnel in the the interface tunnel 100, It's make sense. but real didn't do that.

jcozzupoli Mon, 09/07/2009 - 17:42

Yeah interface X is the physical interface where your LSP begins. Remember, in the routing table you'll see the tunnels and not the physical interface. I have implemented this for a customer and it works pretty really well (sub 2ms failover).

Another note, if you remove "autoroute announce" from the backup tunnel it will work only as a backup, if you have "autoroute announce" there it will load-share between the 2 tunnels.

I recommend doing this in a lab environment so you can break the direct link and see the routing change. An MPLS traceroute or a normal IP traceroute will show you which LSP its taking (ie, which Tunnel is in use).

HTH.

- Joe.

syjeon Mon, 09/07/2009 - 17:56

Thans a lot! Be always happy :)

I would like to know when the below,

The Tunnel 100 is configured with Explicit Path. and It's working well in normal . but Tunnel 100 is down due to its explicit path failed. but Tunnel 200 didn't working due to tunnel 100 indirect link failed.

AS I know. the physcal link still comes up. and the indirect explicit failed . so the traffic can't use the tunnel 200

just thing I would like to know that If I want to activate the tunnel 200, the physical link must be down ? Right?

jcozzupoli Mon, 09/07/2009 - 18:06

Well yes and no. Because like I said in my previous post, you can load-share across the 2 tunnels so this way you don't have any wasted bandwidth. This is done with my configuration having "autoroute announce" in both tunnels.

Correct Answer
jcozzupoli Wed, 09/09/2009 - 01:05

Has your question been answer sufficiently? If so, can you please vote and advise Author's question has been answered?

Thanks.

Joe.

ulatif Mon, 11/16/2009 - 05:19

Okay so you asked two questions:

#1. If you have 2nd path option configured and if there is a failure on 1st path option, you would like the 1st path option to remain in place (using FRR) and 2nd path option should not kick in? is that a correct understanding of your question?

If yes, then I'd have to ask you a question in return - why then you have a second path option configured if you want the TE tunnel to continue using FRR path option ?

What normally happens is that when the PLR detects the failure, it also sends an RSVP message to the head-end of the tunnel informing it about the failure in the path. This is why you normally would see that when FRR is in place for the 1st path option, you see tunnel stating "Change in resources detected: reroute pending" if you do a "show mpls traffic-eng tunnel" on the head-end.

Now if the head-end has a 2nd path-option configured, it would switch to the 2nd path-option (as it is supposed to do) in a make-before-break fashion. If you dont want it, then remove the 2nd path-option :)

#2: Reoptimization timers - i dont think reoptimization timers will help you in achieving what i mentioned in part #1 because reoptimization is a scheduled event that has little to do with FRR and subsequent second path option kicking in.

It would help you more when your failed 1st path recovers and traffic needs to be switched back to 1st path option.

regards

Usman

Actions

This Discussion