SIP GW Local Ringback

Answered Question
Sep 8th, 2009

Hi, Everyone.

I have some problem, I use CUCM7.01 create a sip trunk to my GW2811. GW2811 connection PSTN use ISDN PRI. When I make a call to my cellphone, after finish dial the number, I hear the ringback immediately. but my cellphone not ringing, because connection don't establish. I think the ringback is GW2811 provide. For testing, I change GW mode to H.323, and make call, that call will normal, I can hear ringback until my cellphone ringing, that ringback is music provide form ISP, SIP trunk did not hear that. The real problem is use sip trunk call cellphone, cellphone ringing but hang up the call, This time IPphone still listen normal ringback! not busy or disconnect.

My English is bed, hope everyone can understanding and help me to resolve that problem. THX

I have this problem too.
0 votes
Correct Answer by Stoyan Stoitsev about 7 years 4 months ago

Hello,

You should go to the Cisco CallManager Service Parameter Configuration page. In Clusterwide Parameters (Device - SIP) make sure SIP Rel1XX Enabled is set to Send PRACK for all 1xx Messages.

Also check if you are using a IOS release later than 12.4(20)T on your VGW.

BR,

Stoyan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Correct Answer
Stoyan Stoitsev Tue, 09/08/2009 - 03:45

Hello,

You should go to the Cisco CallManager Service Parameter Configuration page. In Clusterwide Parameters (Device - SIP) make sure SIP Rel1XX Enabled is set to Send PRACK for all 1xx Messages.

Also check if you are using a IOS release later than 12.4(20)T on your VGW.

BR,

Stoyan

rock981119 Tue, 09/08/2009 - 04:29

Thx for your explanation, I will try that config tomorrow. Did you think that problem have relate to Early Media on 180? That option is in default parameter.

Any way thanks for your help, wait the good news!

Stoyan Stoitsev Tue, 09/08/2009 - 05:17

Hi,

The feature on the VGW is:

12.4(20)T Control Media Cut-Through on SIP 18x Response

Provides the ability to send media backward before a call is established, allowing the remote side to send personalized ringback tones (usually music) as a response before a call is established. This is default behavior but, in some scenarios, causes clipping and may need to be disabled (CLI for disabling this behavior was added for this release).

The command is rtp send-recv and it was added under voice service voip/ sip configuration as on by default.

More here:

http://www.cisco.com/en/US/docs/ios/voice/sip/configuration/guide/12_4t/sip_12_4t_book.html

More on CUCM SIP Rel1xx parameter from a post of GONZALO GASCA:

Select "True" in the SIP Rel1XX Enabled.

This forces the 1XX messages sent by the gateway to Callmanager to be Provisionally ACK'd.

The PRACK sent by Callmanager contains the SDP necessary to open the audio

path from the gateway to the IP phone.

BR,

Stoyan

Actions

This Discussion