Add automatically a digit (for CallBack)a to the caller num in missed calls

Answered Question

Hi All,

I would like to know how to add the prefix 0 to the caller number , inorder to make possible to call back a the caller number of a missed call by clicking on the call softphone.

The same problem with the international number , to which corresponds, a different prefix.

best regards,

I have this problem too.
0 votes
Correct Answer by rob.huffman about 7 years 1 month ago

Hi Ramzi,

Excellent Step by Step;

Add Prefix to the Missed Call Number

Hope this helps!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Kenneth Mohammed Tue, 09/08/2009 - 05:50


If this is an MGCP gateway, you can go to system--->service parameters---->cisco call manager service---->click advanced button---->under clusterwide parameters PRI and MGCP gateway settings..there is a field for Incoming Calling Party National Number Prefix - MGCP and Incoming Calling Party International Number Prefix - MGCP ...add the number you would like to prefix there.

If it is H323 gateway, you can setup voice translation rules to prepend numbers to the incoming calling number.

Hope that helped, if so please rate.

Lulzim Islami Thu, 09/23/2010 - 04:31


I'm facing a same issue with adding prefix to missed calls. I'm using MGCP as a gateway in CUCM 7.1.5.

I went to System---service parameters---cisco call manager service---->click advanced button---->under  clusterwide parameters PRI and MGCP gateway settings. On the  Incoming Calling Party National Number Prefix - MGCP and Incoming  Calling Party International Number Prefix - MGCP I added 9 so when I receive call from 038549XXX on my missed call to shown as 9038549XXX. But for some reason the 9 is not showing up.

Any ideas?

Thank you,

Aaron Harrison Thu, 09/23/2010 - 04:45


The prefix is added based on the 'type' of number as signalled in from the ISDN. When you do 'debug isdn q931' on the gateway, it should show the number as 'international', national, subscriber or unknown. You need to configure each prefix type to suit your needs.

If all numbers (despite being national or international) come in as unknown, you can't use this feature unless your service provider can fix the ISDN signalling for you.



Please rate helpful posts...

Lulzim Islami Thu, 09/23/2010 - 04:57

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;}

All my numbers are coming as unknown and I doubt that my service provider will do something to fix ISDN signaling type. I guess I have to stick with editing the number.

Thanks for the help.

Aaron Harrison Thu, 09/23/2010 - 05:07


Yes, I'm afraid so - in general if you don't have good information coming from the SP you are often better to use H.323 as you can do more flexible translations - for example you can apply different prefixes to the numbers if they look like international numbers than if they are national.



This Discussion