×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SPA9000 SLA and Forward to AA

Unanswered Question
Sep 8th, 2009
User Badges:

My Shared Extension Mentioned Below is 108.


I have 4 SPA942's, 1 SPA901, and one WIP310 phone registered on my SPA9000 with their own extensions registered on EXT 2 and a shared extension on EXT 1.  On the SPA901 and WIP310 only the shared extension is on EXT 1.  I have an SPA400 that handles one voicemail box and two PTSN lines that I use for incoming and outgoing calls on "Line 1" of the SPA9000.


I want incoming calls to ring the shared extension for about 25 seconds and then go straight to the auto attendant.  Anyway that I setup up the system with a timer longer than 20 seconds, calls ring the shared extension for about 20 or so seconds, then the shared extension stops ringing and then the shared extension starts ringing for another 20 or so seconds before the call finally goes to the aa.  In essence, with a no answer delay longer than 20 seconds I get a loop of an incoming call.


The following setups I have tried:

1.  I have the contact list for Line 1 set to "aa,108."  I have the Cfwd No Ans Delay set to 90.  And in the answer delay for the aa, any delay less than 20 seconds works just fine but any number above 20 seconds causes the call to stop ringing the shared extension and then start the ringing again (aforementioned problem in explanation above.)


2.  I have the contact list setup for "108,cfwd=aa."  If the Cfwd No Ans Delay is set for more than 20 seconds I get the same problem.


Can anyone provide some insight?  I would greatly appreciate it.  Thank you.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
William Childs Thu, 09/10/2009 - 02:10
User Badges:
  • Bronze, 100 points or more

I have set this up in my lab and got it to work with no problem. The way I understand it, you want incoming calls to ring the shared extension for 25 seconds and then go straight to the AA. I factory reset my hardware and configured it with the wizard. When I got to the page that asks who should be contacted first when a call comes in, I chose the middle option to ring extension 108 for 25 seconds and then forward to the aa. I completed the wizard and configured my phones with 108 as a shared extension on the top button and a private extension on the second button. I made the call and it rang my shared line then forwarded to the aa. I then dialed one of my extensions (the shared one -- 108) and it continued to ring until I hung up. By default shared extensions do not have a vm nor a cfwd no ans. rule. If you could post your configuration (save the web page of the 9000 and each phone) maybe we can take a closer look.


Bill


P.S. My contact list looks like (108,cfwd=aa) with the no answer delay of 25.

southamptonit Fri, 09/18/2009 - 23:14
User Badges:

Thank you Bill.  I will do a factory reset and test the system and update you with the details.  I appreciate the effort and the detailed response!

crooney29 Wed, 03/24/2010 - 10:54
User Badges:

I am trying to support a related use case and am seeing the same issue. As I understand it, the Voicemail Answer Delay on each of the individual phones is defaulted to 20 seconds. If you set up any instructions for this phone (send to AA for example) that a triggered after any period longer than 20 seconds, they will be ignored and the phone's voicemail (or the AA if no voicemail is set up for the extension) will pick up after 20 seconds, regardless.


The big outstanding question then is, how can this defauld setting of 20 seconds for the Voicemail Answer Delay be configured (either globally or on a per-extension basis)? Seem like this would address both mine and southhamptonit's problems.


Please advise,


- Chris

Actions

This Discussion

Related Content