DHCP Problems

Unanswered Question
Sep 9th, 2009
User Badges:

Hi all,

I have a Catalyst 3560 with a 12.4 ipservices image, in which I configured DHCP server for a data vlan and a voice vlan. the configuration is:

ip dhcp pool <pool name>

network 10.0.0.0 255.0.0.0

default-router 10.0.0.1

Pool 1 is for data and pool 2 for voice

The interface config is

interface range FastEthernet0/1-24

switchport host

switchport access vlan 109

switchport voice vlan 209

mls qos trust dscp

The problem is when I connect a phone it gets an IP address from the data pool, not the voice pool.

What am I doing wrong or what is missing in the configuration?

Thanks


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hipohoneywell Wed, 09/09/2009 - 08:28
User Badges:

I changed the port to trunk and now is getting no Ip address at all

That is because the switch port is expecting a 802.1q tag in the ethernet frame.


Does your IP hardphone support 802.1q? You also need to tell the trunk port, what the native VLAN is, i.e which vlan should the switch place all un-tagged frames into.


I would suggest you find out what the SIP phones can do before you make config changes.

mahmoodmkl Wed, 09/09/2009 - 08:07
User Badges:
  • Gold, 750 points or more

Hi,


I dnot see the pool for voice..?


Can u paste the config.


Thanks

Mahmood

hipohoneywell Wed, 09/09/2009 - 08:11
User Badges:

ip dhcp pool 2

network 10.16.109.0 /24

default-router 10.16.109.1


mattwilsonuk Wed, 09/09/2009 - 08:19
User Badges:

option 176 ascii "TFTPSRVR=172.16.244.189,MCIPADD=172.16.104.11,MCPORT=1719,L2Q=1,L2QVLAN=109,L2QAUD,L2QSIG=3"


This option needs to be bound to your data vlan, your phone will then get this ip address and see that the L2QVLAN=109 is the voice vlan, it will release the IP address then collect a new one from the voice vlan.


This then needs to be added to the voice vlan pool


option 176 ascii "TFTPSRVR=172.16.244.189,MCIPADD=172.16.104.11,MCPORT=1719"


The other options are for the telephone controller.


The above syntax is for avaya


;-)


Cheers


Matt



mattwilsonuk Wed, 09/09/2009 - 09:57
User Badges:

try just....

option 176 ascii "L2QVLAN=109"

on the data vlan


see if this makes the phone release the ip from the data vlan and grab one form the voice vlan


What model of phone is it, do you have a controller for it?


or are you just connecting it to a remote sip provider?


The other options are to specify things like the firmware for the phone.


We use mitel which luckily uses cdp to determined its voice vlan ;-)


Matt

Actions

This Discussion