CUCM---h323---h323--pbx issue

Unanswered Question
Sep 10th, 2009
User Badges:
  • Green, 3000 points or more

I have a scenario here. Currently I have:


pbx---h323---h323--pbx works fine, no issues.


I added CUCM to equation:

CUCM---h323--h323---pbx does not work. Call gets setup, but will not connect... busy signal after a couple seconds.


If I go cucm--h323--pbx no issues .


What could I be missing in this scenario? I have allow h323 to h323 in my voip service. My dial peers work correctly.


Thanks!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Thu, 09/10/2009 - 09:47
User Badges:
  • Red, 2250 points or more

Try this on your gateway:


voice service voip

h323

h225-connect passthru



-nick

Tommer Catlin Thu, 09/10/2009 - 10:39
User Badges:
  • Green, 3000 points or more

I would, but my IOS does not have that command.


Version 12.3(14)T7


Im thinking it's an IOS issue, but I cant confirm it.

Nicholas Matthews Thu, 09/10/2009 - 09:57
User Badges:
  • Red, 2250 points or more

It's almost definitely IOS. That IOS is very old and only contains the very first code for IPIPGW (h323-h323). I would move to 12.4(20)T or later and retry this.



-nick

lawaeljnr Fri, 09/11/2009 - 07:17
User Badges:

I've just tried the TACcase instructions and it still does not work for me. my setup is CUCM->H323->H323->PBX. I can callPBX to CUCM but when i call CUCM to PBX, it rings no audio when picked up and eventually gives busy tone. What i'm i doing wrong. can you share your IP-IP GW configs?


thanks in advance

Tommer Catlin Fri, 09/11/2009 - 07:23
User Badges:
  • Green, 3000 points or more

Sounds like your gateway is configured correctly, it sounds like the codec is not working.


When you call from the PBX to CUCM, answer the IP phone and hit the "?" twice to see what codec you are using. Assume it would be G711.


Now, make a call from CUCM to the PBX and hit the "?" twice and see what the codec says.


If codecs are changing anywhere in the call legs, you will need to have transcoders setup for the H323 gateway and IP phone to use.

But it should work with straight G711.


On my gateway, its pretty basic.


Voice Service Voip

allow h323 to h323

h323


Then the dial peers to/from the PBX serial interface (T1 card) and the CUCM (IP)



lawaeljnr Fri, 09/11/2009 - 08:01
User Badges:

it's G.711 both ways but still does not work.

Do I need Outbound faststart on the gateway page on the CUCM?

on the dial peers, do I need

progress_ind setup enable 8 command?

Tommer Catlin Fri, 09/11/2009 - 08:05
User Badges:
  • Green, 3000 points or more

What version IOS is on your gateway?


I do not have any faststart on my H323 gateway.


Are you using any Loopback addresses, or going straight to the FE interface?


Also, is this QSIQ to the PBX? Could be an issue with the Display IE getting stuck.

lawaeljnr Fri, 09/11/2009 - 08:15
User Badges:

my IOS is c2801-spservicesk9-mz.124-3h

and using the FE interface directly.

and yep, it's qsiq on the GW connected to the PBX

Tommer Catlin Fri, 09/11/2009 - 08:19
User Badges:
  • Green, 3000 points or more

So you are going:


CUCM----H323----PBX correct?

Tommer Catlin Fri, 09/11/2009 - 08:40
User Badges:
  • Green, 3000 points or more

So try this:


Go CUCM----h323B---PBX


Does this work?


This is what I did to test the remote PBX first with CUCM. Then I worked on the CUCM---h323---h323--PBX.


If you can get CUCM---h323b--PBX to work, then you know it's the gateways and CUCM that have an issue.

csshenoy80 Fri, 06/10/2011 - 10:55
User Badges:

Hey Tommer,


I am facing same issue, did you find a solution for your issue. Kindly share.

Actions

This Discussion