Unable to set ASA interface to Full Duplex/100

Unanswered Question
Sep 10th, 2009

I have an ASA 5510 it connects to a 2950 switch. I am trying to hard-code the speed and duplex on the ASA interface to 100 speed and full duplex but when I do, the ASA disconnects from the network.

I have the switchport port to 100/full hard-coded. So both ends are the same but still no luck.

I've also configured the switch port to auto/auto and the ASA to hard-coded 100/full and no goal.

The ASA disconnects and it shows as down/down.

I have to put the ASA to auto/auto and it fixes the problem.

Any known issues why I can't get the 2 devices to properly connect when I set both ends to the same hard-code 100/full?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)
Loading.
ktwaddell Fri, 09/11/2009 - 07:10

Sounds like a mis-match of speeds!

When you set both side to auto, what speed and duplex are you getting?

insccisco Fri, 09/11/2009 - 07:25

Currently, I have both sides set to auto and the speed and duplex are 100full on both end.

this is seriuos stuff... again, when I manually set both ends at 100full, it does not work.

My switch is a 2950. I've read that there might be cases where some settings on the switch ports are turned on by default and these might affect or conflict when the switch ports connects to an ASA. For example, the channeling, the trunk mode, etc., are features that might be on by default on a switchport.

any help

Collin Clark Fri, 09/11/2009 - 07:39

Can you post the conf of the switch interface? Also turn your logging on the switch to debug, then configure both to 100/full, and then connect the cable and post the log.

ktwaddell Fri, 09/11/2009 - 07:41

Yeah we do need to see the config, but if both ends are connecting at 100mb full duplex -auto, then you aren't gaining anything by hard setting it anyway.

insccisco Fri, 09/11/2009 - 08:32

you're right, but then you get that itching thing that when something is supposed to work and it doesnt... plus, it is always better to hard-code those things anyway, I believe you do gain some speed (in terms of seconds)...

here's the port config:

interface FastEthernet0/16

switchport mode trunk

spanning-tree portfast trunk

end

here's the sh ver:

3#sh ver

Cisco Internetwork Operating System Software

IOS (tm) C2950 Software (C2950-I6Q4L2-M), Version 12.1(22)EA4, RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2005 by cisco Systems, Inc.

Compiled Wed 23-Mar-05 15:33 by yenanh

Image text-base: 0x80010000, data-base: 0x80562000

ROM: Bootstrap program is C2950 boot loader

INSC2950-03 uptime is 51 weeks, 1 day, 16 hours, 44 minutes

System returned to ROM by power-on

System image file is "flash:/c2950-i6q4l2-mz.121-22.EA4.bin"

cisco WS-C2950SX-24 (RC32300) processor (revision L0) with 21039K bytes of memor y.

Processor board ID FHK0937W0M9

Last reset from system-reset

Running Standard Image

24 FastEthernet/IEEE 802.3 interface(s)

2 Gigabit Ethernet/IEEE 802.3 interface(s)

32K bytes of flash-simulated non-volatile configuration memory.

Base ethernet MAC Address: 00:15:63:8C:C3:C0

Motherboard assembly number: 73-8135-07

Power supply part number: 34-0965-01

Motherboard serial number: FOC09370NRP

Power supply serial number: DAB0924BQTM

Model revision number: L0

Motherboard revision number: A0

Model number: WS-C2950SX-24

System serial number: FHK0937W0M9

Configuration register is 0xF

The port is now setup as a trunk as I had to create sub-interfaces on the ASA.

For the logging part, this is what I have on the switch:

logging buffered 512000 debugging

I think I had the console up when I was doing this last night and every time it was failing, nothing was coming up on the switch... no logs... but perhaps I need to increase the logging, I don't know... HELP

Collin Clark Fri, 09/11/2009 - 12:10

Your logging looks OK, but you should have seen some entries on why it was not connecting. Have you enabled logging as well (logging enable)?

insccisco Wed, 12/09/2009 - 11:11

I never got or found a definite answer. I gave up and kept them to auto.

Since, didnt have the time to troubleshoot any longer as it is a production environment.

There has to be an answer though. The other day, I was presented with the same scenarion, and I was remotely doing the work, so in order to be on the safe side, I didnt even bother to follow best practices (hard coding the ports) and kept the asa and the 2950 switch on auto

didnt really want to risk it

mkkeyan Fri, 12/11/2009 - 02:11

Check with cross over cable or straight cable ,if your using cross over. pl check in  non production hour ,it should be ok .

-MK

mkkeyan beat me to this response, but further details might help..

Setting the port to "Auto" will also set the "Cable detection" for MDI or MDIx (straight through or cross-over cables)

Setting the ports to 100 and Full will NOT enable this feature, so you MUST have a correct cable attached between switch and ASA.

Straight through cables are usually used from Workstation/Server/Router to switches.

Cross-over cables are usually used from Switch to Switch connections.

The article below does a good job describing the pin-outs and reasons for these different cables:

http://en.wikipedia.org/wiki/Ethernet_crossover_cable

Actions

This Discussion