How to resolve the ISP DNS from L2 switch?

Unanswered Question
Sep 11th, 2009

How to resolve the service provider DNS from L2 switch.

Find the detailed scenario in attached network diagram with router and switch configurations.

The network is-

Internet-Service Provider Modem-Cisco router-Cisco switch-pc/desktop

with this setup we are able to ping the network of

1. Service provider(LAN & WAN IPs-123.*.*.* &

2. External DNS (202.*.*.*) from pc/desktop( entered static IP with static Service provider DNS in TCP/IP properties)

but if i browse the from desktop , showing DNS error and not opened.From this same dektop we are able to ping the public IP of

why this PC/desktop can't resolved the DNS or not able to access the internet?

If i ping from cisco router( to, the DNS was resolved and ping response is also OK,

but if i ping to from cisco switch(, the DNS was not resolved & gives request time out or no ping response.

Service Provider DNS IPs are alredy added same in switch and router.

1. Which commands are require to be enter in the switch for all FE ports will be able to resolve service provider DNS? & access the internet from switch end.

2. Is it any DNS forwarding configuration required by switch? or any configuration to be update or change in current configurations? Kindly help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Jon Marshall Fri, 09/11/2009 - 01:08

Your switch is a L2 switch so it does no DNS forwarding. The switch is nothing to do with the problem you have.

Can you -

1) post the output of "ipconfig /all" from your pc/desktop

2) Try to access by IP address rather then URL in your browser and report the results.


pp1326mah Fri, 09/11/2009 - 03:40

Thanks Jon,

1. Find the attached output of ipconfig/all from PC/desktop.

2. I am able to access through its public IP address.


Jon Marshall Fri, 09/11/2009 - 02:57


Your router DNS servers are different from your PC's, is this just a typo ? ie.

router name servers -

PC name servers -

As you router can resolve DNS names i suggest you update the client and test again.


pp1326mah Fri, 09/11/2009 - 04:28

Thanks Jon,

I had updated same as per routers and switch DNS in PC/desktop, still problem is same.

Able to ping from PC/desktop and browse to through IP but not ping and browse via name through PC/desktop.

Jon Marshall Fri, 09/11/2009 - 06:21


Just to clarify where we are

1) You can ping the IP of google AND from the router ?

2) From the desktop you can ping the IP of google and you can ping the DNS servers but you cannot ping ?

If so can you

1) on the desktop in a dos prompt can you type

"nslookup" and post the result

2) post a "traceroute " from the desktop


pp1326mah Sat, 09/12/2009 - 01:41


Pls find the result of nslookup and traceroute from PC'desktop end.

1. nslookup:


DNS request timed out.

timeout was 2 seconds.

*** Can't find server name for address Timed out

DNS request timed out.

timeout was 2 seconds.

*** Can't find server name for address Timed out

*** Default servers are not available

Default Server: UnKnown


2. Traceroute:


Tracing route to over a maximum of 30 hops

1 20 ms <1 ms <1 ms

2 <1 ms <1 ms <1 ms

3 28 ms 27 ms 29 ms

4 26 ms 26 ms 25 ms

5 39 ms 28 ms 29 ms

6 27 ms 28 ms 27 ms

7 216 ms 215 ms 217 ms

8 227 ms 229 ms 238 ms

9 226 ms 226 ms 226 ms

10 226 ms 226 ms 227 ms

11 235 ms 231 ms 232 ms

12 235 ms 234 ms 234 ms

13 232 ms 232 ms 234 ms

14 233 ms 232 ms 233 ms

15 233 ms 234 ms 233 ms

16 247 ms 253 ms 248 ms

17 247 ms 247 ms 248 ms

18 258 ms 257 ms 252 ms

19 248 ms 249 ms 250 ms

Trace complete.

malaradi83 Fri, 09/11/2009 - 12:47


i don't see any problem with you config just verify this tips:

1-if ip routing enable on your switch please add default route pointing to your router inside interface.

2-make sure port F0/24 on the switch is dot1q encapsulation insted of ISL.

3-Vlan 100 is created on the switch if you issue show vlan bri

4-PC gateway is your router not switch.

5-try other static DNS on your PC like or

please let me know how is going with you.

pp1326mah Sat, 09/12/2009 - 01:52

1. FYI.ip routing not worked in L2 switch

2. Yes: F0/24 switch dot1q encapsulation

3. I had added PC gateway as a router ip instaed of switch

4. Mentioned DNS also tried.

But problem is same as it is:

1. is not ping from pc/desktop end, but ip of ping resolved from router but not switch.

2. Instead of, ip works in browser to open

Still i am in same issue phase,Why L2 switch or ethernet ports not resolved public DNS? Give your valuable suggestion.

malaradi83 Sat, 09/12/2009 - 07:01


can you please try to connect you PC directly to your router and static your DNS on you PC and let me know what you get.


This Discussion