Unable to receive direct incoming calls when in SRST mode

Answered Question
Sep 11th, 2009

Hi there - I have an issue relating to my 2851 when in SRST mode. I am able to make outgoing calls with no issues. However if I dial a number at the site I am presented with a dial tone and not a phone ringing. During this dial tone if I dial the 4 digit extension the SRST phone at the site rings.

I'm grateful for any suggestions. Config and debug isdn Q931 below.

Note all works OK when the gateway can see the CUCM server.

=========================================

VG04_2851_LAB#sh run

Building configuration...

Current configuration : 2347 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VG04_2851_LAB

!

boot-start-marker

boot-end-marker

!

card type e1 0 0

logging buffered 4096 informational

logging console informational

logging monitor informational

!

no aaa new-model

!

resource policy

!

network-clock-participate wic 0

network-clock-select 1 E1 0/0/0

ip subnet-zero

!

!

ip cef

!

!

ip host CUCM6-Publisher 10.60.5.10

isdn switch-type primary-net5

!

voice-card 0

no dspfarm

!

!

voice call send-alert

voice rtp send-recv

!

!

!

!

!

!

!

!

!

!

!

application

global

service alternate Default

!

!

!

!

username <removed for privacy>

!

!

controller E1 0/0/0

pri-group timeslots 1-31 service mgcp

!

!

!

interface GigabitEthernet0/0

ip address 10.60.5.23 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.60.5.1

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:15

!

ccm-manager fallback-mgcp

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.60.5.10

ccm-manager config

!

mgcp

mgcp call-agent CUCM6-Publisher 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

dial-peer voice 1 pots

destination-pattern 9T

port 0/0/0:15

!

dial-peer voice 2 pots

destination-pattern 02032061...

incoming called-number .

direct-inward-dial

!

!

!

call-manager-fallback

max-conferences 8 gain -6

limit-dn 7960 2

ip source-address 10.60.5.23 port 2000 strict-match

max-ephones 3

max-dn 6 dual-line

dialplan-pattern 1 02032061... extension-length 4 extension-pattern 1...

keepalive 20

!

!

line con 0

login local

line aux 0

line vty 0 4

login local

!

scheduler allocate 20000 1000

!

end

VG04_2851_LAB#

=========================================

incoming debug ISDN Q931

*Sep 11 13:04:22.231: %ISDN-6-CONNECT: Interface Serial0/0/0:0 is now connected

to N/A N/A

*Sep 11 13:04:30.067: %ISDN-6-DISCONNECT: Interface Serial0/0/0:0 disconnected

from unknown , call lasted 7 seconds

=========================================

Outgoing debug ISDN Q931

*Sep 11 13:05:45.635: %ISDN-6-CONNECT: Interface Serial0/0/0:30 is now connected

to <removed for privacy>118 N/A

*Sep 11 13:05:48.307: %ISDN-6-DISCONNECT: Interface Serial0/0/0:30 disconnected

from <removed for privacy>118 , call lasted 2 seconds

=========================================

Thanks again for your help.

Best Regards,

Alfie

I have this problem too.
0 votes
Correct Answer by scott.searle about 7 years 2 months ago

I would recommend that you use voice translation rules for digit manipultaion and remove the dialplan-pattern command from your SRST configuration, as this has an affect on both outbound and inbound calls.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Kenneth Mohammed Fri, 09/11/2009 - 04:37

Hello,

Under dial-peer voice 2 pots enter the following:

port 0/0/0:15

Hope that helped, if so please rate.

alfiesummers Fri, 09/11/2009 - 05:30

Hi Kenneth,

Thanks for the swift response. I added the port as requested

dial-peer voice 2 pots

destination-pattern 02032061...

incoming called-number .

direct-inward-dial

port 0/0/0:15

!

Unfortunately this did not work. Now when dialing there is an unobtainable tone and no Q931 info being displayed.

Best Regards,

Alfie

Kenneth Mohammed Fri, 09/11/2009 - 04:47

This is most likely a dial-peer problem. issue debug voip dialpeer and see which dialpeer the call is hitting. Also, how many digits is telco sending on incoming calls?

alfiesummers Mon, 09/14/2009 - 04:28

Hello Again,

I have debugged as requested but get no output!!!

The Telco has confirmed they are sending six digits. In light of this I have amended dial-peer 2 to read;

dial-peer voice 2 pots

incoming called-number 061...

direct-inward-dial

for a number 020320617XX

debugging is as follows with term mon;

The following ISDN debugs are enabled on all DSLs:

debug isdn error is ON.

debug isdn q931 is ON. (filter is OFF)

DIALPEER:

debug voip dialpeer error call is ON (filter is OFF)

debug voip dialpeer error software is ON

debug voip dialpeer inout is ON (filter is OFF)

CCAPI:

debug voip ccapi inout is ON (filter is OFF)

=============================

Now getting an unreachable tone when dialing and no debug output.

Getting frustrating now so appreciate your help.

Regards,

Alfie

Kenneth Mohammed Mon, 09/14/2009 - 04:36

Hello,

Whether or not the call completes, you should get some debug output when the call completes if you have "term mon" on. I know this seems obvious, but please check to make sure that your PRI is indeed up.

alfiesummers Mon, 09/14/2009 - 04:43

Hi again,

ISDN is up and have verified for sanity by dialing in when there is a call going out. Output is below.

The following ISDN debugs are enabled on all DSLs:

debug isdn error is ON.

debug isdn q931 is ON. (filter is OFF)

VG04_2851_LAB#

*Sep 14 12:37:58.485: %ISDN-6-CONNECT: Interface Serial0/0/0:30 is now connected

to 123 N/A

*Sep 14 12:38:04.461: %ISDN-6-CONNECT: Interface Serial0/0/0:0 is now connected

to N/A N/A

*Sep 14 12:38:08.937: %ISDN-6-DISCONNECT: Interface Serial0/0/0:0 disconnected

from unknown , call lasted 4 secondsconf t

Enter configuration commands, one per line. End with CNTL/Z.

VG04_2851_LAB(config)#dial-peer voice 2 pots

VG04_2851_LAB(config-dial-peer)#incoming called-number 061...

VG04_2851_LAB(config-dial-peer)#direct-inward-dial

VG04_2851_LAB(config-dial-peer)#^Z

VG04_2851_LAB#

*Sep 14 12:39:01.509: %SYS-5-CONFIG_I: Configured from console by ksfadmin on vt

y0 (10.56.45.51)

*Sep 14 12:39:22.221: %ISDN-6-DISCONNECT: Interface Serial0/0/0:30 disconnected

from 123 , call lasted 83 seconds

--------------------

Still the same issue if I remove the incoming dial peer I'm presented with the dial tone. Then I dial the 4 digit ext and am put through.

Kenneth Mohammed Mon, 09/14/2009 - 05:02

If telco is sending you 6 digits and your extensions are 4 digits, you may try translating the 6 digits to 4. Example

voice translation-rule 1

rule 1 /^061.../ /1.../

voice translation-profile TEST

translate called 1

dial-peer voice 2 pots

destination-pattern 061...

translation-profile incoming TEST

incoming called-number .

direct-inward-dial

Hope that helped, if so please rate

alfiesummers Mon, 09/14/2009 - 05:17

Hi appreciate your swift responses.

I had to amend the translation rule to

voice translation-rule 1

rule 1 /^061.../ /1702/

purely as my router did not like me adding the final ... as you suggested.

Still no answer when dialing 02032061702. However unlike previously when I just got a reorder tone, I now get the dial tone as previously.

Thanks again for your help.

Alfie

Kenneth Mohammed Mon, 09/14/2009 - 06:23

Try removing the dialplan-pattern statement from under call-manager-fallback and try again. Sorry for all the back and forth, Im not an expert in SRST but am curious about the issue.

alfiesummers Mon, 09/14/2009 - 06:35

Hi Kenneth - Don't worry about the back and forth. To be honest I'm grateful for the help.

I removed the statement but have the same issue. Can dial out but get a dial tone when calling in before placing the 4 digit ext and getting connected.

Has to be a DID/dial-peer issue but this one is eluding me!! I found this doc if you are interested.Halfway down page two describes this behaviour exactly. However I cannot get it working. I am a routing/switching guy and relatively new to VoIP.

Best Regards,

Alfie

Kenneth Mohammed Mon, 09/14/2009 - 08:06

Try removing the translation-profile from the dial-peer and add underneath voice-port 0/0/0:15. Remove destination-pattern from dial peer and just have incoming called-number .

Hope that helped if so please rate.

scott.searle Wed, 09/16/2009 - 12:21

I would recommend that you use voice translation rules for digit manipultaion and remove the dialplan-pattern command from your SRST configuration, as this has an affect on both outbound and inbound calls.

sysjes Tue, 09/15/2009 - 19:32

try this:

logging monitor debug

or

logging buffered 1000000 debug

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 2 pots

destination-pattern 9T

port 0/0/0:15

alfiesummers Wed, 09/16/2009 - 01:03

Hi all - Still not working I am afraid. Same issue when I amend the dial peers I can call out but get an unobtainable when dialing in! As soon as I restore the link to CUCM I am able to dial in so must be a local dial-peer issue.

CUCM is configured with significant digits of 4 if this helps in relation to incoming calls.

minghui.qi Wed, 09/16/2009 - 01:54

have u got translation rules on your voice port 0/0/1:15, or whatever that port number is??

u might need to configure the tranlation rules to translate from the full number to the 4 digit number. then apply that rule under the voice port, probably not under dial peer...

Correct Answer
scott.searle Wed, 09/16/2009 - 12:22

I would recommend that you use voice translation rules for digit manipultaion and remove the dialplan-pattern command from your SRST configuration, as this has an affect on both outbound and inbound calls.

alfiesummers Fri, 09/18/2009 - 01:46

Hello and thanks to all. I finally cracked this. The telco confirmed they are presenting 6 digits. This equated to 0617XX hitting the gateway, internally we use 17XX.

As such I added the following command for translation with these dial peers.

num-exp 0617.. 17.. in global conf mode.

dial-peer voice 2 pots

destination-pattern 9T

port 0/0/0:15

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

port 0/0/0:15

All works A-OK now.

Actions

This Discussion