SPA2102: No outgoing calls on Line 1 but Line 2 ok

Unanswered Question
Sep 12th, 2009

Please bear with me, I bought this unit to replace the PAP2 because I need a Fax line. I have 2 phone numbers both connected to the FXS ports. Internet>Router>spa2102>Phone and Fax. The router in spa2102 is in bridge mode. I setup Line 1 to be used mostly for voice calls and Line 2 for FAX calls. Line 1 and 2 configs are attached.

Basically, both phone numbers work in Line 2 (including FAX). However in Line 1 only the inbound calls work. Outbound calls do not work. When I dial a number, it goes busy immediately. I tried various configs and countless suggestions from the VOIP provider to no avail.

Interestingly, both phone  numbers work in Line 1 and 2 of the PAP2 except the fax transmission only works maybe 50% of the time.

Please help.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
David Hornstein Sun, 09/13/2009 - 10:26

Hi Dina,

I have never had much luck when i tried to use the SPA2102 as a router. (Routing between the internet port and the LAN port.)

Like it's bigger brother,  the SPA9000,  I only connect a CAT5 cable to the (blue) internet port never the LAN port.  I just ignore the LAN port.

In terms of bridging mode, i always leave it in router mode and allow the internet port to accespt a IP address via DHCP, then just fix the unit in my network. It that a best practice, maybe at least i know where the unit is on my network rather than having to use the IVR system to find the IP address of the 2102.

Are you using the latest software version 5.2.10  ?

it is available from the folowing location;

So please try the following three steps please, and reply with an answer to step 4 ;

1.  Put the unit back into router mode

2.  only connect the SPA2102 to the LAN via the internet (BLUE) port.

3.  Verify you are using the most current version of code.

4.  What is the model number  and make of the WAN router  that connects you to the internet ?

So if these  three steps 1 to 3,   does not resolve your issue we could try and see what is happening is to the SIP calls initiated by line 1.

We can do this by initiating a  SIP debugging from the SPA2102 line 1 tab;

5.  to enable the SIP debug for  'line 1'   goto the  line 1 tab and set "SIP Debug Option"  from 'none' to 'full'

6. . Under the system tab , set a IP address of a debug server and syslog server to that of  your PC.

This debug server software is usually a freeware syslog server software that you can add to your PC.

Hopefully you should find plenty of freeware Syslog servers available via a google, bing  or yahoo seach .

There is i believe a native syslog server in most PC's, here is a link that may assist you in collecting information via syslog and enabling the native syslog service.

The syslog server will record with timestamps, hopefully to a file,  the SIP messages coming in and out of the SPA2102 line 1 interface.

Only capture activity on Line 1 at this stage please.  The reason for me humbly requesting limiting the syslog capture is that these syslog captures can be volumous

and all i really want to see is only a plain old telephone on line 1 making a call.

Copy the resulting capture from the syslog server here and i'll take a  quick look.

regards Dave

dinasand1 Mon, 09/14/2009 - 17:50

Thanks, Dave.

I did all what you said. Upgraded the firmware as well. But no change.

Then I went back to my VOIP provider and we tried several settings again- no change.

Then they said to try setting "SIP Remote-Party ID: No" instead of yes which is the default setting.

And it worked. :)



This Discussion