cisco deny operation 2960 switch

Unanswered Question
Sep 13th, 2009
User Badges:

hello

i have wonderfull problem:

we have about 40, ws-c2960-24tc-l switch. and we changed ios of all switches to "c2960-lanbasek9-mz.122-s0.SE1.bin" after few days about 30 of these switches become none operational and when you want to loggin it says:"%ILET-1-AUTHENTICATION_FAIL: this switch may not have been manufactured by cisco or with cisco's authorization.this product may contain software that was copied in violation of cisco's license terms.if your use of this product is the cause of a support issue,cisco may deny operation of the product,support under your warranty or under a cisco technical support program such as smartnet. please contact cisco's technical assistance center for more information",but some of switches still work with this ios,what is problem?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Sun, 09/13/2009 - 03:55
User Badges:
  • Cisco Employee,

Hello,


The IOS name you indicated probably contains a typo - is it the c2960-lanbasek9-mz.122-50.SE1.bin?


Nevertheless, this is a serious problem. I am not sure about its cause but the error message is explanatory here: the IOS thinks that it runs on non-genuine hardware. To my knowledge, the C2960-24TC-L does not use any special license files. Thus, I do not see any alternative except contacting your Cisco support and/or contacting the TAC.


Does a downgrade of the software solve the issue? Also, does the message appear even after reloading the switch?


Best regards,

Peter


a7_seven7 Sun, 09/13/2009 - 10:19
User Badges:

yes, ios is "c2960-lanbasek9-mz.122-50.SE1.bin",always when you reload these switches this message will be appeared and amber light will be on after complete hardware test. switch is not operational so it is not possible to change IOS.

because some of the switches with this ios still working fine, i want to sure is this message because of non genuine hardware?

i dont have access to cisco support or TAC. please if it is possible for you, tell me the exactly what is the problem?

if you want, i can send you output of sh version command.

thank you very much for your answer( i am in hard presure from my company to find out the cause of problem)

adamclarkuk_2 Sun, 09/13/2009 - 10:34
User Badges:
  • Silver, 250 points or more

You should be able to downgrade the IOS as suggested by attaching a console cable to the switches and hitting the break sequence, list of break sequences below :-


http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a0080174a34.shtml


You can then use rommon mode either boot another IOS.


* Dont forgot run these commands once in ROMMON


flash_init

load_helper

Peter Paluch Sun, 09/13/2009 - 11:06
User Badges:
  • Cisco Employee,

Hello,


I agree completely with Adam. While the IOS may refuse to work, the boot mode of the switch should still be available and you should be able to downgrade the IOS in the FLASH using the xmodem transfer.


I don't know what could be the cause of your problem. I assume that it is beyond question that your 2960 switches are indeed fake. This could also be an IOS bug. In any case, I would try to contact your supplier that has supplied you with these switches and try to confirm that the devices are indeed genuine (you could also have a look on the original packaging if you still have it), or even talk to the Cisco office representatives in your country to find a way of investigating and solving this issue. After all, it's in their interest that if the switches are genuine that they work with the new IOS.


Best regards,

Peter


Leo Laohoo Sun, 09/13/2009 - 15:02
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

I've heard of fake Cisco parts but never a complete appliance. And I've never seen this fault being reported to regarding the 12.2(50) IOS.


Do you know where you got your IOS from?


I'm currently using 12.2(46) all across my network.

Peter Paluch Sun, 09/13/2009 - 15:27
User Badges:
  • Cisco Employee,

Hi Leo,


Yes, cheap (and workable! :) SFP modules, for example, can be quite common, and as far as I know, there even is a way to force the Cisco box use them despite not being genuine. But selling an entire switch that looks like Cat2960 and being fake? I haven't heard of something like that before.


This is interesting. Seven, keep us posted!


Best regards,

Peter


Leo Laohoo Sun, 09/13/2009 - 16:16
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Hi Peter,

I've used the non-Cisco branded SFP successfully in the past.


If this is indeed a fake Cisco appliance, there could be a serious repercussions against the dealer for sure. Because of this, I hope the original Delivery Receipt or Purchase Order is still available as the dealer will be bending-over-backwards just to clear their name. Seven might even consider raising a TAC Case and escalate it because without up/downgrading the IOS, the appliance is now an expensive door jam.


I would also like to know where Seven got his IOS. Did he download it directly from Cisco or did the dealer provide him with a copy?


However, I can't wait to find out if an IOS bug could be at fault either. But if I see that error message myself, I'd have a heart attack.

a7_seven7 Sun, 09/13/2009 - 20:36
User Badges:

hi friends

i download this IOS directly from cisco site. now this ios is run on all of our 2960 switches. most of these switches have problem and amber light is on and switch is not operational. but still about ten of these switches with this ios work fine. my main problem is find out why this happen? why some of my switches works but some of them not work.i saw in cisco that for 2960 switches there is no license for ios.is this because of switches are not orginal?

i can try later to use xmodem but in the first step my company wants to know why this happen.if you think sh ver information can help you to determine the problem i can send it

Leo Laohoo Sun, 09/13/2009 - 23:20
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Hi Seven,


Only the 3560-E and 3750-E requires the license file. The 2960 doesn't require one at all.


I would recommend that you contact your authorized vendor and let them know what is going on. At the same time, raise a TAC case to back up your claim.


Hope this helps.

a7_seven7 Sun, 09/13/2009 - 23:51
User Badges:

hi leo

i dont have access to TAC.contact with authorized vendor need to buy support service and we have only support from seller. i am not sure devices are orginal but they said to my boss these devices are original and problem occured because of changing ios. i am sure that ios i used is original because i download it from cisco site directly.

my boss wants to know why this happen?

how can i findout these product is original? now we dont have access to switch package. what information you need to findout these devices are original or no?

i have sh ver information. i heard about some of my friend that some kind of china devices are in the market.

i cant satisfy company to buy support service. i am in the presure to find out why this happpen. and they want evidence, but i think in the first step, i must find a solution to check these device is original or no. i cant trust to seller.

kyle woodhouse Fri, 07/02/2010 - 06:56
User Badges:

I have seen this problem happen on some 2960 switches as well as some 3750E model switches (3750E only, not the regular 3750 or 3750G).  The error message looks like this after you upgrade the IOS:


%ILET-1-AUTHENTICATION_FAIL: This Switch may not have been manufactured by Cisco or with Cisco's authorization. This product may contain software that was copied in violation of Cisco's license terms. If your use of this product is the cause of a support issue, Cisco may deny operation of the product, support under your warranty or under a Cisco technical support program such as Smartnet. Please contact Cisco's Technical Assistance Center for more information.


The error occurs after updating to 12.2(50) or above.  12.2(52) and 12.2(53) produce the error as well.  Downgrading back to an image below 12.2(50) such as 12.2(46) or 12.2(44) do not make the error go away.  Formatting flash, clearing rommon variables, resetting rommon to gold, etc etc, it wont go away once it comes up.  This problem is very rare and seems to be related to some batches of 2960's but it hasnt been narrowed down to any particular serial number range or anything yet to my knowledge.


Recently Cisco has made a Bug ID CSCtb12181 for the issue.  Details are here:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCtb12181



%ILET-1-AUTHENTICATION_FAIL : Error message Symptom:
Switch reports the following error after an upgrade to an image version 12.2(44)SE crypto or above :
%ILET-1-AUTHENTICATION_FAIL: This Switch may not have been manufactured by Cisco or with Cisco's authorization. This product may contain software that was copied in violation of Cisco's license terms. If your use of this product is the cause of a support issue, Cisco may deny operation of the product, support under your warranty or under a Cisco technical support program such as Smartnet. Please contact Cisco's Technical Assistance Center for more information.

Conditions:
IOS upgrade to IOS version 12.2(44)SE crypto or above

Workaround:
Currently no workaround.



If anyone finds a way to fix the issue or finds a particular software image that fixes the problem please post it or let me know.  Thanks guys,

Mark Bowyer Wed, 02/02/2011 - 03:32
User Badges:

Did anybody find a fix for this? or know of a way around it?or has it been narrowed down to a particular range of serial numbers yet?

dansken82 Sun, 09/25/2011 - 06:06
User Badges:

Did anyone find a solution to this problem? I have a 3750E, that was running fine with 12.2(46) universalk9, and a permanent ipbase license, after upgrading to 15.0(1) universalk9, I got this problem, and now the ibase license is gone.

Downgrading to 12.2(46) didn't resolve the issue.

kyle woodhouse Tue, 09/27/2011 - 14:03
User Badges:

Hi Dansken, No fix or further details or updates then what i provided above on my part.  If you do a TAC case let me know the out come.  As far as i know once the error comes up the unit needs to be RMA'd and there is no fix.  Seen it happen on a wide range of units from multiple sources including the Cisco Channel.  I update all units once we take them out of the box and RMA the ones that fail now because of this issue.  Best of luck. 

rosenhan Mon, 04/13/2015 - 14:26
User Badges:

Had the exact same problem, removed the non-Cisco GLC-T that was in port 51 on the switch, rebooted and viola!  The switch came up and worked fine.

The issue was the non-Cisco branded SFP that was causing the error.  Funny thing is, I waited for it to boot, then put the SFP back into the port and it works fine.  But if the SFP is still in the switch when you boot up, this error will pop up and the switch won't work.  

This is a very big problem.  I understand Cisco wanting to corner the market with their approved SFP's that have a pretty substantial markup, but making the switch unworkable if it see's a non-Cisoc SFP in a slot is just ridiculous.

Just my opinion here, nothing more :)

 

Edited********

 

One other item I just figured out is the "service unsupported-transceiver" command will work in the 15.x code.  Once I put this command into the switch, it will reboot with the non-Cisco SFP still in its slot and come up fine.  Cisco does not recommend this, and they won't support the SFP (for obvious reasons).

Figured I would let you know what I found.

Good Luck!

 

 

 

Actions

This Discussion