CS Discovery problems

Answered Question
Sep 13th, 2009
User Badges:

Today (14Sept) the menus in the Device Center are missing a number of the reports etc. that we normally see, relating to ports, User tracking etc. The only problem that appears to have occured over the weekend is a CSDiscovery failure. Attached are the log files indicated in the error message.



Correct Answer by Joe Clarke about 7 years 6 months ago

Make sure your Data Collection filters allow for these devices to be managed under Campus Manager > ADministration > Data Collection > Mode and Policy Settings, then run a new Campus Data Collection.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Joe Clarke Sun, 09/13/2009 - 18:39
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Discovery has nothing to do with the options that show up in Device Center. These depend on the applications installed and the applications managing the device in question.


Was the hostname recently changed on this server? Are all devices missing the same menu options? Post a screenshot of the Device Center illustrating the problem. Also, post the NMSROOT/lib/classpath/md.properties, and the output of the DOS SET command.

marshajr Sun, 09/13/2009 - 19:02
User Badges:

Attached are the requested files.



1. hostname has never changed on this server.


2. as far as I can determine the menu options are the same for each device (we have approx 600 devices!).


3. Should I be worried about the previously posted log errors?



Attachment: 
Joe Clarke Sun, 09/13/2009 - 19:48
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This doesn't look problematic. It just looks like the device being displayed is not managed by Campus Manager (per the Managing Applications list). All the tasks for RME and DFM are showing up.


The Discovery errors aren't necessarily a bad thing unless they are reliably reproducible. In that case, it could be that a previous Discovery has hung., and you need to shutdown the CSDiscovery daemon.

marshajr Sun, 09/13/2009 - 19:55
User Badges:

It appears from the Managing Applications list that none of our devices are being managed by CM! How do we re-establish this?

Correct Answer
Joe Clarke Sun, 09/13/2009 - 20:11
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Make sure your Data Collection filters allow for these devices to be managed under Campus Manager > ADministration > Data Collection > Mode and Policy Settings, then run a new Campus Data Collection.

Actions

This Discussion