WRP400 - Inbound calls not activating

Answered Question
Sep 13th, 2009
User Badges:

Outbound calling works fine.
When I receive an inbound call, the phone rings, but when I pick up the phone, the conversation does not get established.

This seems like a routing or firewalling issue, but so far I have not found the solution.
I am connected to a cable ISP: the WRP400 gets the public IP address, but I could not find any routing/firewalling setting for the voice part.

A friend lent me a SPA-2012, and, with a totally similar configuration, inbound calls work on it. Also: incoming calls work on a softphone that I run on a computer in my local network.

I have tried to give back the router, assuming that it was defective, but even the new one behaves the same.

Can anybody help me, or point me to a previous thread where this issue was discussed and solved?

Thanks in advance.



PS: The firmware is 1.00.04.c I have not updated it, as the Linksys site offered it only in their USA site, and not elsewhere, and it did not specify whether the new version was suitable for european users.
PS2: I am attaching a log of a phone call attempt and the configuration of my VOIP part of the router.

Correct Answer by andreaszzz about 7 years 5 months ago

Hi,


I solved the problem together with the customer support of sipcall.


The solution was setting the "FAX Process NSE" on Line X to no.


Interestingly i had no problems on sip to sip calls. But pstn to sip didn't work.


Regards,

Andreas

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Alberto Montilla Mon, 09/14/2009 - 07:13
User Badges:
  • Cisco Employee,

Dear Sir;


First of all, I suggest you update the firmware to the latest version. You can download the firmware there. For Europe, please use the ETSI version.

http://www.cisco.com/en/US/prod/voicesw/ps6790/gatecont/ps10024/ps10028/WRP400_1_01_00_Firmware.zip


Try again, and if you continue with the issue, please gather the traces and send it back to us, will have a look to it.


Regards

Alberto

ur17-cisco Mon, 09/21/2009 - 01:33
User Badges:

Hi Alberto,

As you suggested, I have updated the firmware.

Unfortunately the issue is still there.

Please see the enclosed attachments: the log and the conf.

Cordially,

Filippo

ur17-cisco Tue, 10/13/2009 - 09:39
User Badges:

Hi,

In case it helps, I am enclosing another log file of an incoming call attempt.

So far, no matter what modifications I have attempted on the router configuration, I still cannot receive phone calls.

Is there any hope that this issue can be solved?

Attachment: 
Alberto Montilla Tue, 10/20/2009 - 10:28
User Badges:
  • Cisco Employee,

Dear Sir;


Issue seems to be on your nat mapping configuration. On Line 1 and Line 2, please set NAT Mapping Enable to NO, apply changes and reboot the device.


Please note that if problem persists I would need full SIP traces to see what the issue is. From your configuration issue seems to be on the above.

Regards
Alberto

ur17-cisco Tue, 10/20/2009 - 13:59
User Badges:

Hi Alberto,

I have tried to set NAT Mapping Enable to NO, I rebooted, but the problem persists.

Please note that the issue happens on Line 1. Line 2 does not have a DID to receive calls. Just ignore Line 2.

How can I send you the full SIP traces? So far I have put the debug level to 3, and I have caught the signals with a log software. See the .csv files that I had previously attached.

Is there anything else that I should do?

Thanks in advance,

Filippo

Alberto Montilla Mon, 10/26/2009 - 04:46
User Badges:
  • Cisco Employee,

Need to enable SIP debug on [Line 1] tab. That would include SIP traces on the syslog.


I suggest you follow the instructions available for taking syslog/debug messages on the documentation section of this community.


Regards
Alberto

Alberto Montilla Sat, 10/31/2009 - 08:27
User Badges:
  • Cisco Employee,

Dear Sir;


Looking at the traces, it seems that for some reason, the WRP400 is not receiving the RTP packets, so it ends the call. WRP400 is sending RTP packets according to the negotiation.


In order to further debug the issue, I would suggest you try restricting the codecs at the WRP400 initially to G711 only and then to G729a only, to see if outgoing and incoming calls work properly. It could be a codec negotiation issue.


Regards
Alberto

ur17-cisco Tue, 11/03/2009 - 14:03
User Badges:

Hi,

I have set the WRP400 on "Use Pref Codec Only: yes", and I have first put it on g711u and then on g729a, making and receiving calls (see the four attached logs).

And the result is the same: I can make calls, but I cannot receive.

Please note that a SPA-2012 configured in the same way as the WRP400 for the same VOIP provider would receive the  incoming calls without any problem.

Attachment: 
Patrick Born Tue, 11/10/2009 - 16:35
User Badges:
  • Cisco Employee,

Hi Filippo,


Alberto is currently on business travel. I've escalated this issue to Engineering.


Regards,



Patrick

----------

andreaszzz Tue, 11/17/2009 - 07:13
User Badges:

I have exactly the same problem on my WRP400. No incoming calls are possible, phone rings, but i hear only the busy signal.


Same settings on a FritzBox works fine. The WRP400 is directly to a cable modem and has a public ip.


I'm running the WRP400 with 2.00.05 ETSI firmware with a sipcall account in switzerland.

Alberto Montilla Sat, 11/21/2009 - 07:41
User Badges:
  • Cisco Employee,

Dear Sir;


Please try the following on the WRP400


On the [SIP] tab, please delete the following (empty)

G726r24 Dynamic Payload:

G726r16 Dynamic Payload:

G726r32 Dynamic Payload:

G726r40 Dynamic Payload:


On the Line X, please disable all G.726.


Let me know if it works, for some reason there is a missmatch on the codec number used on the server and the ATA (this is pretty standard so surprising) and it looks like for the incoming calls the WRP400 is selecting the wrong codec.


If this solution does not work, please investigate what is the packetization time the server (operator) uses (10, 20, 30 or 40 ms), a missmatch here will also cause the behavior this is showing.


Regards
Alberto

ur17-cisco Fri, 11/27/2009 - 01:13
User Badges:

Hi,


I did as you suggested:

- I emptied the field G726r32 on the SIP tab

- I disabled G.726 on the Line tab

Please note that there is only "32", and not 16, 24, 40.

I placed a call: same result, not working.


So I contacted the technical support of my VOIP provider, asking them to tell me what is the "packetization time" of their server, as you suggested. To better explain my request I put a link to this page.


This was their answer:


"I read the thread at Cisco's forum. I activated our RTP proxy for you. Please check, if the problem persists.


As I wrote in the last answer, packetization delay depends on the codec you chose for voice communication. As voice data (RTP) is exchanged peer-to-peer, that is, directly from your communication partner to you, packetization time/delay does not have an influence on the behavior of your WRP."


I placed a call: same result, still not working.


Is their answer useful to you? Should I precise the question?

Correct Answer
andreaszzz Tue, 12/01/2009 - 05:35
User Badges:

Hi,


I solved the problem together with the customer support of sipcall.


The solution was setting the "FAX Process NSE" on Line X to no.


Interestingly i had no problems on sip to sip calls. But pstn to sip didn't work.


Regards,

Andreas

Alberto Montilla Tue, 12/01/2009 - 07:31
User Badges:
  • Cisco Employee,

Hi Andreas;


Thanks for your update. Happy to see that you can now use the device to its full "voice" capability.


Regards
Alberto

ur17-cisco Thu, 12/10/2009 - 11:21
User Badges:

Hi Alberto, hi Andreas,

I can confirm that, with that setting, it works for me too.

Thanks,

Filippo

rajnivanza Sun, 02/14/2010 - 22:02
User Badges:

Hi Friends,


I have also face same problem.


Outbound calling works fine.
When I receive an inbound call, the phone rings, but when I pick up the phone, the conversation does not get established.


I have call from inside NAT extension number to Outside NAT extension ( Outbout call ) then call get estabished and two-way audio work fine

but when I have call from Outside NAT extension to Inside NAT extension (Inbound call ) then  phone rings,

but when pickup the phone, audio is not present.


During inboud call RTP packets are not transmit whereas Outboud call RTP packets transmit successful.


Sometimes, Inbound and Outbound call only one-way audio present.


Can anybody help me, or point me to a previous thread where this issue was discussed and solved?

Thanks in advance.

Actions

This Discussion