2 router ports in the same vlan

Unanswered Question
Sep 14th, 2009

I would like to set up a fault-tolerant configuration where 2 routers with 2 FE ports connect to 2 L2 switches with trunk ports.

I am thinking if the following configuration would work on the routers :

int vlan 30

ip address 10.10.30.1 255.255.255.0

int vlan 40

ip address 10.10.40.1 255.255.255.0

int fa 0/1

no ip address

int fa 0/1.30

ip unnambered vlan30

encapsulation dot1q 30

int fa 0/1.40

ip unnambered vlan40

encapsulation dot1q 40

int fa 0/2

no ip address

int fa 0/2.30

ip unnambered vlan30

encapsulation dot1q 30

int fa 0/2.40

ip unnambered vlan40

encapsulation dot1q 40

Do you this this is a valid configuration ?

Thanks,

Laszlo

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
franklaszlo Mon, 09/14/2009 - 04:59

Well, ignore the configuration I obviously have mixed up switch and router configuration commands :-(

But the question remains. How can I build a fault-tolerant configuration with two 2811 routers and two L2 switches (IBM Blade server with built-in Cisco IGSM switches),so that routers could use HSRP among eachother, and if one switch or one router fails the network would still work.

You just need to configure a trunk port on each switch that faces either router.

Then you create sub-interfaces on the routers, and tag the packets with the specific vlan number.

Then just configure your default gateway on all LAN devices as the hsrp address. Configfure witch router will be the primary and secondary.

HTH>

franklaszlo Mon, 09/14/2009 - 05:55

Yes, this is what I have been thinking on, but in my thought experiment configuration there is a problem.

I think a possible configuration on one router would be similar to this :

int fa 0/1.30

encap dot1q 30

ip address 10.10.30.2 255.255.255.0

standby 10 ip 10.10.30.1

standby 10 priority 150

standby 10 preempt

int fa 0/1.40

encap dot1q 40

ip address 10.10.40.2 255.255.255.0

standby 20 ip 10.10.40.1

standby 20 priority 150

standby 20 preempt

int fa 0/2.30

encap dot1q 30

ip address 10.10.30.3 255.255.255.0

standby 10 ip 10.10.30.1

standby 10 preempt

int fa 0/2.40

encap dot1q 40

ip address 10.10.40.3 255.255.255.0

standby 20 ip 10.10.40.1

standby 20 preempt

Now, I assume I cannot have two different sub interface belong to the same subnet, can I ?

Laszlo

franklaszlo Mon, 09/14/2009 - 06:13

Sorry, it is not clear for me.

I have two routers and two switches. If I want redundancy I need to connect both routers to both switches which requires two physical FE ports on both routers.

If I have two VLANs then I should configure two subinterfaces for both physical ports, so 4 subinterfaces in total. My probles, is that these subinterfaces' network would overlap.

I hope I was clear of what am I trying to do.

Ideally you have a trunk between the 2 switches, thus negating the need to multiple connections.

The IP subnet will NOT allow you to have multiple interfaces on the router in the same subnet = not possible.

I understand what you are trying to do - it is just not possible. To be honest I think it is over kill.

I would go for:-

RT1 RT2

|(trunk) |(trunk)

SW1 SW2

Have the layer 3 interface in vlan 30 on RT1 & RT2, and the same for vlan 40. So only 2 sub-interfaces on each router.

HTH>

franklaszlo Mon, 09/14/2009 - 07:18

Well, I also concluded so, this way is not possible, sure.

But what happens if I had a virtual interface and the subinterfaces would be brigded to that virtual (or loopback ?)interface ?

This way the subinterfaces are bridging VLAN network traffic to the L3 interface.

Is this configuration possible ? I've heared about concepts like IRB and bridge-groups. Can I not use them somehow to achieve my goal ?

Richard Burts Mon, 09/14/2009 - 07:41

Laszlo

If you really want 2 router interfaces in the same subnet (same VLAN) then IRB with the BVI as the virtual interface would allow you to do this and would be the best alternative.

You might also consider configuring one of the FastEthernet Interfaces with backup-interface pointing to the other interface. This should result in one active interface and one interface standing by. I have not configured this myself but believe that I have read posts from people saying that they got it to work. Be aware that for the backup interface to take over it is usually necessary for the primary interface to go protocol down. Be aware that there are several failure modes on the router where the FastEthernet interface will lose IP connectivity but the interface is still protocol up. So I would really not advise using the backup-interface approach.

In most circumstances the complexity of the configuration of IRB, the impact of introducing bridging onto the router interface, and the potential impact of interacting with Spanning Tree on the router interface leads many people to conclude that IRB is not worth it. They frequently just configure HSRP on a single router interface, make sure that each router connects to a different switch, and make sure that the switches are well connected/trunked and find that this level of redundancy is enough.

HTH

Rick

franklaszlo Mon, 09/14/2009 - 07:56

Thank you Rick,

I think I will take the simple HSRP approach because, as you wrote, the network complexity overhead in not worth configuring bridging.

I also agree that this level of redundancy will be enough.

Thanks,

Laszlo

Richard Burts Mon, 09/14/2009 - 08:21

Laszlo

I am glad that my suggestion pointed you in a good direction and that you agree that the level of redundancy supplied by HSRP will be enough.

Good luck in implementing this. Let us know how it turns out.

HTH

Rick

franklaszlo Mon, 09/14/2009 - 07:23

Also, what you are suggesting is just a half solution (do not misunderstand, thank you for you help anyway) because if SW1 fails and RT2 fails (rare condition, though) the network is dead, while theoritically there are enough resources to get it work, just the configuration do not allow.

Actions

This Discussion