Running two versions of code on one WiSM (one per controller)

Unanswered Question
Sep 14th, 2009

Recently it has come to my attention that Management wishes to pursue the possibility that one controller on a WiSM can run on an older version than the other controller (on the same WiSM).

Quick reasoning behind it is that our Wireless network is strictly LWAPP at the moment with close to 150x 1000 model APs deployed. Naturally this means we are stuck on version 4.2 as 5.0 and above do not support 1000 model APs, and replacing all our APs is pretty much out of the question at this time.

We also cannot use the newer APs because Cisco has started using CAPWAP now, which doesn't work on 4.2 of course.

So, this brings up a couple questions that I would like answered and verified:

1. Is it feasible/safe to run multiple software versions on the same WiSM blade, one per controller?

2. What are the downfalls of this?

3. Would I need to configure the management interfaces on both controllers to be different subnets from each other (if possible)? I would like to avoid the 1000 APs from associating to the higher version.

4. Will I need to disable LAG?

5. Which version would be recommended for the second controller?

6. I'm assuming that WCS will be able to handle both controllers, as long as the WCS is on the most recent version (to match the highest version controller). Is this correct?

That's all I can think of for now. Please add any comments/concerns that I should know about with this kind of configuration setup.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (4 ratings)
Robert.N.Barrett_2 Mon, 09/14/2009 - 11:48

This doesn't answer your question, but be aware that the only new AP that is CAPWAP only is the 1140. The other current AP's will still do LWAPP (and work fine with 4.2).

Leo Laohoo Mon, 09/14/2009 - 15:27

Why do you want to run TWO? If the question is to support the existing 1000 model APs, then run only one.

A1, A2 & A5: The "downfall" for running two different firmwares is when the APs go from one controllers to another, they have to download the IOS and reboot. This takes time. Secondly, there are some specifications 4.2 won't do that can be found in the buggy 5.0. I'd recommend you stick with 4.2. A significant number has agreed that 5.X is a lost cause. With 4.2 you may not be able to deploy 802.11n.

A4: You can't disable LAG on a WiSM.

A6: Correct. WCS has to be equal to or higher version to the WLC.

Lucien Avramov Mon, 09/14/2009 - 15:54

1. Yes technically you can, its 2 controllers in a WiSM.

4. Yes BUT be careful for one thing, it's higher version of WCS AND the release date of the WCS software must be AFTER the one for the controller.

The dates are posted next to the release notes:


Darren Ramsey Mon, 09/14/2009 - 17:44


We are doing this now, 4.2 on controller A and 6.0 on controller B, and running WCS version 6 that works with both WLC versions. Our Vocera installation requires 4.2 (Assurewave) or they won't support, and our new ED has 40 new 1142 that won't work with 4.2. The setup is not best practice and likely not supported by Cisco, but we had no choice. We have turned off AP fallback to keep the AP from flapping should they reload, and we have set the primary controller in each AP to keep them sticky to their particular controller. Had to do some tricky priming to make it all work. So far it's worked OK, both controllers are in the same mobility group and I've not heard of any roaming issues. Once 6.0 MR1 is released and Vocera supports, then we will synchronize the 2 WISM (all 4 controllers) at this particular facility to 6.0MR1.

jpeterson6 Tue, 09/15/2009 - 06:16

Thank you all for the input and responses!

The reason we may have to support 2 versions is because management is pushing for more APs but we simply do not have any 1000 models in stock, and since they're EoL we cannot purchase any through Cisco.

Management has chosen the new 1142 models, which doesn't work on 4.2.

Understood that 5.x is a lost cause. I will keep that in mind.

One more quick question:

If 5.x is a lost cause, how is 6.0 doing so far?

Leo Laohoo Tue, 09/15/2009 - 14:29

6.X is alot better than 5.X, however, due to recently discovered OTAP vulnerabilities, I'd recommend that you hold off upgrading to 6.X until a new fix/firmware has been published.


This Discussion



Trending Topics - Security & Network