Cisco Router Route of Last Resort

Unanswered Question
Sep 14th, 2009

I am testing out a Cisco 1841 Router and need to set a route of last resort. I made a static route of "ip route 0.0.0.0 0.0.0.0 172.16.48.1". Then issued the command "ip default-network 172.16.48.1". This now allows me to ping anything on the 172.16.0.0/16 network from the router. But I am not able to ping anything on the internet or outside of this network from the router. Here is my running config and routing table. What am I missing? fa0/0 is facing the network 172.16.0.0/16, and fa0/1 is facing another internal network.

Router#show run

Building configuration...

Current configuration : 925 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

no aaa new-model

ip cef

!

no ip domain lookup

multilink bundle-name authenticated

!

archive

log config

hidekeys

!

interface FastEthernet0/0

description outside LAN

ip address 172.16.50.1 255.255.240.0

duplex auto

speed auto

!

interface FastEthernet0/1

description internal LAN

ip address 10.2.3.1 255.255.254.0

duplex auto

speed auto

!

interface FastEthernet0/0/0

!

interface FastEthernet0/0/1

!

interface FastEthernet0/0/2

!

interface FastEthernet0/0/3

!

interface Vlan1

no ip address

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 172.16.48.1

ip route 172.16.0.0 255.255.0.0 172.16.48.1

!

no ip http server

!

control-plane

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

end

Router#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.48.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks

C 172.16.48.0/20 is directly connected, FastEthernet0/0

S 172.16.0.0/16 [1/0] via 172.16.48.1

S* 0.0.0.0/0 [1/0] via 172.16.48.1

Router#

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Mon, 09/14/2009 - 11:07

Probably your internet GW doesn't know anything about the addresses you're using.

Note, "ip default-network" is of no use to you.

waterboy550 Mon, 09/14/2009 - 11:42

I ran the command no ip default-network to remove this and I'm still experiencing problems. Any thoughts?

Paolo Bevilacqua Mon, 09/14/2009 - 11:57

As mentioned above. Your other routers do not know about you. Are you doing a lab or this is for business ?

Paolo Bevilacqua Mon, 09/14/2009 - 12:18

Please go back to routing 101 where it explains how each router needs to know somehow about all the networks around.

Actions

This Discussion