CER 7.01 db replication issues

Unanswered Question
Sep 14th, 2009

Hello,

My CER Publisher and subscriber are having DB replication issues. This morning got alert that subscriber was active due to db issue and then it went back to publisher server. The publisher is running fine but the CER Event log saids there is problem with database replication.

At the SSH Command Line, if I do a utils dbreplication status I get this.

admin:file view activelog er/trace/dbl/sdi/ReplicationStatus.124550.out

SERVER ID STATE STATUS QUEUE CONNECTION CHANGED

-----------------------------------------------------------------------

CER1 2 Active Local 0

CER2 3 Active Dropped 343488 Sep 14 12:42:43

I tried to reset the db replication and it isn't working. Has been sitting for a few hours.

I did a 'utils dbreplication reset' on publisher CER1 and it said it needed the subscriber nodename. So I did 'utils dbreplication reset CER2' and it said it was resetting the replication and it will take 15 minutes. It's been several hours now.

Now the 'utils dbreplication status' command saids it can't be ran because replication is in progress or disabled, or only one node in cluster, etc.

On the CER2 server if I look the the dbreplication log this is what it has in it.

admin:file view activelog er/trace/dbl/sdi/ReplicationStatus.152918.out

connect to CER2_cer failed

Enterprise Replication not active (62)

command failed -- unable to connect to server specified (5)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gogasca Mon, 09/14/2009 - 23:14

Hi Eric,

Per last error check if DNS resolution is correct,

check that CER pub and sub can resolve properly, IP, reverse lookup and hostname and fqdn,

reboot server to force replication

Otherwise we may need to get root access and verify resolv.conf and nsswitch.conf to see if we are using DNS or local files.

Open TAC case is recommended

Erick Bergquist Tue, 09/15/2009 - 06:45

I have a TAC case open on this. Waiting for them to callback. Anyway, have verified DNS back and forth (before opening TAC Case) and reset the servers.

This is error on the reset command we are getting now.

admin:utils dbreplication reset CER2

Repairing of replication is in progress.

Background repair of replication will continue after that for 15 minutes..

(sits for like 5 mins or so) then this...

PING CER2 (10.12.255.3) 56(84) bytes of data.

64 bytes from CER2 (10.12.255.3): icmp_seq=0 ttl=64 time=0.054 ms

--- CER1 ping statistics ---

1 packets transmitted, 1 received, 0% packet loss, time 0ms

rtt min/avg/max/mdev = 0.054/0.054/0.054/0.000 ms, pipe 2

PING CER2 (10.12.255.7) 56(84) bytes of data.

64 bytes from CER2 (10.12.255.7): icmp_seq=0 ttl=64 time=0.252 ms

--- CER2 ping statistics ---

1 packets transmitted, 1 received, 0% packet loss, time 0ms

rtt min/avg/max/mdev = 0.252/0.252/0.252/0.000 ms, pipe 2

IDSPORT: 1500

IFXSERVER: CER1_cer

BASEDIR: /usr/local/er

INFORMIXDIR: /usr/local/er/db/informix

XMLRPCPORT: 1515

IDSPORT_B: 1501

IDSGROUP: informix

IDSUSER: informix

IDSENV: /usr/local/er/db/informix/local/ids.env

W1SPACEDIR: /var/log

5084

CER1

CER2

Error []

admin:

Erick Bergquist Tue, 09/15/2009 - 08:26

FYI,

Got this working by rebooting subscriber, then doing a db repair command, then db reset command again (for 4th or 5th time) and it cleared up.

Actions

This Discussion