Nexus 5020 and 1Gbps connections

Unanswered Question
Sep 15th, 2009
User Badges:

Hi


I'm having problems connecting 1Gbps interfaces (just a simple autonegotiating 1 Gbps Laptop) direct to a Nexus 5020 port. I'm using a GLC-T in one of the ports that supports 1 Gbps (ports 1-16), and I've configured the speed to 1000.


The link tries to come up for a fraction of a second (by looking at the laptop port)then drops.


I've tried several ports and a couple of different GLC-T SFPs, and I'm using the latest software (n5000-uk9.4.1.3.N1.1.bin). I've even tried fixing negotiation, using a crossover cable, but no luck. Does anyone have any suggestions or know if this is a known problem?


Thanks

Darryll




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Yudong Wu Tue, 09/15/2009 - 11:59
User Badges:
  • Gold, 750 points or more

can you post the following when the link is in down state?

show interface x/y

show interface x/y trans

show system internal ethpm event-history errors | grep x/y



darryll.plumb Tue, 09/15/2009 - 12:03
User Badges:

Thanks, I'm off-site at the moment, but I'll get the information to you tomorrow

darryll.plumb Wed, 09/16/2009 - 03:30
User Badges:

Output from the switches below


CPLUKLONNXS0001# sh int eth 1/1

Ethernet1/1 is down (Link not connected)

Hardware: 1000/10000 Ethernet, address: 000d.ecb4.dac8 (bia 000d.ecb4.dac8)

MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA

Port mode is trunk

auto-duplex, 1000 Mb/s, media type is 1/10g

Beacon is turned off

Input flow-control is off, output flow-control is off

Rate mode is dedicated

Switchport monitor is off

Last link flapped never

Last clearing of "show interface" counters never

1 minute input rate 0 bits/sec, 0 packets/sec

1 minute output rate 0 bits/sec, 0 packets/sec

Rx

0 input packets 0 unicast packets 0 multicast packets

0 broadcast packets 0 jumbo packets 0 storm suppression packets

0 bytes

Tx

0 output packets 0 multicast packets

0 broadcast packets 0 jumbo packets

0 bytes

0 input error 0 short frame 0 watchdog

0 no buffer 0 runt 0 CRC 0 ecc

0 overrun 0 underrun 0 ignored 0 bad etype drop

0 bad proto drop 0 if down drop 0 input with dribble

0 input discard

0 output error 0 collision 0 deferred

0 late collision 0 lost carrier 0 no carrier

0 babble

0 Rx pause 0 Tx pause

0 interface resets


CPLUKLONNXS0001#



CPLUKLONNXS0001# sh int eth 1/1 trans

Ethernet1/1

sfp is present

name is Methode Elec.

part number is SP7041

revision is A

serial number is MTC009044

nominal bitrate is 1300 MBits/sec

cisco id is --

cisco extended id number is 4


CPLUKLONNXS0001#



The grep 1/1 output of the show system internal command didn't return with any output. I have added an attachment with the command without the grep command





Attachment: 
Yudong Wu Wed, 09/16/2009 - 13:41
User Badges:
  • Gold, 750 points or more

Yours SFP looks OK. In general, we will see "SFP validation failed" under "show interface". I validated its SN as well.


Can you try the following?

1. "speed 1000" must be configured.

2. try a different cable.

3. hard code your laptop seed to 1gig

4. upgrade laptop NIC driver

5. try a different laptop.


If the above still does not help, please open TAC case.


darryll.plumb Thu, 09/17/2009 - 00:14
User Badges:

Thanks for Validating the SN for us. We have tried all of the tests above, and also tried cross-over cables, a couple of SPF, and connection to a 3750 switch on site. None of these have worked for us, in all cases the link comes up for a fraction of a second then fails, so we are going to raise a TAC case .Thanks for the response. If I get any resolution I will post it here.

Actions

This Discussion