Strange behavior?Port goes down if both sides=100/full

Unanswered Question
Sep 15th, 2009
User Badges:

Interesting.

On a 3750-A, port fa1/0/24, I connect a crossover cable to 3750-B, port fa1/0/24. If I leave the respective ports as 'auto/auto', the connection is established. If I set 'speed 100 and duplex full'on both sides, port status goes down and it shows status as 'not connected'. Any ideas what is going on?


Here is the actual output regarding the port involved:

3750-A#show int status

(...)

Fa1/0/24 notconnect routed full 100 10/100BaseTX

(...)

3750-A#show run int fa1/0/24

Building configuration...


Current configuration : 132 bytes

!

interface FastEthernet1/0/24

description 3750-B

no switchport

ip address 10.2.50.229 255.255.255.252

speed 100

duplex full

end


(...)


3750-B#show run int fa1/0/24

Building configuration...


Current configuration : 115 bytes

!

interface FastEthernet1/0/24

description 3750-A

no switchport

ip address 10.2.50.230 255.255.255.252

speed 100

duplex full

end






  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Tue, 09/15/2009 - 06:50
User Badges:
  • Purple, 4500 points or more

I would plug them in and make sure you are connected to the ports you think they are via cdp. Also you could try and turn off mdix auto and see what happens . Are you sure its a crossover ??? If its not a crossover that is the correct status if you are using mdix to correct the pairing as mdix will only work if both sides are set as auto otherwise it will show not connect.

news2010a Tue, 09/15/2009 - 07:51
User Badges:

It is a remote site and the tech told me it was a crossover for sure. Maybe he got it wrong. I am sure it is the right port, because using the same cable, when I put in 'auto/auto' it works right away.


Let me ask him about the cable again.

Richard Burts Tue, 09/15/2009 - 08:28
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Marlon


It sure sounds to me like the switches need MDIX to make the connection work. And I believe that Glen is very correct about needing negotiation auto for MDIX to work.


HTH


Rick

Leo Laohoo Tue, 09/15/2009 - 14:36
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

MDI/MDIX is enabled by default. IF both ports are 100mb, why do you want to hard-code the speed and duplex ... on a 3750?


I'd leave it the way it is.

Actions

This Discussion