redistribution and route-maps

Unanswered Question
Sep 15th, 2009
User Badges:

Hi,

I have a bunch of routers setup in a lab running EIGRP and BGP.


Currently the two routers that are BGP neighbours redistribute the BGP routes into some of the other routers in the network.


I only want one router in my network to receive the redistributed BGP routes. I thought i could do this with a route map... This is what I have configured


router eigrp 1

redistribute bgp 65000 metric 2048 10 255 1 1500 route-map deny-to-r6


route-map deny_to_r6 permit 10

match ip address routing_updates


ip access-list extended routing_updates

permit ip any host 10.1.1.1

permit ip any host 10.2.2.1

deny ip any any log


So I thought this should permit the redistributed BGP routes to 10.1.1.1 and 10.2.2.1 (this is the same router, just two different interfaces) and deny them everywhere else.


However when i apply this command, no routes get redistributed at all.


So i must be missing something.... any suggestions?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Edison Ortiz Tue, 09/15/2009 - 16:38
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Your ACL should be as followed:


ip access-list standard routing_updates

permit host 10.1.1.1

permit host 10.2.2.1


HTH,


__


Edison.

LucaSalvatore_2 Tue, 09/15/2009 - 16:51
User Badges:

hmmm that didn't change anything... the extended ACL does the same thing doesn't it?



Edison Ortiz Tue, 09/15/2009 - 17:06
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Reading your original post once again, I believe there is a misunderstanding. You don't redistribute to a destination router by including the host information in the route-map - you redistribute from one routing protocol to another while using the route-map to match on routes that are needed to be redistributed.


The logic that I thought you wanted to implement was to redistribute 2 host routes from BGP into EIGRP. It seems you want to redistribute all BGP routes into EIGRP but to have a destination of those 2 devices? It does not work like that. Once you bring those routes into the IGP, all other routers running the IGP will receive the route unless you filter it at ingress.



__


Edison.

Actions

This Discussion