SSH Problem

Answered Question
Sep 16th, 2009
User Badges:

I have LMS 3.1 with win 2003 stnd sp2 in AAA mode. I am trying to connect via SSH in topology service of CM. But getting error " SSH can not be found" "Probable csuse; SSH client configuration missing" "Recomended action ; configure SSH client in Java Plug-in control panel. for details on configuring SSh client, see online help".

I have created campusmgr.properties file under my home directory containing CMSSH=d:\\putty\putty.exe.


Pls. help.



Correct Answer by yjdabear about 7 years 8 months ago

Well, McAfee is about the only X-factor I could see so far. Though I just took away my own read-access to campusmgr.properties, yet I can still launch SSH from Topology Services, on two different Windows boxes no less.


What "Version with Patch Level" is Campus Manager at Common Services -> Software Center -> Software Update? If it is 5.1.1 or higher there, I'd restart LMS, if you're allowed to. Then try deleting the Java cache files: Java Control Panel -> General - Temporary Internet Files - click Settings - click Delete Files. Now close all the browser windows, relaunch and clear cache there. Then access Topology Services and try SSH again. This is assuming it's all taking place on the LMS server you're RDPing to.


Another thing: What about trying on the PC you're RDPing *from*, with the same setups (campusmgr.properties and all)? Does it work there?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
yjdabear Wed, 09/16/2009 - 06:18
User Badges:
  • Gold, 750 points or more

Due to a bug in CM 5.1, you'd need at least CM 5.1.1 to get this working correctly. So check that prerequisite first.


Secondly, make sure the campusmgr.properties file does not have a hidden .txt extension.

pradip.saha Thu, 09/17/2009 - 02:16
User Badges:

My CM version is 5.1.0. How can I upgrade it ? Is it possible to upgrade any particular module. If yes, Can u pls provide me the procedure & suggest from where I can get the software.


I have checked campusmgr.properties file. It does not have a hidden .txt extension.

yjdabear Thu, 09/17/2009 - 06:03
User Badges:
  • Gold, 750 points or more

If your LMS server can get to cisco.com, you can download CM 5.1.1 or maybe 5.1.3 through Common Services - Software Center - Software Update - click the Download Updates button.


Otherwise, you can get it manually from:

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-campus, where both 5.1.1 and 5.1.3 are listed.

pradip.saha Thu, 09/17/2009 - 21:50
User Badges:

I have updated CM to 5.1.3. But still the problem is there.

yjdabear Fri, 09/18/2009 - 06:01
User Badges:
  • Gold, 750 points or more

Are you using an administrator account on the client PC? That's also one of the requirements.


Secondly, notice your campusmgr.properties uses a single backslash between "putty":


CMSSH=d:\\putty\putty.exe


The example in the Campus Manager User Guide, OTOH, has double backslashes everywhere:


CMSSH=C:\\Progra~1\\SSHCOM~1\\SSHSEC~1\\ssh2.exe


So make that change to your campusmgr.properties and see if that makes a difference.

pradip.saha Fri, 09/18/2009 - 06:14
User Badges:

I am entering into the server by server OS administrator account only. Then entering into LMS application via AAA authentication with admin rights.


My campusmgr.properties file contains CMSSH=d:\\putty\\putty.exe. Let me change it to CMSSH=d:\\putty\putty.exe. Then getting back to you.


yjdabear Fri, 09/18/2009 - 07:32
User Badges:
  • Gold, 750 points or more

What you use to log on to the LMS server doesn't matter in this case. What I was asking was whether your Windows account has administrator privileges on your client PC.


CMSSH=d:\\putty\\putty.exe is the correct syntax. So you would want to revert back to that, if you had changed any \\ to \.


Now, to t-shoot further:


1) set Control Panel -> Java -> Advanced -> Java Console -> enable Show Console;


2) close all Java apps, particularly any Campus Manager - Topology Services windows;


3) Now access Campus Manager - Visualization - Topology Services.


A Java Console should spring up in the background. Just be patient and wait a little bit as gobbles of texts scroll by, until they final stop. Now do a Select All (ctrl + a) and copy-n-past those text to Notepad. Do a Find in Notepad for "SSH Property File". If that string exits, simply post that entire line, e.g.:


SSH Property File: C:\Documents and Settings\myID\campusmgr.properties


If not, save the Java Console text in Notepad as a txt and attach it in your reply. Zip up the txt file if it's too large.


Also post the following:

1) your "campusmgr.properties" file.

2) The location of your putty.exe (Get Info in Explorer, and copy-n-paste the Location.)

3) The output of the "SET" command from a DOS prompt.


yjdabear Mon, 09/21/2009 - 14:51
User Badges:
  • Gold, 750 points or more

Is campusmgr.properties located at "C:\Documents and Settings\Administrator\campusmgr.properties"? A screenshot in Explorer should do.


Is campusmgr.properties readable by Administrator? Specifically I'm suspecting the McAfee anti-virus sw might have a hand in this somehow.

pradip.saha Mon, 09/21/2009 - 22:40
User Badges:

Yes, campusmgr.properties is located at "C:\Documents and Setting\Administrator\campusmgr.properties. campusmgr.properties is readable by Administrator.


Why/How r u suspecting McAfee.


Correct Answer
yjdabear Tue, 09/22/2009 - 09:40
User Badges:
  • Gold, 750 points or more

Well, McAfee is about the only X-factor I could see so far. Though I just took away my own read-access to campusmgr.properties, yet I can still launch SSH from Topology Services, on two different Windows boxes no less.


What "Version with Patch Level" is Campus Manager at Common Services -> Software Center -> Software Update? If it is 5.1.1 or higher there, I'd restart LMS, if you're allowed to. Then try deleting the Java cache files: Java Control Panel -> General - Temporary Internet Files - click Settings - click Delete Files. Now close all the browser windows, relaunch and clear cache there. Then access Topology Services and try SSH again. This is assuming it's all taking place on the LMS server you're RDPing to.


Another thing: What about trying on the PC you're RDPing *from*, with the same setups (campusmgr.properties and all)? Does it work there?

pradip.saha Wed, 09/23/2009 - 02:32
User Badges:

Ok, I will disable McAfee on the server. Also I have disabled some other softwares like OP Manager & Kiwi syslog running on that particular server. Let me check and accordingly I will inform you.


Currently CM is 5.1.3 as you prescribed earlier in this post.





pradip.saha Wed, 09/23/2009 - 11:08
User Badges:

whhhhhhh..... after deleting temporary internet files & cookies I am able to do SSH.......


THANKS for your big hand.


yjdabear Wed, 09/23/2009 - 11:27
User Badges:
  • Gold, 750 points or more

Ok, glad it has worked for you, cuz that's my last 'trick'. =D

Actions

This Discussion