unable to transfer calls spa9000 ..

Answered Question
Sep 16th, 2009

I have a spa9000 (2 sip accounts setup), spa400 (pstn and voicemail) 2 handsets connected and working fine (1 spa941 and 1 spa922)

Both of the handsets can do everything we need other 2 things  1 - transfer calls!! and 2 - dial each other by dialling extension number, we have to use the corporate directory entry.

We are following the instructions for transferring call off the handsets reference guides but the caller gets put on hold and can't be retrieved by the other handset.

I want to expand the number of phones I am using but nee to resolve this first!! I am using all of the latest firwares on all devices.

Can anyone help??

I have this problem too.
0 votes
Correct Answer by Alberto Montilla about 7 years 4 months ago

Dear Sir;

For issue number 2 (i.e. dialing extension one to another) make sure that your SPA9000 Phone dial plan (at the bottom of the SIP tab includes |1xx| at the end as entry) assuming you are dialing the default extension numbers (100 and beyond).

Lets solve issue above before debugging the transfer issue, they must be linked.

Regards
Alberto

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Alberto Montilla Wed, 09/16/2009 - 07:04

Dear Sir;

For issue number 2 (i.e. dialing extension one to another) make sure that your SPA9000 Phone dial plan (at the bottom of the SIP tab includes |1xx| at the end as entry) assuming you are dialing the default extension numbers (100 and beyond).

Lets solve issue above before debugging the transfer issue, they must be linked.

Regards
Alberto

Clearview92 Wed, 09/16/2009 - 08:14

This is the dial plan I have on my SIP tab, I am using extension numbers 10 and 11 etc..

(<*97:vmm>|[98],xxS3|[98],xxxS3|[98],[1-9]xxxxxxxxS0|[98],xx.|[234567]|[234567]x|[234567]xx|[234567]xxx)

What should I add in for these extension numbers?

Patrick Born Wed, 09/16/2009 - 15:40

Hi Clearview92,

1. Consider using the SPA9000 Setup Wizard to configure your environment with one ITSP.

2. Use the web-UI to configure your second ITSP and you're done.

     The Wizard will get your dial plans right too.

If you choose to not use the Wizard:

Your dialplan needs some work:

(<*97:vmm>|[98],xxS3|[98],xxxS3|[98],[1-9]xxxxxxxxS0|[98],xx.|[234567]|[234567]x|[234567]xx|[234567]xxx)

Some suggestions:

If you're using 10, 11, 12, etc your dial plan needs to include |xx| to allow two digit dialing

It looks like you use 9 and 8 as steering digits so each outbound sequence needs |[98],nn|

If you're not trying to limit outbound calls, use a wide open plan similar to the following:

(<*97:vmm>|[98],xx.|xx)   This should allow you to:

  - dial *97 to access vmail

  - dial 8 or 9 and hear external dial tone and then dial any number of digits
     [press # after dialing number so you don't have to wait for dialing timeout]

  - dial two-digit extensions

Be aware that the SPA9000 will autoprovision a default dial plan over your phone's dial plan when you least expect it...

Be aware that the dial plan is checked in 3 places ...

Read this dial plan write up from top to bottom: https://www.myciscocommunity.com/docs/DOC-10461

WRT the transfer issue, take a look at this doc on how to transfer calls: https://www.myciscocommunity.com/docs/DOC-8581

Regards,

Patrick

-----------

Clearview92 Mon, 09/21/2009 - 09:16

I have just reset my spa 9000 and spa400 back to factory defaults and reconfigured using the setup wizard, I am now using 101, 102 etc for my internal extensions and still cannot dial between handsets using the extension number, in addition I still cannot transfer calls!!

After doing all of this my voicemail system seems to have died on me as well, there is no longer a recorded message when a call goes unanswered, I can however dial my voicemail from my phone to check for messages!!

I am getting increasingly fed up with this system as it seems to promise me everything I need in a small phone system but has yet to work in the manner I need it to.

If I am unable to get this system working as it should I will have to move to a different system, can you please help?

Patrick Born Mon, 09/21/2009 - 15:44

Hi Clearview92,

This is very strange...

Let's try some basics, please answer every question to help me help you:

  1. Describe your network.
  2. What physical connections do you have on the SPA9000?
  3. What physical connections do you have on the SPA400?
  4. How are the phones connected to the network?
  5. Do all phones reboot if you power-cycle the SPA9000?
  6. Are all LEDs on the phones' line keys green?
  7. How do you attempt to dial between extensions? Please describe in great detail...
  8. Press speaker button on ext100, dial 101#. Does 101 start ringing?
  9. When using the Wizard, did you have problems on any of the Wizard's pages?

Regards,

Patrick

----------

Clearview92 Tue, 09/22/2009 - 01:24

Hi,

Thanks for getting back to me, I have made some progress since my last post, I downloaded and ran the Beta setup wizard v2.1.1.2 from your site which has resolved my problems with regards to dialling internal extension using the extension number ie 102 or 103.

I still have not managed to transfer calls intenally as yet but will test this more today, I also still have an erratic voicemail system!

In response to questions see below.

1 - Small network, spa9000, spa400 (pstn and vm), spa941 and spa922 phones plus analogue extension. These are all connected to a 10/100 unmanaged switch.

     Pc's and servers on network have thier own switch which is linked to the phone system switch.

2 - SPA9000  has 1 analogue phone connected and it is linked to the switch

3 - SPA400 currently has no pstn connected untill I get system working ok so only has LAn connection and usb for voicemail.

4 - The phones are connected to the network over cat5 via the 10/100 switch

5 - Yes the phones reboot when spa9000 is power cycled or altered.

6 - Yes LEDs are green

7 - I can dial 103 to dial extension 103 and this works now, previuosly I had to use the corporate directory entry for "Station USER" .

8 - Yes it does now.

9 - No problems using wizard.

I will try to resolve the voicemail issues today, and will post my progress, again thanks for your help.

Would the fact that I am using an unmanaged switch be causing problems?

Tim

Clearview92 Tue, 09/22/2009 - 01:41

Hi,

Further progress in that we can now transfer calls!!!!! :)

Just need to resolve voicemail issues.....

Will update you as soon as I resolve..

Patrick Born Tue, 09/22/2009 - 05:05

Hi Tim,

I'm glad that the installation is progressing.

To answer your earlier question, no, an unmanaged switch should not affect what you're trying to do, but will affect the user experience because of no QoS. This means that when the network gets busy because of data, gaming, or configuration error, the users will complain about voice quality and the phone system in general. Voice is not forgiving when it comes to busy/choppy network availability...

The vmail, like the SPA9000 and phones will work without issue provided all Wizard steps are followed, in order, and exactly as described. For example if the Wizard says connect now, that means listed devices must be connected *now*. Similarly with factory resetting devices and rebooting. The timing and sequence of the steps is critical during the Wizard setup phase. Once an installer becomes expert, it's easy to short-cut steps etc, but for the novice, a short-cut usually results in lack of functionality and more time.

Some thoughts. Make sure that the SPA9000, SPA400, and Wizard computer are all on the same switch, don't have them on separate switches thinking that they're effectively on the same LAN... spanning tree or derivatives will get you when you least expect it. The SPA9000 can power cycle *very* fast, ~3 to 5 seconds. The SPA400 takes much longer. The SPA9000 registers to the SPA400. If the SPA400 is not found during initial setup/registration when being installed then interesting things happen. This is why it is very important to follow the Wizard's lead.

My suggestion is if vmail is not working, simply factory reset *everything* and start again. Now that you know your ITSP information, user names, extensions, and so on, you should be able to configure from factory reset to making calls in under 25 minutes. Once everything is working, inbound, outbound, transfers, vmail, aa, and whatever else you have configured, then take a look and see how all is configured.

It sounds like you're almost there, good luck.

Regards,

Patrick

-----------

Clearview92 Wed, 09/23/2009 - 01:15

Hi,

I have tried resetting wveything to defaults again and can make and receive calls, intenally and externally, transfer calls internally but I still have a problem with voicemail.

I Think that it is working but I get no message prompting me to leave a message, if I leave a message and the press # I can leave a voicemail.

Can you tell me where I can locate the audio file that prompts me to leave a message so I can check to see if it damaged or indeed missing?

Thanks,

Tim

Actions

This Discussion