Strange vlan and multicast issue

Unanswered Question
Sep 16th, 2009

Hi

I've two 3750 stacks in site2 and each one is configured with HSRP on their vlan's. I've got a remote site (Site1) that sends multicast to site2.

The problem occurs that receivers are receiving the multicast stream when both vlan's are configured in site 2. If I remove an interface on one stack then suddenly multicasts start working. Can someone please shed some light on this?

Site 2 Switch1 vlan config:

interface Vlan81

ip address 10.44.81.253 255.255.255.0

ip helper-address 10.45.64.51

no ip redirects

no ip unreachables

ip pim sparse-mode

no ip route-cache cef

no ip route-cache

no ip mroute-cache

standby 81 ip 10.44.81.1

standby 81 timers 1 2

standby 81 priority 120

standby 81 preempt

end

Site2 Switch2 vlan config:

interface Vlan81

ip address 10.44.81.254 255.255.255.0

ip helper-address 10.45.64.51

no ip redirects

no ip unreachables

ip pim sparse-mode

standby 81 ip 10.44.81.1

standby 81 timers 1 2

standby 81 priority 105

standby 81 preempt

end

Also the trunk links between the stack of switches have the following config:

interface TenGigabitEthernet1/0/2

switchport trunk encapsulation dot1q

switchport mode trunk

end

Any thoughts?

Thanks Dan

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sadbulali Tue, 09/22/2009 - 08:15

When you deploy the multicast application for the first time on a Cisco Catalyst switch network and the multicast fails to work. In addition, some servers/applications that use multicast packets for the cluster/high-availability operation can fail to work if you do not configure the switches appropriately.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a008059a9df.shtml

Actions

This Discussion