HUM 1.2 Quick Report

Unanswered Question
Sep 16th, 2009

Hi

Following a backup and restore of LMS 3.1 to LMS 3.2 and HUM 1.2.

I have lost the Quick Report CPU Utiliztation, get an error meeage "CPU Utilization jobs not avaiable".

Any ideas.

Many thanks

IAn

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 09/16/2009 - 07:24

Go to HUM > Admin > Quick Reports Schedule, and make sure CPU Utilization is enabled, and properly scheduled.

Ian Beck Thu, 09/17/2009 - 06:06

Hi,

Went to the Schdeule and the report was enabled, so tryed to disable and got the following message :

ERROR: No such job exists in JRM. Query for the available HUM jobs.

I was able to re-enable without issue.

But still get the same error message when going to report management.

Joe Clarke Thu, 09/17/2009 - 08:01

You may need to wait an hour (the default) before trying the Quick Report again. However, if you try disabling the report again, do you get the same error?

Ian Beck Sat, 09/19/2009 - 03:12

Hi,

I have done a bit more tetsing with the Quick report Schedule.

When I disable the report and apply, I still get the JRM error message.

If I move away for the screen and come back the JOb is still showing as enabled although I did not re-enable.

Thanks

Joe Clarke Sat, 09/19/2009 - 08:42

Post the upm_ui.log. Is this only happening for CPU quick reports, or do you see this behavior disabling/enabling all reports?

Joe Clarke Mon, 09/21/2009 - 10:31

Post the jobattribute.xml and jobattribs-mapping.xml files from NMSROOT/MDC/tomcat/webapps/upm/WEB-INF/classes/com/cisco/nm/upm/properties/common.

Joe Clarke Wed, 09/23/2009 - 08:26

Shutdown the UPMProcess daemon, then clear out the upm_process.log, then restart UPMProcess. Now you'll need to wait. UPMProcess will start taking a lot of CPU as it runs through all the jobs on the system. When it becomes idle, post the new upm_process.log.

Joe Clarke Thu, 09/24/2009 - 07:53

There was a problem adding all of the Quick Report jobs to JRM at the time of the upgrade. Now, HUM mistakenly thinks it doesn't need to add the missing job. If you reinitialize the upm database, restarting Daemon Manager should properly add all the Quick Reports. However, you will lose all of your HUM historical data. This may be fixable with some database surgery as well, but you will need to contact the TAC to get the steps.

To reinitialize the upm database run:

NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=upm dmprefix=UPM

Ian Beck Thu, 09/24/2009 - 08:32

Hi Joe,

Many thanks for your assistance in getting to the bottom of this.

Regards.

Ian

Actions

This Discussion