Linksys SFE2000P Plugged into a UC500

Unanswered Question

I am trying to plug a Linksys SFE2000P in the expansion port of a UC500 to add some extra phones to a system.  I preconfigured the phones directly connected to the UC500 before I moved them over to the Linksys.  I cannot get them to work while connected to the Linksys.  It just says "Configuring IP."  Does anyone have any tips for configuring this switch to work with the UC500?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
daviddun Wed, 09/16/2009 - 06:59

Good Morning,

I would look into the management VLAN of both the switch and UC500.

Typically the UC500 is going to use VLAN100 for the phone traffic.

The native VLAN or management VLAN of the SFE2000P is setup on VLAN 100 also.

Hope this points you in the right direction

Steven Smith Wed, 09/16/2009 - 07:15

You will need to check vlan's to make sure that the switch is properly configured.  I believe VLAN 100, which is for the phones on the UC500, was defaulted for data on the SFE2000P.  You should also make sure that the appropriate VLAN's are configured for the trunk port as well.  If not, you aren't going to be passing any traffic across the expansion port.

I don't know if the SFE2000P will pass CDP traffic and try to put the phones on the correct VLAN or not, so you may have to manually do this on the phones, set the admin VLAN to 100.

Maulik Shah Wed, 09/16/2009 - 23:24

As others have mentioned on the SFE you would need to change the below:

- enable vlan 100 for voice

- if you intend to have PCs on this switch as well as phones - you will need both VLAN 1 and VLAN 100 enabled on the SFE else all PCs will also be on the voice VLAN which is not a good thing for voice QOS

- you will also need to setup each switch port to be a trunk port with VLANs 1 and 100 passing on it

- you will need put the SFE admin IP address in the same subnet as the UC500 data VLAN subnet

As a sidenote, if you had used an ESW switch - all of the above is pre programmed by default - would have definitely saved you time on the install. The SFE is a great switch but the ESW is pre configured to work in a UC500 deployment which makes it simpler for you as a partner. Check this video for more

https://www.myciscocommunity.com/docs/DOC-9789

Steven Smith Thu, 09/17/2009 - 08:12

Vlan 100 is there, but it is untagged.  It should be the tagged Vlan in an SBCS environment.  Vlan 1 should be the default vlan on all of the ports.

David Harper Sun, 09/20/2009 - 16:46

I've had a couple of customers do this and it works well, albeit there is a fair bit of manual configuration involved.  The ESW switches are definitely easier.

Aside from getting the VLAN configuration matching on the switch and UC500, you should also consider how CDP is handled.  The SxE switches pass CDP through transparently, which gives you a couple of options:

1. Leave CDP enabled on the UC500 expansion port

Pro: All the phones attached to the SxE switch will see the CDP advertisement and automatically install themselves in the correct VLAN

Con: The UC500 will see CDP advertisements from the phones on the expansion port and will generate a warning message about mis-matched smart ports roles.  This is because normally a port connected to a phone should be set to Desktop+IP Phone, but in this case, the port is not really connected to a phone, so should remain with a role of Switch.  The warning can be safely ignored, but if you don't know to expect it, it can be a little disturbing.

2. Manually disable CDP on the UC500 expansion port

Pro: No disturbing error message

Con: Phones need to be manually installed in the voice VLAN by setting the Admin VLAN parameter through the settings screen.

Personally, I find option 1 much more preferable, and would recommend that approach.

Cheers,

Dave.

Steven Smith Mon, 09/21/2009 - 14:00

There is an administration VLAN.  You need to see what that is set to.  Also, did you set a static IP on the switch?  You need to make sure it all matches up.

daviddun Mon, 09/21/2009 - 14:26

Hello,

You stated that you changed the VLAN, you must be sure not to change the VLAN on the switch off management VLAN100.  This is setup in the firmware and all the changes need to happen to the UC500 side of things..

Steven Smith Tue, 09/22/2009 - 11:26

You don't need to enable CDP on the switch port.

You should change the tagged Vlan's on the SFE to be 100 and the untagged vlan to be 1 on all the ports you are plugging phones and PC's into.  That should fix the problem with the computers getting the wrong IP address range.

Steven Smith Wed, 09/23/2009 - 10:09

I don't have a box in front of me, but I think to make the VLAN 100 tagged, you first need to change the port to not have multiple VLANs.  Then, make the untagged VLAN be VLAN 1.  Then add the tagged VLAN and make it be 100.  It has been awhile since I have done this, but that is the process I remember doing.