SPA3102 very unreliable incoming call ringing

Answered Question
Sep 16th, 2009

I'm using SPA3102 with Gizmo5 SIP VoIP service currently without any PSTN connectivity. Outgoing calls are very fine. However, incoming calls are very unreliable, like only occasionally the attached analog phone rings. It's not a total no-ringing-at-all. After the SPA is rebooted, the attached analog phone rings for the first incoming call all very fine. However, the next incoming calls do not ring the analog phone at all. Sometimes after a reboot, several incoming calls ring the phone fine, but thereafter, no rings at all. I'm not sure if it's the SIP provider  or the ATA device, as when I check the ATA's info page while the incoming call is made, it shows no incoming call at all. However, other SIP phones (SW on PC and iPod Touch) rings very fine. Out of frustration, I even upgraded the firmware (it was 3.x.x before the upgrade) to the newest 5.1.10 and still the same problem. Tomorrow, I'll bring in my GrandStream ATA from my home and make sure it's not the network or the analog phone issue. In the meantime, please advise me what to do in this situation, like whether to request an RMA (or would it be worthwhile at all?).

Thanks,

Hosung

I have this problem too.
0 votes
Correct Answer by Alberto Montilla about 7 years 2 months ago

Dear Sir;

Please try the following. On each device, please set NAT Keeplive Enable to YES. Reboot and try again.

This is likely related to the fact that routers close the UDP ports after some time of inactivity.

Regards

Alberto

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Patrick Born Wed, 09/16/2009 - 16:03

Hi hosung33,

This sounds unusual. Can you try another cable between the FXS port and the analog phone? Just use a simple 2-wire cable, not 4-wire.

If the cable does not make a difference, try a different brand analog phone, some (very few) analog phones don't work well with SPA devices.

If the above doesn't work, consider enabling debug and then viewing the resulting syslog log for clues as the the cause of the issue/s.

https://www.myciscocommunity.com/docs/DOC-5405

Good luck,

Patrick

-----------

William Childs Thu, 09/17/2009 - 03:59

It almost sounds like you are having packet loss coming into your network. What type of internet service do you have? If dsl, make sure the mtu settings are correct (verify with provider). That wouldn't make total sense because you say the outbound calls are clear. Do you know what codec the provider is trying to use when contacting you? There could be a mismatch there I suppose. How about QoS on your network. Outbound seems fine but inbound traffic could be suffering. Is it possible you don't have enough bandwidth for your voip call?

Also, has this worked before and just started this problem, or is this a new installation? Did you factory reset and reconfigure after the firmware upgrade?

Bill

Correct Answer
Alberto Montilla Thu, 09/17/2009 - 06:48

Dear Sir;

Please try the following. On each device, please set NAT Keeplive Enable to YES. Reboot and try again.

This is likely related to the fact that routers close the UDP ports after some time of inactivity.

Regards

Alberto

hosungs33 Thu, 09/17/2009 - 11:18

Dear Alberto,

I think you are super and you nailed the problem! It's been already a few hours and I can receive all incoming calls. Yes, NAT Keepalive Enable was set to No and after I changed it to yes, it seems like there's no missing incoming rings at all. Thanks very much Alberto again!

Sincerely,

Hosung

Actions

This Discussion