Trouble after upgrade IOS autonomous to LWAPP/CAPWAP

Unanswered Question
Sep 16th, 2009

We are experimenting some trouble after upgrade about 40 APs from autonomous IOS to a controller 4402.

Some areas seems to have their coverage decreased after that.

Most complainig come from users who has 7921 IP Phones and walk through the coverage wi-fi area talking on it.

For example, in some AP coverage area I could stay away from the AP 15 meter before LWAPP upgrade, now I must stay just 11 or 12 meters and this is impacting roaming.

TAC says controller works different from IOS autonomous and that is the reason why this happens.

So we are supposed to increase APs number to coverage the same area...

We have already tried versions, and 6.0

I would like to hear any thoughts from someone who went through this before.

Is this really like that?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
weterry Wed, 09/16/2009 - 19:55

The only realistic reason you'd see less coverage between lwapp and autonomous is if the controller is turning down your power levels (this is dynamic by default).

So if you were at Power Level 1 on all your autonomous APs, and now the controller believes that Power level 3 is best, that would decrease your cell.

But if this is happening, then it would imply your coverage is good enough to warrant the power level drop.

If these APs are all Power Level 1, then your deployment really isn't designed for voice to begin with. A typical voice deployment is going to usually yield the APs at about power level 2 for each and every AP.

Completely unrelated, the wireless controller has a lot of different settings covered in the 7921 Deployment Guide that can help out with roaming. If you are convinced the Roaming issue is coverage related, than no big deal, but most 7921 roaming issues I get, are not coverage related.

I'd do a sitesurvey on the 7921. If you go stand between two APs and you've got a signal of -67 or better, than your coverage is fine for roaming. If this number is worse than -70, then you really do have a coverage issue (especially if the radio are power level 1)...

rafaelzendrine@... Fri, 09/18/2009 - 05:48


Thank you for your response.

The first TAC recommendation was to configure controller as 7921 Deployment Guide indicates. CCKM of course, was the first thing.

Also a webex session was made and tac engineer had access to the controller and did all the configuration/debugs/shows he wanted.

That been said...

In fact APs are channel and power dynamically set and all of them are showing Power Level 1.

I understand when you mention that power level should be 2 at the APs to have a better voice scenario. That make sense too. But site survey was done assuming all APs at the full power (100mW). Overlap areas was considered as well and this worked fine for about a year.

Following a simple survey we did at the 7921 between two APs in a problematic roaming area.

We did first with lwapp APs and second with autonomous APs (same models)

Controller LWAPP

AP1 - Point 1 - 52

AP1 - Point 2 - 63

AP1 - Point 3 - 71

AP1 - Point 4 - 70

AP1 - Point 5 - 68

AP2 - Point 1 - 57

AP2 - Point 2 - 57

AP2 - Point 3 - 57

AP2 - Point 4 - 48

AP2 - Point 5 - 57

IOS Autonomous

AP1 - Point 1 - 57

AP1 - Point 2 - 61

AP1 - Point 3 - 67

AP1 - Point 4 - 65

AP1 - Point 5 - 69

AP2 - Point 1 - 72

AP2 - Point 2 - 55

AP2 - Point 3 - 56

AP2 - Point 4 - 45

AP2 - Point 5 - 51

We are collecting some debugs again.

I let you know what happens.

Thank you all.

bill.vanderwaal Thu, 09/17/2009 - 09:19

Hi, Make sure your antenna configs are correct after you do the lwapp upgrade.(wireless tab->radio->802.b/g -> on right hand of page see drop-down-> configure-> see Antenna settings.

Leo Laohoo Thu, 09/17/2009 - 19:18

You can also manually override the WLC's setting of the Radio Resource Management on a per-AP basis. Wireless > Access Points > Radios > Choose radio band > on the right-most side of the AP is a drop down box. Hover your cursor over it and choose Configure.

Hope this helps.

Hi, I  need help about  upgrade the acccess point autonomus to access point  LAP.

The   problem is the sintax for the following information:   ap-ip-address,telnet-username,telnet-user-password,enable-password. You   can send me a example about this point.

which is the exact  procedure for only one access point??

best regards

Leo Laohoo Thu, 07/01/2010 - 15:14

How about this:

If you have the "rcv" image file ... copy this IOS to the AP you want to convert from autonomous to LWAP.  Change the boot string so the AP will boot the "rcv" image.  Connect the AP in question to the same VLAN as the WLC and boot the AP.

Don't forget to rate useful posts. Thanks.

shh5455 Thu, 07/01/2010 - 21:00

Save a text file with something like this:,Cisco,Cisco,Cisco

Where is the IP address of the AP you want to convert.  Then load that text file into the conversion tool.  If your telnet and enable passwords are different make sure to change those from the default Cisco.

predeeka1 Mon, 10/18/2010 - 12:37

I know it's been a while, but I'm having the same problem with an autonomous to WLC conversion.  Did this ever get resolved?


The procedure is the following: On the Access Point, Ip address, mask, default gateway, username and password nust be the same in the input data from Tool Cisco Wireless Upgrade.

Example: In the Access Point:,, , Cisco, Cisco Cisco

Input Data on Tool Cisco Wireless Upgrade:,,, Cisco, Cisco Cisco


predeeka1 Mon, 10/18/2010 - 13:22

Thanks, but I was actually referring to the problem posted by Rafael at the very top of the thread, with coverage problems introduced by an upgrade from autonomous to lightweight.


This Discussion