ICM to CVP Application taking a long time

Unanswered Question
Sep 16th, 2009

All,

I am working on an application in CVP, and it seems that from When ICM calls the run External Script, to when the first Prompt is heard is like 5-6 seconds! As well when the applications is over it takes 4-5 to return... Is this normal? I have experienced a bit of lag before but nothing this long. I am wondering if it has something to do with the VXLM Gateway being in Europe and the CVP in the USA. Possibly its taking the gateway awhile to download the entire VXML document from CVP before it start rendering?

CVP 7.0(2) ICM 7.5(5) VXML Gateway 12.4.20T(3)

Cheers,

Chad

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Chad,

Get a baseline for the exchange of switch leg establishement and VRU leg establishment by building a simple script - Send To VRU node followed by a label that returns the CVP error label (typically 92929292) to the gateway, so the gateway plays the error message.

What sort of time lag do you see?

Regards,

Geoff

Chad Stachowicz Fri, 09/18/2009 - 12:44

Geoff,

Your test yields about 2.5 seconds from any VXML gateway that we use in europe. This is from when I see 0 on my ip comm and the wav file starts between 2-3 secs. After this it looks like the next 3 or so secs seem to be "intializing the CVP" Application. At this point I hear the wav file around 5.5 total seconds. From here I use the audio element followed by a small custom action element. Per some recomendation on the other forum using audio followed by action will allow the action element to run in the background of the audio being played. I tested this out and confirms it works. Befor this it took aournd 7 second to return from the app to ICM to the next prompt. Now that this is implmented its about 4 seconds. Any ideas? 4 seconds does seem really long...

Chad

That is a surprisingly long time. Typical one-way latency between EU and US is around 150-180ms one way. In your system we would expect 4 trips for the test, so maybe 700ms in transport time. 2.5s seems a little high.

But your other figures just push it past usability.

You will have to put some CVP Combos and CVP PGs in Europe.

Regards,

Geoff

jimbrittcisco Thu, 09/17/2009 - 11:17

That would sure seem logical, to check latency and traffic across that network.

Actions

This Discussion