Aironet 1140: from lwap to autonomous AP

Unanswered Question
Sep 17th, 2009

Just this: is it possible to downgrade a 1140 from lwap to autonomous AP?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
blarkins1 Wed, 10/14/2009 - 06:16

There is an Autonomous IOS available for the 1140 now, however I have yet to figure out how to get a command prompt to convert it while consoled in. When the LAP cannot find a controller it just continues to error without timing out.

Carlo Zaina Wed, 10/14/2009 - 07:00

Thank you for the news.

I was waiting for the release of an autonomous IOS

blarkins1 Wed, 10/14/2009 - 07:04

I have been waiting anxiously too... We have several 1140's but no controller yet. If you know how to get a command prompt without the AP joining a controller please let me know. Mine just keeps erroring and will not give me a prompt.

Here is the release notes for the IOS and support for the 1140's:

http://www.cisco.com/en/US/docs/wireless/access_point/ios/release/notes/12_4_21a_JA1rn.html

blarkins1 Wed, 10/14/2009 - 10:55

Got it figured out... the 1142's need to get a DHCP IP address, then they'll create an AP hostname, THEN you will get a command prompt to work from.

If you're working in a test environment, just build a DHCP pool on your switch and the AP will grab an IP from there.

Carlo Zaina Thu, 10/15/2009 - 07:24

So far i worked only with Autonomous AP, so i may be wrong..

When AP boots, can't you halt the normal boot process and go in a maintenance mode, much like with a catalyst switch? And then, upload the image?

I'll have to wait until my 1142 get shipped

blarkins1 Thu, 10/15/2009 - 07:36

Typically, yes. But with the 1142 pre-loaded with a lightweight image, I was not able to break into rommon at all, and I could not get a prompt after it finished loading its image. It kept erroring that there was no IP and it could not find a controller, so I setup a DHCP pool on my switch and once it got an IP, it created a hostname for itself then went into a > prompt. Once that was done, a debug command was needed to get into config mode, THEN I was able to TFTP the new image on, and force a reload. .... Wasn't the easiest thing to do, but I know how to do it now. Only 19 more AP's to convert... :-)

Carlo Zaina Fri, 10/16/2009 - 03:11

What i can say: have fun with the upgrade :-) (In this circumstance i would opt for a wireless controller).

Anyway, thank you for sharing these info

rosarra Fri, 10/16/2009 - 04:27

I've successfully downgraded my 1420 to autonomous AP using the monitor mode (Press and hold MODE while you reconnect power to the access 
point). In this state you can easily configure the TFTP server and the Lan interface to download the Autonomous image.

Robert.N.Barrett_2 Fri, 10/16/2009 - 08:44

Probably too late now, but perhaps someone could try these steps to get into monitor mode (which work on other lightweight Cisco AP's when converting to autonomous):

This is what I've done on 1242's. Does it not work on an 1140?

Step 1 The static IP address of the PC on which your TFTP server software runs should be between 10.0.0.2 and 10.0.0.30.

Step 2 Make sure that the PC contains the access point image file (such as c1200-k9w7-tar.122-15.JA.tar for a 1200 series access point) in the TFTP server folder and that the TFTP server is activated.

Step 3 Set the timeout value on the TFTP server to 30 seconds.

Step 4 On the PC where the TFTP server is located, perform these steps:

a. Disable any software firewall products, such as Windows firewall, ZoneAlarm firewall, McAffee firewall, or others.

b. Ensure all Windows files are visible. From Windows Explorer, click Tools > Folder Options > View; then uncheck the Hide extensions for known file types check box.

Step 5 Rename the access point image file in the TFTP server folder to c1200-k9w7-tar.default for a 1200 series access point, c1130-k9w7-tar.default for an 1130 series access point, c1240-k9w7-tar.default for a 1240 series access point, and c1250-k9w7-tar.default for a 1250 series access point.

Step 6 Connect the PC to the access point using a Category 5 (CAT5) Ethernet cable.

Step 7 Disconnect power from the access point.

Step 8 Press and hold MODE while you reconnect power to the access point.

Step 9 Hold the MODE button until the status LED turns red (approximately 20 to 30 seconds) and then release.

Step 10 Wait until the access point reboots, as indicated by all LEDs turning green followed by the Status LED blinking green.

Step 11 After the access point reboots, reconfigure it using the GUI or the CLI.

brian.kachel@qu... Sat, 10/17/2009 - 05:43

The process works perfectly without issue.

Use a tftp server from Solarwinds (free) and you'll see your file transferring over - process took about 5 minutes total including the reload.

Since running on the autonomous 1142.. I'm noticing some buggy behavior. Random drops of the wlan while using wpa2 and PSK.

And some clients just can't join at all (noticed this on a Cisco 305 old PC card, as well as a recent IBM with Intel 5500 ABGN card.)

I am comparing this to a 1242 that is also autonomous on a recent code.

I think there are some known issues in this first release for teh 1142 - hopefully a new rev coming out soon!

Robert.N.Barrett_2 Sat, 10/17/2009 - 09:53

Did you enable ClientLink?

To enable ClientLink, enter this CLI command in interface configuration mode on 802.11n radio interfaces:

beamform ofdm

brian.kachel@qu... Mon, 10/19/2009 - 03:38

I've only recently enabled it but have been working with the 1252 more so than the 1142 - I'll know in a day or three if the 1142 behaves better with the Intel client with clientlink enabled.

Robert.N.Barrett_2 Mon, 10/19/2009 - 06:19

I've been playing with a 1252 on the same code level with an Intel 5300, some Atheros card (in an iMac), an Intel 3945, and a Cisco CB21. ClientLink is enabled. Not nary a drop so far, a, g, or n. I am single channel 802.11n on the 2.4 and dual channel (bonded channel, 40mhz channel width, whatever) 802.11n on the 5Ghz radio. There is little to no interference where I'm testing, so it's kind of ideal for performance testing, but not ideal for real-world testing.

I hope to be testing a converted 1140 this week or next (the 1252 was CAPWAP, is now autonomous).

insccisco Fri, 11/13/2009 - 09:04

Hi Robert,

can you please share the experience so far with your 1142N that you downgraded to Autonomous?

I have 15 of these guys and a controller was not purchased and upper management said there is no more budged, thus I am stuck with these APs and no controller.

I'd like to convert all these 1142N units to Autonomous and then deploy them into a 3560G PoE switch for a branch that needs wireless network.

Can you advise? My main concern is roaming, meaning that the users will be walking around the building, so everytime they hit another spot, I'd like the APs to provide them with seamless roaming so they won't experience any manual reconnect

thanks

blarkins1 Fri, 11/13/2009 - 09:14

I know the ? was directed at Robert, but...

I have converted (6) of our 1142's to Autonomous now and used them to replace some older AP's. Our laptops have the necessary profiles installed to join the wireless and are configured to log on automatically. We use a WDS architecture for authentication, so roaming between many access points, is virtually seemless, and very rarely requires anything from the user. These AP's in autonomous mode, appear to behave just like all the other Cisco AP's I've worked with...

insccisco Fri, 11/13/2009 - 10:08

Brett,

I actually meant to ask just about anyone :) so thank you very much for the quick response.

Your input is great news. So far I have converted one of my 1142N APs to autonomous, so now based on your input and I will go ahead and convert all of them and test.

Is there anything else I need to know while I set this up?

I've had problems in the past with the 1130 where WEP was enabled and many laptops, especially the MACs, were having lots of problems connecting to the wireless networks.

thanks

Carlo Zaina Fri, 11/13/2009 - 12:25

I confirm.

I am working with 2 1141 downgraded to Autonomous: they works perfectly. Users connects and roams seamlessly.

I've set up a network with WPA2-PSK to test and no trouble. The clients connecting in the past to 1130s now connect to 1140s, without noticing the change, as long as the WPA settings are unchanged.

Next step would be using dot1x, but this require carefull planning :)

blarkins1 Fri, 11/13/2009 - 12:35

more info..

We have both Cisco clients and Intel Clients using the wireless. Both types are configured with the same profiles as before... nothing has changed except the AP's. I replaced 6 of them 1 week ago, and nobody has reported any problems... in fact, nobody noticed they were replaced. All our clients are configured to log on automatically, so the users do not need to do anything except log onto thier PC when they start Windows. P.S. I do not recommend using the Windows Wireless Client. Use the software that came with your client adapters...

Carlo Zaina Fri, 11/13/2009 - 12:42

I agree with blarkins: as long as you can use the software coming with your NIC. Intel, Cisco, whatever.

I've also Macintosh (they are the only enjoying the 802.11n so far) and Linux laptops connecting and no trouble: just type in the password and you are connected. The OSI layer 1 is simply a detail :)

Robert.N.Barrett_2 Fri, 11/13/2009 - 13:08

Sorry to have been absent from this thread.

I had no problems with the 1142 I converted, but it was just for testing. It is now back to being a LAP.

For the best roaming and protection, I would recommend using WPA2/AES. If you have a RADIUS server, go the 802.1X route. If you do not have a RADIUS server, use WPA2/AES with a strong PSK.

WPA2 supports Pre-authentication, which should minimize your roaming problems (provided all AP's support the same SSID with the same authentication/encryption).

insccisco Fri, 11/13/2009 - 15:36

Great information guys.

I will start converting the other 1142Ns tomorrow and then perform the test. What will you say are the main advantages to using these devices with the Controller? The way I will be deploying them will be by using a using where all the APs will be connecting to (wired).

Carlo Zaina Sat, 11/14/2009 - 00:32

Controller gives you centralized management, that's the main advantage. You haven't to configure manually each AP, update each AP's config if you make a change in the overall configuration. Also installing becomes simpler: once the AP can reach the controller, it downloads the configuration and is ready to operate.

I found the controller most useful if you wish to migrate to a new encryption key or create a new Wireless LAN spanning across many APs.

insccisco Mon, 11/16/2009 - 06:51

The controller then does give you lots of advantages. I read about it and it is just like you advised. Thank you for that info.

As for the deployment of the 1142N APs converted to Autonomous, I've configured only one so far and none of my laptops are able to see the SSID. Any help?

insccisco Mon, 11/16/2009 - 07:30

Disregard. I had not checked the "Broadcast SSID in Beacon" option.

I do have a concern though. I have 2 latops connected to this single AP. One that support abg which I am able to see it under the Radio0-802.11N2.4GHz interface. The second laptop supports N, and I see it under Radio1-802.11N5GHz. However, both laptops are connected at 54Mbps speeds. I was under the impression that my N laptop was going to connect at higher speed. Can you advise?

Carlo Zaina Mon, 11/16/2009 - 13:14

While 802.11b/g works only in the 2.4 GHz spectrum and 802.11a works only in the 5 GHz, 802.11N works on both he frequencies, so you could be connected to dotradio 0 or dotradio 1 interface.

As first try, i would disable the 5 Ghz radio: i've noticed, on a 1130 abg, that a couple of clients, with Cisco PCI wireless card, being in range, were used to connect with 802.11A , achieving a 18-24 Mbps link speed. Disabled the 802.11A, they connected with a link speed near 36-48 Mbit in the 2.4 GHz frequency.

I've used so far only AP with 802.11N 2.4 GHZ (also on ISR Routers) and the laptops were able to reach 200 Mbps, without any particular configuration (i use only CLI to configure).

As second option, you could raise the minimum speed rate allowed, above the 54 Mbps, but keep in mind that doing so, your abg laptop will be unable to connect since it can't transmit at those bit rates. This can be useful only to debugging/evaluate the AP's performances.

In the end, it's a design issue, however: do you want the best throughput or the best coverage?

blarkins1 Mon, 11/16/2009 - 14:05

Keep your "basic" rates set to: 1.0 , 2.0 , 5.5 , 11.0 Mb/sec, but make sure that all your other rates are "enabled". (both 802.11g rates and the MCS rates)The MCS rates will be the ones that give you throughput beyond the regular 802.11g rates.

Robert.N.Barrett_2 Mon, 11/16/2009 - 15:09

You must have WMM enabled, and you must be using either open auth/no encryption or WPA2/AES in order to achieve full 802.11n speeds.

insccisco Mon, 11/16/2009 - 19:25

Although it does not say anything about WMM anywhere on the GUI, I was able to follow some documentation online and finally got it. It was indeed the WMM. I enabled it along with the WPA2 and I was able to get the full speeds on the N laptops. Thank you for the feedback

Carlo Zaina Tue, 04/27/2010 - 11:45

The conversion (explained in the above replies) has been done using the image c1140-k9w7-mx.124-21a.JA1

ap#show version

Cisco IOS Software, C1140 Software (C1140-K9W7-M), Version 12.4(21a)JA1, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Wed 16-Sep-09 18:09 by prod_rel_team

ROM: Bootstrap program is C1140 boot loader

BOOTLDR: C1140 Boot Loader (C1140-BOOT-M) Version 12.4(18a)JA, RELEASE SOFTWARE (fc4)

ap uptime is 3 weeks, 5 days, 21 hours, 24 minutes

System returned to ROM by power-on

System restarted at 23:13:36 Berlin Wed Mar 31 2010

System image file is "flash:/c1140-k9w7-mx.124-21a.JA1/c1140-k9w7-mx.124-21a.JA1"

Actions

Login or Register to take actions

This Discussion

Posted September 17, 2009 at 1:41 AM
Stats:
Replies:33 Avg. Rating:
Views:18513 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard