Changing native VLAN on non-root bridges

Unanswered Question
Sep 17th, 2009

I have quite a few 1310 Bridges setup in point to multipoint configuration with a root bridge with a sector antenna at the campus network and remote sites connecting in. I have multiple VLANs trunked onto one SSID, this allows for having multiple vlans in use at the remote site. The problem is I want to configure some remote site bridges with a different native vlan than the standard allowing me to plug the client directly into the injector and eliminate the need for a vlan aware switch. I have tried to configure the the "encapsulation dot1q VLAN# native" but this swaps the bridge group on the subinterface to a bridge-group 1 .

!

! Last configuration change at 01:23:08 UTC Tue Sep 15 2009 by Cisco

! NVRAM config last updated at 01:23:09 UTC Tue Sep 15 2009 by Cisco

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

!

no aaa new-model

!

!

!

dot11 ssid Cisco-24

vlan 1

authentication open

authentication key-management wpa

guest-mode

infrastructure-ssid optional

wpa-psk ascii test

!

!

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm tkip

!

encryption vlan 1 mode ciphers aes-ccm tkip

!

encryption vlan 901 mode ciphers aes-ccm tkip

!

encryption vlan 902 mode ciphers aes-ccm tkip

!

encryption vlan 904 mode ciphers aes-ccm tkip

!

ssid Cisco-24

!

speed basic-1.0 basic-2.0 basic-5.5 basic-11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0

station-role non-root bridge

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.901

encapsulation dot1Q 901

no ip route-cache

bridge-group 255

bridge-group 255 spanning-disabled

!

interface Dot11Radio0.902

encapsulation dot1Q 902

no ip route-cache

bridge-group 254

bridge-group 254 spanning-disabled

!

interface Dot11Radio0.904

encapsulation dot1Q 904

no ip route-cache

bridge-group 253

bridge-group 253 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

hold-queue 80 in

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface FastEthernet0.901

encapsulation dot1Q 901

no ip route-cache

bridge-group 255

bridge-group 255 spanning-disabled

!

interface FastEthernet0.902

encapsulation dot1Q 902

no ip route-cache

bridge-group 254

bridge-group 254 spanning-disabled

!

interface FastEthernet0.904

encapsulation dot1Q 904

no ip route-cache

bridge-group 253

bridge-group 253 spanning-disabled

!

interface BVI1

ip address 10.0.0.100 255.255.255.0

no ip route-cache

!

ip default-gateway 10.0.0.1

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

snmp-server community misdept RO

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode