New Vlan

Unanswered Question
Sep 17th, 2009


I need some help adding a new vlan to our company network. Our network has been segmented into mutliple vlans since I began working here, but I've never had to add a new vlan until now, so I'm not sure what I am missing.

The router is a cisco 3640 and all the vlans are configured on the FastEthernet 3 interface. The new vlan is 90 and I added it to this router, and added the new network to the router eigrp 1 section. I have attached the config. I've checked the switched on my network and the new vlan has migrated to them.

I also have a Cisco switch that my desktop is connected to(which is on a different vlan). I have configured a port on this switch for the new vlan, and connected a laptop to it with a static IP address.

From my desktop I can ping the default gateway for the new vlan (, but I can not ping the laptop. From the laptop I can't even ping its default gateway or connect to anything else on the network.

My networking knowledge is limited, so I most likely have just overlooked a setting somewhere, but can not figure out why the new vlan is not working. Any help would be appreciated. Let me know if you need any additional information. Thanks for the help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
platinum_jem Thu, 09/17/2009 - 19:53

Hi ,

Looks like you've just missed a config or 2.

Show your switch configuration here also.

Is that switch trunked to the router ? or is it daisy chained to other switches ?

Where is the Router interface F3 connected to ?

nwt002tech Thu, 09/17/2009 - 20:17

Thanks for the quick response.

I have attached the Switch config. It is a Cisco 2924 and the laptop is connected to port 3. The switch is daisy chained to other switches.

I'll have to look tomorrow to make sure, but I believe the router interface F3 is connected to a Procurve switch.

platinum_jem Thu, 09/17/2009 - 20:32

If its daisy chained, make sure it is trunked all the way back to the router.

Did you configure VLAN 90 in the Procurve switch also ?

Make sure that all the switches along the way are aware of the new VLAN 90. If its missing in one of the switches, the destination switch will not see the 802.1Q VLAN 90 traffic.

nwt002tech Thu, 09/17/2009 - 20:52

Yes, I did a "show vlan" command on all of our switches, and they all showed the new vlan. Yes, I also added the new vlan to the procurve switch.

nwt002tech Thu, 09/17/2009 - 21:21

I think I might have figured it out. My VTP Mode was set to Client. I changed it to Transparent so I could update the vlan's Name, and I was able to ping the laptop. When I changed it back to Client I was not able to ping the laptop anymore.

Is the VTP Mode supposed to be set to Transparent?

platinum_jem Thu, 09/17/2009 - 21:55

VTP mode transparent will set your switches to ignore VTP updates, whereas mode Client will enable it to pick up updates from VTP Servers.

it shouldn't be affecting your scenario.

this is a weird solve.

The fact that you can ping the new vlan interface from your desktop is not very relevent. Your desktop is on the correct Vlan which is getting to its vlan interface and being routed to the new vlan via the router. It sounds to me like the procurve is not trunking the new vlan (90). Make sure the new vlan (90) is tagging the port on the procurve that is plugging into the router.


This Discussion