VPLS deployment

Answered Question
Sep 18th, 2009
User Badges:

Hi there


I am new to vpls and trying to get some design advice. We have vpls from the carrier and I am thinking of implement it with ospf as bgp need static peers.


The offices are in US,Europe and Asia.


I was thinking of two options:


a) Setup OSPF local within the continents and do bgp to tie the continents redistributing the summarized routes via bgp.


b) Do ospf only even between the continents no bgp.


If anyone has design it or experience with vpls, please give me you your feedback.


I will apprecaite it very much.


Thank you


Regards.

Correct Answer by Giuseppe Larosa about 7 years 9 months ago

Hello Mehdi,

how many sites are involved?


if they are many you need to think of a two levels hierarchy if they are in the order of several tens an OSPF only approach can be enough.


see for example this design guide


http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/ngwane.html


Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Giuseppe Larosa Sat, 09/19/2009 - 00:31
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mehdi,

how many sites are involved?


if they are many you need to think of a two levels hierarchy if they are in the order of several tens an OSPF only approach can be enough.


see for example this design guide


http://www.cisco.com/en/US/docs/solutions/Enterprise/WAN_and_MAN/ngwane.html


Hope to help

Giuseppe


mehsulsss Sat, 09/19/2009 - 06:30
User Badges:

Hi Giuseppe,


Thank you for response. It's definitely helps. For now, I think it will be about 10 sites and the most it will increase will be 20.


Should I go with the OSPF only approach? and tie them with areas?


Thank you

Mehdi.

Giuseppe Larosa Sat, 09/19/2009 - 11:44
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mehdi,

the number of sites 10-20 shoild mean up to 20-40 routers connected to the VPLS.


I recommend using default OSPF network type broadcast to reduce OSPF load on devices (it reduces the number of OSPF adjacencies that are needed with the DR and BDR election).


the VPLS ip subnet(s) can be placed in OSPF area 0 with internal subnets of each site placed in non zero areas.

This design allow for route summarization at area boundary that improves OSPF stability over the VPLS.


Another important note is to avoid as possible any form of redistribution:

instead of using redistribute connected for client vlans that generate external routes it is better to use:

network x.x.x.x area y

+

passive-interface type z/k


this allows for fine route control allowing also route filtering at area border (if needed now or in the future).


Hope to help

Giuseppe


mehsulsss Sun, 09/20/2009 - 05:57
User Badges:

Hi Giuseppe ,


Thank you for your precious advice as it is making me realize how much worth netpro is when it comes to getting some advice from people with knowledge on the subject.


In the past, I have been using rip,eigrp and bgp. Have not used ospf and is a learning curve aswel.


What I have understood from your recommendation is that to use all OSPF, define each sites router which holds the vpls connection as area o.

Using a bigger subnet, setup interface that connects to the area 0 as using the same subnet for the vpls handoff.


e.g: One VPLS cloud and asigned a /24 subnet for all the sites interfaces connected to the cloud.


Subnet asigned: 192.168.116.0.24


Site# 1 ---Site# 2---Site# 3




Site#1 (has two router 1 & 2 and a switch)


e.g Router #1 is an (ABR)router which is directly connected to Interface facing the cloud


interface s1/0

Ip address 19.168.116.1/24


interface g1/0

ip address 192.168.16.2/30



router ospf 120

network 192.168.116.0 255.255.255.0 area o

network 192.168.16.0 255.255.255.252 area 20

passive interface default

no passive interface s1/0

no passive interface g1/0



Router# 2


is not connected to the vpls cloud so the statement will be as follows:


interface s1/0

ip address 192.168.116.2/24


interface g1/0

ip address 192.168.16.6/30



router ospf 120

network 192.168.116.0 255.255.255.0 area o

network 192.168.16.4 255.255.255.0 area 21

passive interface default

no passive interface s1/0

no passive interface g1/0





Switch:


is not diretctly connected to the vpls cloud but uplink connection to the routers and the statement will be as follows:


int g1/0

description connection to router#1

ip adress 192.168.16.1/24


int g1/1

description connection to router#2

ip address 192.168.16.5/24



router ospf 120

network 192.168.116.0 255.255.255.0 area o

network 192.168.16.0 255.255.255.0 area 20

network 192.168.16.4 255.255.255.252 area 21

passive interface default

no passive interface g1/0

no passive interface g1/1




Does the concept in the above config correct. As long s they are directly connected to the area 0 which is the ABR router, we can have multiple area and should be fine. Same for Site 2 & 3. Summarize the routes when sending through the advertisement on the ABR router.


Hope I have been able to explain my understanding. Thanks again for your help.


Regards

Mehdi.

Giuseppe Larosa Mon, 09/21/2009 - 08:26
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mehdi,

your understanding is correct.


some details are wrong but probably are just typing errors.


area 0 not o.

Note:

the subnet you use on the VPLS cannot be the same used as backbone vlan inside a single site.


I would consider to connect two routers on the VPLS link as a form of redundancy.


You need also to think of what to do if the VPLS link fails.

You may consider a backup solution based on DMVPN over the internet may be just to be able to reach an isolated site when the VPLS link is failed to understand what is happening.


Hope to help

Giuseppe


mehsulsss Tue, 09/22/2009 - 04:02
User Badges:

Great! Thank you Giuseppe. I will give it a try.


Regards and thanks for helping me out.

Actions

This Discussion