DHCP relay- MPLS VPN support

Unanswered Question
Sep 20th, 2009

Hi All,

Just wondering if a CE router is configured to receive an IP address from a P router acting as a DHCP server, what configuration is required on the P router for DHCP pool?

At the moment, I have configured the devices for DHCP as follows-

CE1--PE1--P

CE1-

int fa 0/0

ip address dhcp

no shutdown

PE1-

ip dhcp relay information option vpn

!

int fa 0/0

ip vrf forwarding CUST1

ip address 10.1.1.1 255.255.255.252

ip helper-address global 3.3.3.3

!

P-

ip dhcp pool CUST1

network 10.1.1.0 /30

!

There is reachability to 3.3.3.3 from PE1. But no addresses are received on CE1 fa 0/0. Do I need to configure the DHCP pool for a particular VRF? What do I search for such functionality?

Regards,

Amit.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
amit.bhagat Sun, 09/20/2009 - 19:06

Also, one of the study guides suggest if the CE/PE connectivity is anything other than thru Bridged headend access through DSL or thru cable modem, the helper-address command should be placed on the CE router directly.

How true is that?

shivlu jain Sun, 09/20/2009 - 23:31

Hi Amit

For DHCP relay agent option 82 is required for segregation. I don't this so cisco router works for for this. Cisco router can only forward the request to the DHCP with helper enable under vrf interface. For this use require windoes 2003 server which supports DHCP-82 option.

regards

shivlu jain

Hi

Changing configuration and using an external DHCP server (ISC,CNR,Win2003??) should fix this problem.

But I have an extension to this network:

CE1 (routed) gets assigned IP by configuration, and we connect an DHCP client to an interface on CE1.

-CE1 cannot add proper option82 suboptions as it does not know anything about VRF/VPN-ID

-CE1 cannot relay as it does not know how to get to DHCP server (well - routing could be fixed by using non-conflicting IP on the WAN link, or NAT)

Is this a supported configuration at all?

Jon

YANGCCIE4 Wed, 10/14/2009 - 18:53

Hi, Amit,

I am not very clearly knowing what is dferent with global, and vrf ip address,

but I the example in the cisco website,

the orignal configuration shall be,

ip dhcp relay information option vpn

!

interface ethernet 0/1

ip helper-address vrf red 10.44.23.7

have you try this way,

help this help,

Yang

amit.bhagat Wed, 10/14/2009 - 19:02

Hi Yang,

The "global" keyword here will indicate the MPLS network and hence the DHCP Server is located in the SP MPLS network.

However, the "VRF " will indicate the DHCP Server is located in the remote customer's network.

I think, as Shivlu mentioned above, the Cisco IOS does not support DHCP Option 82 (although I haven't given any try since then).

HTH.

Amit.

Actions

This Discussion