Device Discovery

Unanswered Question
Sep 21st, 2009
User Badges:

I have these two issues regarding discovery

1. Several devices (cisco 6509) are being discovered via multiple interfaces, loopack, Ethernet0, serial 0/0 etc

2. Device has two loopback interfaces and both are being discovered, how do I say to manage only from loopback1 and not 2.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Mon, 09/21/2009 - 10:32
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What version of Common Services? Post the show running from one of these 6509s.


The algorithm used to pick the management IP is the loopback interface with the highest IP address. You cannot change this.

nawas Mon, 09/21/2009 - 10:46
User Badges:

LMS 3.0.1 on Solaris 10.

I first thought that it picks the highest ip address but in my case it is picking every loopback interface and in some devices it is also picking the server interface or vlan interface which connect the two devices (I think it is due to cdp). Under discovery setting I have a check on "use loopack" Should I uncheck that?

Joe Clarke Mon, 09/21/2009 - 10:57
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This is a known bug in this version of Common Services. If you upgrade to LMS 3.1 or higher, this problem will go away. There is no workaround.


When you upgrade, you will want to leave the "Use loopback" boxed checked. The devices will be added to DCR with the highest loopback IP as the management IP.

nawas Mon, 09/21/2009 - 12:07
User Badges:

It is a quite familiar term for me from Cisco " it is a known bug and fixed in the next version" I'm very used to of it in my 10 year of networking career. I'm upgrading to 3.2 this week and with the hope that I won't be asked to upgrade to 3.3 (doubted!!!) :)

Joe Clarke Mon, 09/21/2009 - 12:20
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There is no LMS 3.3. The bug is definitely fixed in 3.2 (as well as another related bug). There could still be a device configuration issue which causes this kind of duplication (which is why I asked for the show run), but you should likely see this behavior go away.

Actions

This Discussion