Protected Port and IP local-proxy arp

Unanswered Question
Sep 21st, 2009
User Badges:

Hi

I have this setup:


R1 -> | fa0/1

SW1 (vlan 2)

R2 -> | fa0/2


Two routers connected to a SW1 on the same vlan. Fa0/2 and fa0/1 had switchport protected configured. SW1 has a SVI 2 configured with ip local-proxy arp.

I'm trying to setup for these two routers to talk to each other through a the SVI 2 only and not directly. They can not communicate with each other directly because of the protected switchport but the local-proxy arp does not seem to be working.


Any idea what could be wrong?

All devices are on the same subnet and vlan (verified).


Doing an arp debug i see the requests but no responses.


Thanks in advance.


Tom


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Peter Paluch Mon, 09/21/2009 - 12:32
User Badges:
  • Cisco Employee,

Hi Tomek,


I wonder - do you have the Proxy ARP service enabled globally and/or on the SVI interface? Try entering these commands please:


no ip arp proxy disable

int vlan2

ip proxy-arp

ip local-proxy-arp


Best regards,

Peter


tomek0001 Mon, 09/21/2009 - 12:50
User Badges:

Peter,

Thank you for your response. I did have proxy arp enabled globally, but I didn't have the proxy-arp under the svi just the ip local-proxy-arp... oh and I had another silly mistake I didn't have "ip routing" enabled on that switch...


Thank you for you help.


Tom

Actions

This Discussion