SIP TRUNK with MGCP Gateway

Unanswered Question
Sep 21st, 2009
User Badges:

Hi,

Anyway of setting up a sip trunk on a 3845 MGCP gateway?

I want to be able to put some calls over the sip trunk and some of the E1 via MGCP.

Do i need to drop MGCP and configure it for H323 to get this working?


Thanks in advance..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
virverma Mon, 09/21/2009 - 23:06
User Badges:
  • Silver, 250 points or more

if you are using mgcp gateway there has to be a call agent.

Are the phones using mgcp gateways also using sip trunk then you need to create sip trunk via call agent,


Is it CME or CUCM

virverma Tue, 09/22/2009 - 00:15
User Badges:
  • Silver, 250 points or more

you need to create a sip trunk from cucm,

as you already got the link for it

KonradStepniewski Mon, 09/21/2009 - 23:36
User Badges:
  • Silver, 250 points or more

I believe you have CUCM as you use MGCP, so you current config looks like:

CUCM - mgcp - GW - PSTN


You can added something like:

CUCM - SIP trunk - GW - SIP trunk - SIP provider


Both will work on same gateway, point different route patterns to different destinations.


rate if this help.

clougher01 Tue, 09/22/2009 - 00:08
User Badges:

Ok so i create a sip trunk in CUCM which points to the MGCP Gateway then in the MGCP gateway i create a sip trunk tht points to the provider yeah?


Will this overcome the issue with rtp if phones on sccp and calls going across sip trunk?

virverma Tue, 09/22/2009 - 00:18
User Badges:
  • Silver, 250 points or more

all you need to do is create a sip trunk in cucm which should point to destination,


it should not create any issues with rtp

clougher01 Tue, 09/22/2009 - 01:11
User Badges:

Ok i've created a sip trunk and the call is presented to the mgcp gateway.

Now i've setup a couple of dial-peers and they get chosen in the voip ccapi debug but the call isnt sent to my sip server from the gateway. The call just sits there.

Is there something i'm missing here?


dial-peer voice 5000 voip

destination-pattern xxxxxxx

session protocol sipv2

session target sip-server

session transport udp

dtmf-relay rtp-nte

clid network-number xxxxxxx

no vad





Any clues?



Attachment: 
virverma Tue, 09/22/2009 - 01:16
User Badges:
  • Silver, 250 points or more

since you created sip trunk in cucm,

did you point it to your destination server or mgcp gateway,

you need to point to your destination.


also, you dont need to create a dial-peer as phones are registered on cucm,

when you make a call, depending on your dial-pattern or route pattern, cucm would route the call to sip trunk and in sip trunk you already mentioned the destination, so call should reach to destination

clougher01 Tue, 09/22/2009 - 01:22
User Badges:

I was referring to this from above -

You can added something like:

CUCM - SIP trunk - GW - SIP trunk - SIP provider.


I'm trying to create a sip trunk from the gateway. I've tried to create one directly from the call manager but had issues with nat and it never worked.


KonradStepniewski Tue, 09/22/2009 - 01:41
User Badges:
  • Silver, 250 points or more

Sample config when you have trunk from CUCM pointing to GW:


dial-peer voice 1 voip

answer-address .T

destination-pattern XXXX

session protocol sipv2

session target ipv4:10.1.1.1

dtmf-relay rtp-nte

no vad

!

!

sip-ua

credentials username user password pass realm 100.1.1.1

authentication username cptelco password pass

registrar ipv4:100.1.1.1 expires 3600

sip-server ipv4:100.1.1.1


Change user and pass to proper user/pass when your SIP provider request. Same goes for IP addresses of course.

clougher01 Tue, 09/22/2009 - 01:48
User Badges:

Yeah thats pretty much what i have but still seeing nothing on the sip server end and call just hangs there doing nothing.


I've also tried terminating the call on the mgcp gateway using an h323 gateway address as one of the interfaces and that lands on the gateway fine and hits the dial-peer but doesnt connect to the sip server.

KonradStepniewski Tue, 09/22/2009 - 01:58
User Badges:
  • Silver, 250 points or more

Show me: sh sip-ua reg st


BTW do you have configured?:

voice service voip

allow-connections sip to sip

sip


clougher01 Tue, 09/22/2009 - 02:02
User Badges:

Could be an external firewall issue. Will check it out tomorrow and let you know.


Thanks for the info so far..

clougher01 Tue, 09/22/2009 - 14:13
User Badges:

Ok it was a firewall issue.

Had to bind the media and sip to the loopback and now working.


So in summary i have a sip trunk from CUCM to the Gateway and then a sip trunk from the gateway to the sip provider.


All working fine..

jc.saavedra Thu, 10/23/2014 - 15:13
User Badges:

Hi clougher01 

 

I'm in the same problem, my topology:

 

CUCM -> sip trunk -> CME -> sip trunk -> ITSP

 

When I Answer the call is hang up.

 

My config is 

 

dial-peer voice 67 voip
 description ** SIP trunk ITSP**
 destination-pattern 591[67].......
 session protocol sipv2
 session target ipv4:172.17.0.9
 session transport udp
 voice-class sip early-offer forced
 codec g711ulaw
!
dial-peer voice 68 voip

 description ** SIP trunk CUCM**

 session protocol sipv2

 answer-address .T

 session target ipv4:172.16.6.3
 voice-class sip early-offer forced
 codec g711ulaw

 

 

I Have SIP to SIP and the CUCM configured.

 

bind media source-interface GigabitEthernet0/0 (CME to CUCM Iface)

 

 

Do you guide me?

 

Thanks.

 

Actions

This Discussion