WVC210 - help with ports

Unanswered Question
Sep 22nd, 2009

Hi Folks,

I got this camera to work no problem within the house network and from my other families homes.  So all is well.  But I could never get it to work at my workplace.  After talking to the network guy here he told me that ports 1024 are blocked and he told me to set the camera on lower ports.  Well when i got home I realized that this camera requires 1024 or higher.  So seems like I won't be able to access this cam from work which defeats the whole purpose.

Please let me know if there is anything else I can do?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
clindoan Tue, 09/22/2009 - 07:29

The port can be any number from 1024 or higher.  It is not neccessary to be lower.  To see the work-place camera anywhere, the router needs to forwarding that port number to internet network.

Example: Set WVC210 to port = 1050 and IP address= (local network IP)

                - Router setup to sent IP address and port number of WVC210 to use for HTTP, FTP, or RSTP, etc..

                - The router usually has the WAN IP (ex: where the IP is connected to Internet network.

    User from anywhere can connect via HTTP with "" (The same access is applied to other protocol such as FTP or RTSP)

   You would need the account to access to the camera ofcourse.  Your IT personel can set port forwarding to any port number to use any available protocol from the router.

Hope it helps.

acropora1 Tue, 09/22/2009 - 07:37

Thanks for really quick reply....

But the problem is I can't access anything on port 1024 and higher from my workplace.  For instance when I put in http://ip:1024 it won't work.

Everything on my end at home is all setup as I confirmed that it can be accessed through internet from few of my family members homes.  So it all works well.  Just when I talked to the network guy at work he said that if I try to access anything that is on port 1024 or higher it won't work as it is blocked and they can't open it up for me (it's big organization and they won't make any exceptions for me).  He told me that if I can set the camera on a lower port than 1024 I should be able to access it no problem... But on the camera setup it required 1024 or higher.  ahhhh...

So any ideas of what I can do?? is there any workarounds??

David Carr Tue, 09/22/2009 - 08:02

The reason it is port 1024 or higher is that the ports below that are common ports and are more than likely associated with other protocols.  If you cant get access to a higher port than 1024 i would contact your isp and have them unblock some ports for you.  Once you get that you should be working just fine.

acropora1 Tue, 09/22/2009 - 08:13

ahh that's not the news I wanted to hear.  :-)  at work where i'm trying to access this camera, network guys told me to that they can't open ports over 1024 for me and recommended that I just use port 80.  So i guess that is the limitation of this camera and strict security at my work, and maybe i should of looked into it before buying it.  Well but that just never came to my mind.  So that really sux for me as I have wicked cam, but I can't use it as I intended.

So i guess there are no firmware upgrades or work arounds to allow this camera to work on ports lower than 1024?? For instance I'd like to put in on port 80 :-(

Steven DiStefano Tue, 09/22/2009 - 08:31


I think you will find the use of multiple cameras in the same network will require you to choose alternate ports (i.e. they all can be 80) and all our cameras allow TCP/UDP port adjustment, so I wouldnt agree its a limitation of the Camera.

There are IANA recommendations, which small business products follow:


The port numbers are divided into three ranges: the Well Known Ports, the Registered Ports, and the Dynamic and/or Private Ports. The Well Known Ports are those from 0 through 1023. DCCP Well Known ports SHOULD NOT be used without IANA registration. The registration procedure is defined in [RFC4340], Section 19.9. The Registered Ports are those from 1024 through 49151 DCCP Registered ports SHOULD NOT be used without IANA registration. The registration procedure is defined in [RFC4340], Section 19.9. The Dynamic and/or Private Ports are those from 49152 through 65535
acropora1 Tue, 09/22/2009 - 08:45

I'm not trying to knock down this cam by saying there is limitation.  The limitation is the restrictions at my work and my limited knowledge. I've doen a lot of reading and hence I chose this cam.  I think it's a great camera.

I'm not using this camera for Business.

Friend of mine at work told me since the camera can only listen on 1024 and up, in my case he recommended that I fwd port 80 on router and then when the request comes into the router i should try to fwd it to port 1024 within the LAN.  I don't know how to do it yet... but i'll look at that when I get home.  Does it sound reasonble???

Steven DiStefano Tue, 09/22/2009 - 08:50

Thanks for your understanding and if you have a Cisco Small Business Router, I will help you configure port forwarding on it ;-)

What type of router do you have?

Steve D

acropora1 Tue, 09/22/2009 - 08:59

I have WRT54GL with Tomato firmware.

I think i'm ok with port forwarding on it as i got it to work on 1024 from a different location.  just accessing it from my workplace is giving me a headache.

I can ask my wife to access the cam from her work and disable the alternate ports... but then there's nobody at home to fwd port 80 on the router.  So i think i'll have to do it when i get home.

acropora1 Wed, 09/23/2009 - 06:06

Ok I finally got it to work at my workplace.  Just reporting back for somebody elses reference if they have the same issue.

I unchechekd the alternate port number and now by default the camera is listening on port 80.  Then I forwarded port 80 on the router and pointed it to local ip of the camera.

Now all is well and I can finally access the camera now from everywhere including my work.

Thank you guys soo much for really speedy replies and your advice!!!!

clindoan Tue, 09/22/2009 - 08:07

By default any Cisco 's camera product will be using both ports,  80 or 8080 for HTTP protocol.  For your case, you can access via port 80. IF you are using port forwarding, make sure the router is setup for port 80.  Another option is to use RTSP port number 554, you can streaming video by using application such as VLC or Windows Media Player or any Video Streaming applications that supports RTSP.

Try this: http://ip:80/

(This should be working fine)

acropora1 Tue, 09/22/2009 - 08:32

clindoan you got my hopes up again!!!

I can forward port 80 on my router no problem and point to the internal IP.  But then on the camera in the setup I need to specify which port it will be transmitting on, and the range is 1024 to some high number.  So just out of curiosity I put in port 80 and I got a message that this is invalid port range when i tried to apply the new setting in the cam setup.

Am i doing something wrong maybe???

Steven DiStefano Tue, 09/22/2009 - 08:39

Hi again,

Nice to meet you here BTW, and happy you are here and asking good questions.

So if you disable the alternate port, it will default on port 80.  So maybe just disable alternate http instead of setting it?

My WVC210 is in D.C for a trade show so I cant check it live, but I think this is the case?

BTW, a Best Practice recommendation is to access the cameras over a VPN connection.  Then you dont need to open ports and will keep your Firewall people happy too.

Steve DiStefano

Systems Engineer, US Field Channel.

acropora1 Tue, 09/22/2009 - 08:54

Steve:  Very nice to meet you here as well and all the other folks helping.  In all my hobbies whenever I hit a brick wall I go to the boards.  There's lots of smart people and knowledge out there.. so why struggle on my own.

In terms of the alternate port: I think you've hit it bang on!!!!!!  I remember selecting alternate port and that's where the port range was 1024 and up.  I never knew that if I don't select it the cam will defaul to 80.  If that is the case my problem will be solved and i'm happy camper.  I will adjust the setting when I get home tonight and will report back whether I can access it through port 80.

In terms of VPN: I don't have VPN setup yet... but now you just got my curiosity going and it will be nice weekend project.


This Discussion

Related Content