dhcp pool for vlan no native

Unanswered Question
Sep 22nd, 2009
User Badges:

Hi,

I need to give ip addresses at an a Vlan (4) which isn't native on my switch and

not even management.

This command below are for native vlan.

How have to I modify it for another vlan configured on my switch ?

Can anybody advice me an a document about ?

Best regards


Lorenzo


interface vlan1

ip address 192.168.22.1 255.255.255.0


ip dhcp pool myvlan

network 192.168.22.128 255.255.255.128

dns-server 192.168.1.13 192.168.1.6

default-router 192.168.22.254

lease 10

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
MUHAMMAD SHAHEEN Tue, 09/22/2009 - 08:07
User Badges:
  • Silver, 250 points or more

Hi Lorenzo,


You need to add new configuration, the same way as you have for the existing IP range. For example


ip dhcp excuded-address 192.168.200.1


interface vlan4

ip address 192.168.200.1 255.255.255.0


ip dhcp pool NewVlan4

network 192.168.200.0 255.255.255.0

dns-server 192.168.1.13 192.168.1.6

default-router 192.168.200.1

lease 10



Here I am assuming your new range will be 192.168.200.1/24 in VLAN4.


Hope this helps... please rate all helpfull posts.

Shaheen

lformelli Tue, 09/22/2009 - 08:20
User Badges:

Hi Shaheen ,

can I add this command

at my existing configuration ?


best regards


Lorenzo


Lucien Avramov Tue, 09/22/2009 - 08:32
User Badges:
  • Red, 2250 points or more

You can add as many networks statements as you want for DNS.

Basically the interface on a subnet A will provide DHCP as a DHCP server if there is a network statement for this subnet A under the DHCP pool.


Actions

This Discussion