Load Balancing with BGP in Multihome Environment

Unanswered Question
Sep 22nd, 2009

Hello

I am attaching a diagram with a topology for implementing HSRP and BGP for doing a load balancing with BGP through two internet dedicated each one with its last mille independent.

Besides, i am enclosing the BGP configuration suggest of both routers (CPEs) installed on the LAN of the costumer.

The question is, how can i get doing load balancing for traffic inbound and outbound in this solution??

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 09/22/2009 - 09:08

Hello Alexis,

>> The question is, how can i get doing load balancing for traffic inbound and outbound in this solution??

using GLBP instead of HSRP can help if customer client vlans are directly attached to the routers.

But I see that there is a FW in between that is the next-hop of the customer IP subnets so even GLBP is not of help here.

You can use two HSRP groups and you can have R1 master of group1 and R2 master of group2.

the firewall may support two default static routes out its outside interface using as next-hops the two VIPs.

For example ASA supports it in release 7.x or newer.

Also if you prepend on secondary router traffic will come back from primary router.

To try to have some traffic to come back on secondary you should remove prepending.

Your current configuration provides redundancy but no load balancing.

Hope to help

Giuseppe

alemunmo81 Tue, 09/22/2009 - 13:34

Checking your message above, and being focus on the load balancing for the traffic outside, i have a doubt of the configuration that i could have on the LAN using two HSRP groups, because my intention is to use the same subnet 190.66.3.0/28 for having two master, can i do this??

I am enclosing the HSRP configurations as a proposal for your checking:

Router Ppal

interface FastEthernet0/0

description LAN-PPAL

ip address 190.66.3.4 255.255.255.248

load-interval 30

speed 100

full-duplex

standby 1 ip 190.66.3.2

standby 1 priority 130

standby 1 preempt

standby 1 track FastEthernet0/1.1 50

standby 1 track 100 decrement 50

standby 2 ip 190.66.3.6

standby 2 priority 110

standby 2 preempt

Router Backup

interface FastEthernet0/0

description LAN_BACKUP

ip address 190.66.3.3 255.255.255.248

load-interval 30

speed 100

full-duplex

standby 1 ip 190.66.3.2

standby 1 priority 110

standby 1 preempt

standby 2 ip 190.66.3.6

standby 2 priority 130

standby 2 preempt

standby 2 track FastEthernet0/1 50

standby 2 track 100 decrement 50

ASA 7.x

route outside 0.0.0.0 0.0.0.0 190.66.3.2

route outside 0.0.0.0 0.0.0.0 190.66.3.6

Giuseppe Larosa Tue, 09/22/2009 - 22:55

Hello Alexis,

this can be done and it is what I was suggesting: you can define multiple HSRP groups on the same IP subnet if :

they use different group number

they have a different VIP.

the subnet has to be big enough to accomodate the ip addresses of VIPs, router interfaces, ASA ip address.

And you have 6 addresses available in your subnet.

this is called MHSRP by someone.

Hope to help

Giuseppe

alemunmo81 Tue, 09/22/2009 - 14:03

Checking your message above, and being focus on the load balancing for the traffic outside, i have a doubt of the configuration that i could have on the LAN using two HSRP groups, because my intention is to use the same subnet 190.66.3.0/28 for having two master, can i do this??

I am enclosing the HSRP configurations as a proposal for your checking:

Router Ppal

interface FastEthernet0/0

description LAN-PPAL

ip address 190.66.3.4 255.255.255.248

load-interval 30

speed 100

full-duplex

standby 1 ip 190.66.3.2

standby 1 priority 130

standby 1 preempt

standby 1 track FastEthernet0/1.1 50

standby 1 track 100 decrement 50

standby 2 ip 190.66.3.6

standby 2 priority 110

standby 2 preempt

Router Backup

interface FastEthernet0/0

description LAN_BACKUP

ip address 190.66.3.3 255.255.255.248

load-interval 30

speed 100

full-duplex

standby 1 ip 190.66.3.2

standby 1 priority 110

standby 1 preempt

standby 2 ip 190.66.3.6

standby 2 priority 130

standby 2 preempt

standby 2 track FastEthernet0/1 50

standby 2 track 100 decrement 50

ASA 7.x

route outside 0.0.0.0 0.0.0.0 190.66.3.2

route outside 0.0.0.0 0.0.0.0 190.66.3.6

Actions

This Discussion