LMS 3.2 new install on Windows 2008

Answered Question
Sep 22nd, 2009

Hi,

I finished installing the eval version of LMS 3.2 on a new Windows 2008 server. I manually adjusted the Pagefile size and managed to get the services to start, as suggested elsewhere in this forum. I now manage to get the login screen, but once I enter the login credentials, IE responds with ' Internet Explorer cannot display the webpage '.

I get this from a client and from the server browser itself. Not sure where to go from here....

Thanks!

I have this problem too.
0 votes
Correct Answer by Lucien Avramov about 7 years 1 month ago

Excellent, I guess you can mark this resolved.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (2 ratings)
Loading.
Lucien Avramov Tue, 09/22/2009 - 11:02

Are you trying to login via HTTP or HTTPS?

Can you try the one you did not use?

You dont even get an apache error on the page? such as HTTP 500 or something of that kind?

lpiccioli Tue, 09/22/2009 - 11:04

When I try http, it gives me the error I stated above. When I try https:// I get the following error:

Forbidden

You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request

Lucien Avramov Tue, 09/22/2009 - 12:43

I assume this is a windows install.

Did you run the installer from an administrator user on the machine?

Can you post the files:

Ciscoworks_install*.log from the root of the drive where ciscoworks is installed

Is there any integration with ACS for authentication?

Can you post the output of netstat -an in a file?

Lucien Avramov Tue, 09/22/2009 - 13:28

When you say from the login that has admin privileges on the server, did you remote desktop to the server? If so did you use the /console? The user that installs LMS needs to be the local machine admin, not a network user with admin privileges.

There are some file permission errors on the install:

-----File Permissions Errors Protocol

Access is denied.

Access is denied.

Those messages could be harmless but I suspect you did not use a local admin user to install LMS.

Also can you confirm that you are not running any A/V software on it?

Did you change the properties of the services under Administration tools -> Services?

lpiccioli Wed, 09/23/2009 - 06:40

Hi,

Yes I use RDP to remote access the server and logged in using my regular domain login that has been given loacl admin access to the server. There is no A/V software installed on the server. If I changed the properties of the services under Administratino tools, it was for troubleshooting purposesd but would have changed them back to the original values. I have been trying to solve issues since the install and before contacting this forum.

Should I have not used RDP to install LMS?

Lucien Avramov Wed, 09/23/2009 - 07:50

If you use RDP, make sure to use /console to login.

Also as there are user privilege messages, you should install LMS with the LOCAL admin user on the server.

lpiccioli Wed, 09/23/2009 - 11:22

Hi,

I have just finished re-installing LMS 3.2 using /Console this time (mstsc /admin) and logging in as local Administrator instead of my domain login. I receive the exact same errors in IE as previously described. I have attached the install log and pdshow output for comparisson.

IIS was already installed on this server. Could I be having a conflict with port 443? How can I verify that or adjust that now in the install after the fact, if that is the case?

Thanks!

mchiaravalle_2 Wed, 09/23/2009 - 11:59

Interesting because I'm having the EXACT same issue and I've installed twice.

LMS 3.2 on W2k8 server standard SP1 64bit

IE8

Firefox 3.08

mchiaravalle_2 Wed, 09/23/2009 - 14:00

OK I let TAC in via Webex, and they reset the Casuser password. So far so good on port :1741. As you may recall that is one of the passwords you had to set during a custom install. They think maybe a Microsoft server patch that was applied after the LMS install caused the problem.

Unfortunately I was occupied when they changed the Casuser password via CLI so I can't give any notes on how to get there but it should be documented somewhere.

Lucien Avramov Wed, 09/23/2009 - 14:11

Ok you can reset casuser by executing the file:

resetcasuser.exe. You need to use a local admin account for this.

1.Stop Daemons

c:\net stop crmdmgtd

2. Run the resetcasuser at NMSROOT\CSCOpx\setup\support

3. Start the Daemon.

c:\net start crmdmgtd

You can set the passwords to watever you like.

It's interesting that this issue happens if you do the install with a local admin user it should not.

Try resetting casuser and tell us how it went.

lpiccioli Thu, 09/24/2009 - 06:18

I have just tried reseting the password for user casuser with NO change to the issue described. Can't get the main page to load after the login. Are there instrucitons to ensure that the SSL is configured correctly? I saw it somewhere in this forum but can't find it now for some reason. I am willing to try anything at this point...

Should I have installed a Certificate after the install on the server? The Browser on the client is indicating a Certificate Error. I followed the prompts to Install the Certificate etc... but no change...

Lucien Avramov Thu, 09/24/2009 - 08:35

You may have been affected by: CSCtb17186 Redirection error thrown trying to login to LMS.

Try the following:

1. stop lms: net stop crmdmgtd

2.Run regedit.exe and add or modify the following registry key DWORDs:

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet

Settings\Zones\0\1A10 : DWORD : 0

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet

Settings\Zones\1\1A10 : DWORD : 0

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet

Settings\Zones\2\1A10 : DWORD : 1

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet

Settings\Zones\3\1A10 : DWORD : 1

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Internet

Settings\Zones\4\1A10 : DWORD : 3

3. Restart LMS : net start crmdmgtd.

If those steps dont help here is how to regenerate the SSL certs and disable SSL if you like:

1. Stop services: net stop crmdmgtd

2. Go to the directory NMSROOT\MDC\Apache\conf\ssl and delete the four files that start with server.*

3. Now regenerate the certificate, first run the commands:

Go to NMSROOT\bin\:

perl.exe NMSROOT\MDC\Apache\ConfigSSL.pl -disable

perl.exe NMSROOT\MDC\Apache\ConfigSSL.pl -enable

(If you want to use https for login, then leave it at this. If you want to use http, then run the ConfigSSL.pl -disable command again)

4. Start services: net start crmdmgtd

lpiccioli Thu, 09/24/2009 - 12:59

I will try this tomorrow and report back. I just read through the related article you linked above and it says that you must ensure that SP1 is loaded and not SP2 on the Windows 2008 server. I have SP2 loaded on the server. Is SP2 not suported? Should I still proceed with your recommendations above with SP2 loaded or should I roll back to SP1?

Lucien Avramov Thu, 09/24/2009 - 13:02

You are correct about SP2. Please install SP1.

I would suggest that you try the previous suggestions first, before going back to SP1, just in case.

lpiccioli Fri, 09/25/2009 - 07:19

I have uninstalled SP2. The server now reports only having SP1 loaded. Secondly, I tried the Reg edits above and was NOT able to make the changes. Each Zone number did not have \1A10 below it. Therefore I had nothing to modify. Thirdly, I followed the proceedure to regenerate the SSL Certificate successfully. I still get the same error attempting to login using http and port 1741 after the login. However, when trying to access the server now with Https://, The Forbidden error, as previously noted, has gone away. I now get the LMS Login page...I log in and then get the standard IE error 'Internet Explorer cannot display the webpage'.

dionjiles Fri, 09/25/2009 - 10:19

I'm experiencing the same issue that everyone on this forum topic is experiencing I just open a TAC Case.

Lucien Avramov Fri, 09/25/2009 - 10:39

If the regedit entries are not there, you need to add them.

Have you done a resetcasuser again on the server after you uninstalled SP2? Let the system generate the casuser password.

lpiccioli Mon, 09/28/2009 - 10:36

I have a TAC case open on this now. Current status is that they are checking with the Development team on my issue. Currently waiting for next steps.

lpiccioli Tue, 10/06/2009 - 12:40

In the end once we made these REGEDTS, as recommended, I was able to successfully login and get to the home page... Thanks for all your help!

Christian Huegel Fri, 01/28/2011 - 03:30

I´ve had the exact same issue on a  Win 2008 x64 Enterprise SP2 Server

I´ve added those entries to the registry and the Portal is now accessible. Thank you.

Actions

This Discussion