BGP routing issue

Answered Question
Sep 22nd, 2009

All,

I have three routers, and one of them is acting like an L3 switch. Here's what I have:

RTRA -> RTRB -> RTRC

RTRA and RTRC have eBGP peerings, and RTRB doesn't have anything. There are static routes on RTRA to point to RTRC's inside interface (10.125.1.1) and there's a static route on RTRA's inside interface at 10.127.1.1.

I can't ping anything beyond these inside interfaces from either router, but the bgp tables look correct and the routes are correct on both:

RTRA config:

router bgp 127

no synchronization

bgp log-neighbor-changes

network 10.127.1.0 mask 255.255.255.0

network 172.27.1.0 mask 255.255.255.252

timers bgp 1 3

neighbor 10.125.1.1 remote-as 1

neighbor 10.125.1.1 ebgp-multihop 255

no auto-summary

B 10.125.3.0/24 [20/0] via 10.125.1.1, 00:44:25

B 10.125.1.0/24 [20/0] via 10.125.1.1, 00:44:25

S 10.125.1.1/32 [1/0] via 10.127.1.5

B 172.30.1.0 [20/0] via 10.125.1.1, 00:44:25

*> 10.125.3.0/24 10.125.1.1 0 1 13979 3 i

RTRC's config:

router bgp 1

no synchronization

bgp log-neighbor-changes

network 10.125.1.0 mask 255.255.255.0

network 172.30.1.0 mask 255.255.255.252

timers bgp 1 3

neighbor 10.127.1.1 remote-as 127

neighbor 10.127.1.1 ebgp-multihop 255

no auto-summary

S 10.127.1.1/32 [1/0] via 10.125.1.5

B 10.125.3.0/24 [20/0] via 172.30.1.2, 00:01:01

The problem is that RTRB will be a Dell L3 switch and it only supports OSPF and RIP. I thought about two-way distribution between OSPF and BGP on RTRA and RTRC and only running OSPF on RTRB. Does this sound like the only way to do what I'm wanting to do? If so, what's the best way to ensure that I only have BGP routes in my routing table?

Thanks,

John

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 7 years 2 months ago

Hello John,

thanks for your kind remarks.

>> In your recommendation above, I wouldn't need to worry about running ospf correct?

no if RTRB doesn't need to be able to route traffic for the BGP destination networks.

if this is true creating a L2 path through is really the simplest solution.

Hope to help

Giuseppe

Correct Answer by Giuseppe Larosa about 7 years 2 months ago

Hello John,

I would keep the eBGP session between RTRA and RTRC I think it is simpler then performing mutual redistribution.

But the simplest solution should be the following:

use the dell switch as a L2 switch by adding a new l2 only vlan.

change if needed the RTRA and RTRB interfaces in two vlan subif interfaces this should build a L2 path between RTRA and RTRC.

this if RTRB doesn't need to route traffic to RTRA and RTRC.

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Giuseppe Larosa Tue, 09/22/2009 - 11:57

Hello John,

the L3 device in the middle cannot route packets for destinations advertised by BGP.

your static routes allow for eBGP session to be setup and the BGP routes are installed because being eBGP no sync problem is present (ok, no sync is now the default).

RTRA and RTRB have to redistribute into OSPF BGP routes.

Because you are not implementing mutual two way redistribution you should be safe.

Hope to help

Giuseppe

John Blakley Tue, 09/22/2009 - 12:32

Giuseppe,

I removed the peering between RTRA and RTRC and did redistribution from BGP on both routers into OSPF. Should I keep the eBGP peering? I need the router to update when the routes not available. It seems like OSPF is keeping the route on the "middle" router.

It updates on RTRA and RTRC, but RTRC doesn't advertise it out to the ISP. (Not shown.) This is because I'm not redistributing OSPF into BGP, so the ISP never sees the changed route. Is there anything else I can do other than two way distribution. These routes need to go both ways since this is for a failover scenario. Is there a tremendous danger for redistributing these both ways? I'm only running ospf on these three devices.

Thanks,

John

Thanks,

John

Correct Answer
Giuseppe Larosa Tue, 09/22/2009 - 12:41

Hello John,

I would keep the eBGP session between RTRA and RTRC I think it is simpler then performing mutual redistribution.

But the simplest solution should be the following:

use the dell switch as a L2 switch by adding a new l2 only vlan.

change if needed the RTRA and RTRB interfaces in two vlan subif interfaces this should build a L2 path between RTRA and RTRC.

this if RTRB doesn't need to route traffic to RTRA and RTRC.

Hope to help

Giuseppe

John Blakley Tue, 09/22/2009 - 12:47

Giuseppe,

That sounds like that may work actually. Then I could have them peer on the same subnet and not worry about routing for them. I wonder if there was a way in GNS for me to set that up since I can't emulate a L3 switch on it.

Thanks!

John

John Blakley Tue, 09/22/2009 - 12:57

Giuseppe,

In your recommendation above, I wouldn't need to worry about running ospf correct?

Thanks,

John

Correct Answer
Giuseppe Larosa Tue, 09/22/2009 - 13:01

Hello John,

thanks for your kind remarks.

>> In your recommendation above, I wouldn't need to worry about running ospf correct?

no if RTRB doesn't need to be able to route traffic for the BGP destination networks.

if this is true creating a L2 path through is really the simplest solution.

Hope to help

Giuseppe

Actions

This Discussion