Problem with netconfig jobs under RME

Unanswered Question
Sep 23rd, 2009
User Badges:

When i start netconfig jobs under RME, I get the following error message:

Error occured while processing. Possible Cause: URN_NOT_FOUND : urn "JRM" : Not found !!

I'm running LMS2.6. I guess you need some more info, just let me know and I'll post what ever you request.


Br

Geir

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Wed, 09/23/2009 - 07:16
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Post the output of the pdshow command.

pd.politiet.no Thu, 09/24/2009 - 01:46
User Badges:

Attached the pdswow output. But I also updated the RME from 4.0.12 to 4.0.13, and that solved the problem. But I still have the primary problem inside netconfig jobs:

I have several devices in CS, but I cannot see all the devices in RME. They are not available for selection when I want to do a netconfig job. I have deleted the devices, and created them again. Same thing, some devices do not show up in RME. Could it tha the devices somehow are not supported or I may be missing an update for the devices? The devices are always the same, 3560E-model and CBS30xx bladeswitches. I do get to add 3120 bladeswitches to netconfig jobs, but not those mentioned above.

If any output is needed for more info, please let me know.


BR

Geir



Attachment: 
Joe Clarke Thu, 09/24/2009 - 07:11
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

There is no RME 4.0.13. I assume you're running RME 4.0.6. Go to RME > Devices > Device Management > RME Devices, and try adding the missing devices in DCR to RME.

pd.politiet.no Thu, 09/24/2009 - 08:47
User Badges:

Sorry, you're right. I updated to CM 4.0.13 and RME 4.0.6.

I'm not able to do what you ask, because the devices are not there. I can see the devices in CS and CM and RME under devices, device management and under normal devices.


When I go to RME, devices, device management and RME devices, I can not see the "missing" devices.


And they are not in the selection under devices for netconfig jobs.


I have tried deleting and adding the devices in rme and cs, but the same result.


BrGeir

Joe Clarke Thu, 09/24/2009 - 09:13
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Do you see the missing devices if you go to RME > Devices > Inventory > Inventory Jobs, and create a new job?

pd.politiet.no Thu, 09/24/2009 - 23:13
User Badges:

Yes, I can see the devices, and I also get to do a inventory collection of the devices (tested with 3 of them) successfully.

But when I then go to RME-> Config management -> Netconfig -> Netconfig jobs and start to create a new netconfig job, I can not select the devices. They do not show up when I type the devicename or the ip address in the device selector field. I use the exact match and also wildcard while searching for the "missing" devices.


Br

Geir

Joe Clarke Fri, 09/25/2009 - 07:43
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

What are the sysObjectIDs of the missing devices?

pd.politiet.no Fri, 09/25/2009 - 10:18
User Badges:

It is a several Cisco catalyst blade switch 3020 for HP. When doing a snmpwalk I get the sysObjectID:

CISCO-SMI::ciscoProducts.748


There is also a couple of cisco 3560E-48TD, but if we find the problem with the blade switch, maybe we find the solution for the 3560E also.


Br

Geir

Joe Clarke Fri, 09/25/2009 - 12:35
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Make sure you have version 4.2 of the CBS3000 RME device package. Go to Common Services > Software Center > Device Update to check. If you do not have this package, you can install it from that same interface. Just check the boxes next to RME and Common Services, and download and install all available packages.

pd.politiet.no Sat, 09/26/2009 - 23:19
User Badges:

It's the version 2.0 of the CBS3000 package that's installed. I have downloaded the 4.2, but it needs some other packages thats needs to be updated also. I'm have som minor difficulties installing the packages, but will give you a feedback as soon as it's done.

Thanks.


Br

Geir

pd.politiet.no Mon, 09/28/2009 - 03:50
User Badges:

I have been trying to update the CBS3000 device package from 2.0 to 4.2. There are a lot of dependencies, and I have tried to update the dependencies before I update the CBS3000 package. But there are some problems with that:

1. It written that LibSwim 1.8.7 needs LibCommon 1.3.5 (and I believe that is done), but when I try to update LibSwim it says that it is depended on SharedSwimOpticalSwitch. I cannot find this device package for RME. Why?


2. Updating the SharedDcmaIOS 1.6.5 also says it failed because of vase package LibDcma. LibDcma I cannot find this either on the cisco website. Why?


3. When I try to see which device packages that are installed, CS->Software Center->Device Update and click Resource Manager Essential, I get a http status 500 - internal error with a lot of java messages. Hm, I had this problem when I was running rme 4.0.5, but when i updated rme to 4.0.6 it was gone. But now it is back. The only thing I have done is update a device package LibCommon to 1.3.5.

The server has been rebootet, but the problem stil consists.


I think I have some other problems with dependencies, but maybe solving the above will fix it.


Br Geir

Joe Clarke Mon, 09/28/2009 - 07:21
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Your RME package repository is corrupt. It can be recovered, but you will need to open a TAC service request to get the steps, and requisite package files to do so. Once fixed, you will have all of the up-to-date RME packages, and you should have full device support.

pd.politiet.no Wed, 09/30/2009 - 00:19
User Badges:

After the last tries for installing device package updates, with failure or saying it is depending upon other device updates (which I cannot find), I got http error when I wanted to see which device packages that are installed.


The last tip you gave me where to open a TAC, so I searched the TAC and found a way to re-initilalize the RME database on a Windows system. I ran the procedure described in the TAC (K66251543, http://www.cisco.com/en/US/customer/docs/net_mgmt/ciscoworks_resource_manager_essentials/3.5/installation/windows/guide/trbls.html#wp1025685). The procedure ran without any errors, but the problem still persists. I then decided to reinstall RME 4.0.6. The reinstallation ran ok, and after that I can now click to see the device packages installed for RME. Nice!


I checked to see which device package that was installed for the CBS3000, it was now 4.1. Not 4.2 like you said I needed. I decided to see if the devices show up in RME netconfig jobs, and YES I can se them. So far so good.


The next thing I did was to try making a netconfig job to see if it works fine for the cbs3000 device. Made a simple jobtask, and the result was positive! It compeleted successfully.


I will now take a full backup of the server, and see if I can update the device packages.


I consider the problem solved.


Actions

This Discussion