SNMP Walk Failing Following 6509 Supervisor Engine Replacement

Unanswered Question
Sep 23rd, 2009

We have recently noticed a problem with Cisco View not working on one particular device. This lead us to try to SNMP Walk the device but this failed. We have checked the RO Community String and Starting OID .1.3.6.1.2.1.1.3 which work fine on all other devices. Can anyone suggest anything else we could possibly try? The only coincidental fact is that the supervisor engine on the 6509 was replaced recently but we didn't think this should effect anything although everything was okay before this.

Many Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Lucien Avramov Wed, 09/23/2009 - 07:58

What do you mean by fail, does it time out?

Can you post your show run after removing the sensitive information?


Have you tried restarting the snmp-server process by issuing a no snmp-server and then re adding the commands?


Can you give more details also about the version you are running and the OIDs you are trying to poll

nathanmgrant Wed, 09/23/2009 - 23:58

The SNMP Walk displays the result -

Failed to snmpwalk the device. Please check your community string and starting OID, and try again.


Attached is the show run.


This switch is running catos so I have tried set snmp disable and then set snmp enable without any joy.


We are running LMS 3.01 and I am trying the starting OID 1.3.6.1.2.1.1.3 for the Catalyst 6509 switch.




yjdabear Wed, 09/23/2009 - 08:13

Oh, that's a toughie. :P If you're on Solaris, does snmpwalk from the CLI work? There may be an equivalent utility bundled with LMS on Windows. E.g.:


/opt/CSCOpx/objects/jt/bin/snmpwalk -c yourSnmpReadString -v 2c -t 30 problemDeviceIP .1.3.6.1.2.1.1.3

Actions

This Discussion