clear serverfarm doesn't clear all serverfarm statistics

Unanswered Question
Sep 23rd, 2009

I need to clear serverfarm statistics. But when I used the command clear serverfarm OAS, the value for the current connestions is not zero:-( I tried to use clear conn all and clear serverfarm OAS again, but the situation is same. How can I clear this current connections? Is it a bug in ACE software? See:

aace1/ISKNEBE# clear serverfarm OAS

aace1/ISKNEBE# sho serverfarm OAS

serverfarm : OAS, type: HOST

total rservers : 2



real weight state current total failures


rserver: aiskneap1 8 OPERATIONAL 914 0 0

rserver: aiskneap2 8 OPERATIONAL 757 0 0

Thank you


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Gilles Dufour Thu, 09/24/2009 - 01:09

The clear command has no effect on the current connections counter because this counter should always reflect the number of current connections.

If you do not have active connections on this server currently in 'show conn' then ACE had problem to decrement the counter probably while you were doing some config changes.

The solution is to remove the rserver from the serverfarm configuration and reconfigure it.


ROMAN TOMASEK Thu, 09/24/2009 - 01:42

The customer started the test traffic. I didn't change the config of ACE during the test traffic. After this traffic was stopped I tried to clear statistics, but the situation is same. It seems like bug in the ACE software.

TomaszMazurek Tue, 11/08/2011 - 03:27

and I've similar question to that topic:

let say first pool memeber went out and changed his state to probe-failed.

But despite of that the number of current connection didnt went to 0 .... it decreased let say by 200.

my question is ... shouldn't all connections be transfered to second host ????

Why show serverfarm command shows still some number of current connections ?

serverfarm     : OAS, type: HOST

total rservers : 2



       real                  weight state        current    total      failures


   rserver: aiskneap1        8      probe-failed  414        0         0

   rserver: aiskneap2        8      OPERATIONAL  957        0         0

kkataja Tue, 04/10/2012 - 22:28

The serverfarm by default does nothing to connections already established. Please check different "failaction" types.


This Discussion