IPv6 BSR not advertising candidate RP

Unanswered Question
Sep 23rd, 2009
User Badges:

Hello,


I have R2, R5 and R6 connected via point-to-point frame-relay subinterfaces. Think of them in a triangle. I have IPv6 enabled on the interfaces, loopbacks, and RIPng running throughout. All devices are pingable from all addresses.


I have configured IPv6 multicast-routing on each router and enabled R5 as the candidate BSR/RP, however R2 and R6 are not learning the advertisements.


Here are the configs.


R2:


ipv6 unicast-routing

ipv6 cef

ipv6 multicast-routing


interface Serial0/1/0.25 point-to-point

bandwidth 512

ip address 150.50.25.2 255.255.255.252

ip ospf message-digest-key 1 md5 cisco

ipv6 address 2001:25::2/64

ipv6 rip RIP6 enable

frame-relay interface-dlci 105

!

interface Serial0/1/0.26 point-to-point

bandwidth 512

ip address 150.50.26.2 255.255.255.252

ip ospf message-digest-key 1 md5 cisco

ipv6 address 2001:26::2/64

ipv6 rip RIP6 enable

frame-relay interface-dlci 106


R2#sho ipv6 pim ne

PIM Neighbor Table

Mode: B - Bidir Capable, G - GenID Capable

Neighbor Address Interface Uptime Expires Mode DR pri


FE80::20F:35FF:FE2D:5B21 Serial0/1/0.25 00:09:09 00:01:32 B G 1

FE80::20A:B8FF:FE19:AC80 Serial0/1/0.26 00:09:02 00:01:36 B G 1


R5:


ipv6 unicast-routing

ipv6 multicast-routing

!

interface Loopback6

no ip address

ipv6 address 2001:5::5/128

ipv6 rip RIP6 enable

!

interface Serial0/1/0.25 point-to-point

bandwidth 512

ip address 150.50.25.1 255.255.255.252

ip ospf message-digest-key 1 md5 cisco

ipv6 address 2001:25::5/64

ipv6 rip RIP6 enable

frame-relay interface-dlci 501

!

interface Serial0/1/0.56 point-to-point

bandwidth 512

ip address 150.50.56.1 255.255.255.252

ip ospf message-digest-key 1 md5 cisco

ipv6 address 2001:56::5/64

ipv6 rip RIP6 enable

frame-relay de-group 1 506

frame-relay interface-dlci 506

!

ipv6 pim bsr candidate bsr 2001:5::5

ipv6 pim bsr candidate rp 2001:5::5

!

R5#show ipv6 pim ne

PIM Neighbor Table

Mode: B - Bidir Capable, G - GenID Capable

Neighbor Address Interface Uptime Expires Mode DR pri


FE80::20A:B8FF:FE19:AC80 Serial0/1/0.56 00:09:23 00:01:15 B G 1

FE80::211:93FF:FE68:B360 Serial0/1/0.25 00:09:33 00:01:38 B G DR 1


R6:


ipv6 unicast-routing

ipv6 cef

ipv6 multicast-routing

!

interface Serial0/1/0.26 point-to-point

bandwidth 512

ip address 150.50.26.1 255.255.255.252

ip ospf message-digest-key 1 md5 cisco

ipv6 address 2001:26::6/64

ipv6 rip RIP6 enable

frame-relay interface-dlci 601

!

interface Serial0/1/0.56 point-to-point

bandwidth 512

ip address 150.50.56.2 255.255.255.252

ip ospf message-digest-key 1 md5 cisco

ipv6 address 2001:56::6/64

ipv6 rip RIP6 enable

frame-relay de-group 1 605

frame-relay interface-dlci 605

!

R6#sho ipv6 pim ne

PIM Neighbor Table

Mode: B - Bidir Capable, G - GenID Capable

Neighbor Address Interface Uptime Expires Mode DR pri


FE80::211:93FF:FE68:B360 Serial0/1/0.26 00:10:21 00:01:38 B G DR 1

FE80::20F:35FF:FE2D:5B21 Serial0/1/0.56 00:09:59 00:01:44 B G DR 1



As you can see, R2 and R6 do not learn the BSR or the RP:


R2#sho ipv6 pim bsr election

No BSR information found


R2#sho ipv6 pim bsr rp

R2#sho ipv6 pim bsr rp-cache

No BSR RP-Cache information found


R2#sho ipv6 pim bsr can

R2#sho ipv6 pim bsr candidate-rp

No C-RP information found


Any idea what is wrong?


Thanks,



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Peter Paluch Wed, 09/23/2009 - 22:27
User Badges:
  • Cisco Employee,

Hi Bryan,


You do not seem to have the PIM enabled on your interfaces. Use the ipv6 pim command on your interfaces to get the PIM running.


Also, it might be possible that on R5, you also need to enable PIM on the Loopback6 interface. At least in IPv4, if you advertised a certain interface as the source for BSR/RP, that interface had to be PIM-enabled.


Best regards,

Peter


dodgerfan78 Thu, 09/24/2009 - 04:50
User Badges:

Peter, PIM is on by default and does not show up in the running-config. That is why I gave the "show ipv6 pim neighbor" output.

Peter Paluch Thu, 09/24/2009 - 06:02
User Badges:
  • Cisco Employee,

Hi Bryan,


You're completely right. Sorry about my misstep here - I am not quite fluent in the IPv6 multicast yet.


Let me give it a try in a lab. I'll see what comes out of it in a few hours.


Best regards,

Peter


dodgerfan78 Thu, 09/24/2009 - 06:07
User Badges:

Heh, no problem, I am not that fluent yet as you can tell! I am using 2800s with 12.4(24)T1...but I have experienced a similar problem with 3640s running 12.4 enterprise. And there are not many resources except the DocCD on IPv6 multicast...


Thanks.

dodgerfan78 Thu, 09/24/2009 - 06:41
User Badges:

Well this may explain the issue:


"Use the show ipv6 pim bsr command to display details of the BSR election-state machine, C-RP advertisement state machine, and the C-RP cache. Information on the C-RP cache is displayed only on the elected BSR router, and information on the C-RP state machine is displayed only on a router configured as a C-RP. "


So it looks I should only see the BSR election output...but I am still not getting that...

dodgerfan78 Thu, 09/24/2009 - 07:07
User Badges:

Well I rebooted the 3 routers and now things are looking good. I have no idea what the deal was:


R2#sho ipv6 pim bsr election

PIMv2 BSR information


BSR Election Information

Scope Range List: ff00::/8

BSR Address: 2001:5::5

Uptime: 10:57:29, BSR Priority: 0, Hash mask length: 126

RPF: FE80::20F:35FF:FE2D:5B21,Serial0/1/0.25

BS Timer: 00:01:52


R2#

Actions

This Discussion