How to deactivate refresh of BMP Picture every 5 seconds

Unanswered Question
Sep 24th, 2009


i am currently integrating support for your new SPA525G phone into our téléphony application. We use provisioning to configure the phones and also replace the default background image on the SPA962 and SPA525g phones.

The SPA525G replaces the default image just fine, but then keeps reloading every 5 seconds the new background image from our servers. As we have hundreds of phones, this will lead to an unwanted traffic. I did not find a parameter on the phone, the web-configurator or the provisioning values to disable those repeated pulls or to change the pulling-interval.

Could you please tell me, if there is a way to only reload the image once per day or when the phone restarts?

Here is our configuration :

<Screen_Saver_Enable group="User/Screen">No</Screen_Saver_Enable>
<Screen_Saver_Type group="User/Screen">Black Background</Screen_Saver_Type>
<Screen_Saver_Trigger_Time group="User/Screen">300</Screen_Saver_Trigger_Time>
<Screen_Saver_Refresh_Time group="User/Screen">300</Screen_Saver_Refresh_Time>
<Text_Logo group="User/Screen">[Appname]</Text_Logo>
<BMP_Picture_Download_URL group="User/Screen">[Imageaddress]</BMP_Picture_Download_URL>
<Logo_Type group="User/Screen">Text Logo</Logo_Type>
<Background_Picture_Type group="User/Screen">Download BMP Picture</Background_Picture_Type>
<LCD_Contrast group="User/Screen">15</LCD_Contrast>
<Back_Light_Enable group="User/Screen">No</Back_Light_Enable>
<Back_Light_Timer__sec_ group="User/Screen">900</Back_Light_Timer__sec_>

Valid parameters replaced by [].

Thank you.

Kind regards,

Martin Jendrian

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Marcos Hernandez Wed, 09/30/2009 - 04:56

Hi Martin,

I have forwarded this question to our engineering team. I will post their comments here once they get back to me.



Marcos Hernandez Wed, 09/30/2009 - 12:06


After some more research, we have determined that the phone is using the default refresh time of 5 seconds becasue the HTTP server is not including a value for it in the HTTP header. We will change the behavior in a future version to stop trying to fetch an image if that is the case.

Thanks for bringing this to our attention. In the meantime, your only option is to instruct your HTTP server to provide a "Refresh: xx" field in the HTTP header.


mjendrian Tue, 12/01/2009 - 05:33

Hello Marcos,

sorry that I did not update on this issue for so long. But we did put a standby on those phones for some time.

I did try now to add the header that you suggested and the result is still the same. The phone pulls every 5 seconds an image from our servers. Here is the header, I am sending :

  HTTP/1.1 200 OK

  Date: Tue, 01 Dec 2009 12:55:54 GMT


  Refresh: 86400

  Content-Type: application/octet-stream

  Content-Length: 4347

  Connection: close

Same result with a refresh-rate at 40. The phones poll the web-server every 5 seconds.

I use the firmware 7.3.5

Do you have any other suggestions?

Kind regards,

Martin Jendrian


icastrov Mon, 05/03/2010 - 03:31


This was fixed in 7.4.4, please download it from




This Discussion

Related Content