Incoming calls not answered on SPA9000/SPA400

Unanswered Question
Sep 24th, 2009

Hi,

I've got problems when making incoming calls to my SPA9000/SPA400 system. It's got a single analogue line coming in and currently two phones on it. I had to factory reset the system as outbound audio down the PSTN line wasn't working.

Since that reset I've only had a single incoming call answered for about 10-15 calls I made from my mobile. It was working previously The PSTN line is a BT (NTL to be more precise) line and has no extra features installed. Previous to the reset it was answering calls everytime.

I've attached on the two configs and a debug log from the two devices.

Can anyone tell why it's not answering?

Adam

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
William Childs Fri, 09/25/2009 - 05:02

Did you use the wizard to set this ENTIRE operation up? Are the firmware(s) up to date? Try factory defaulting the phones, SPA9000, and SPA400 once again and setting it up according to the admin guide. With the wizard everything should run smoothly. I looked at the log and the only two items I see on the network are the SPA9000 and SPA400. There are many 200 ok messages between the 9000/400. This tells me that the 9000 doesnt know where to send the call after it lands on the 9000. If you could check to see if your phones are registered to the 9000.

You can do this by looking at the PBX status on the 9000 web page. If you don't have phones listed there, then the 9000 doesn't have any "peers/clients" to send the call to.

Using the wizard will make you set all of this up and will also detect if your phones are on the same network as your pbx.

Good Luck,

Bill

biggles69 Fri, 09/25/2009 - 11:28

The firmware on all the devices is up to date. I've done a factory reset on the SPA9000, SPA400, SPA942 and the WIP310. I also used the latest Wizard to configure it all.

Are you saying that the logs show the call is coming in to the SPA9000 but it doesn't know where to ring/which phone? It's odd that I managed to get through once after a few attempts but not since.

I can try and reset it all again next week, but not sure whether that will help.

Also, does anyone have the recommended settings for using the SPA400 with a UK phone line? There is something on the site here about the Caller ID settings, but that doesn't cover everything.

Thanks,

Adam

Patrick Born Fri, 09/25/2009 - 14:54

Hi Adam,

You shouldn't need special settings for the SPA400, SPA9000, and SPA phones if you used the Wizard and localized for the UK. The Wizard does it all.

Regards,

Patrick

-----------

d-schuemann Wed, 09/30/2009 - 14:51

I have this exact same problem also. When I reboot the SPA9000 it works again for a couple calls. Then stops.

Patrick Born Thu, 10/01/2009 - 17:10

Hi d-schuemann,

I suggest that you verify that the SPA9000/SPA400 and IP phones are properly localized.

Configure debug on the SPA400 and SPA9000.

Start the syslog server.

Make calls until inbound calls fail. [Keep a detailed log of calling number, time of day, and result] Notes are useful when reviewing large logs.

Stop logging.

Review the log and compare working inbound calls with failing calls.

If you need help analyzing the log file, I'll need:

Configurations from SPA9000/SPA400, and IP phones

Log file and notes from inbound calls

Useful documents:

https://www.myciscocommunity.com/docs/DOC-1751

https://www.myciscocommunity.com/docs/DOC-2148

Good luck,

Patrick

----------

Patrick Born Tue, 10/06/2009 - 18:54

Thanks d-schuemann,

I'll take a look and get back to you.

Regards,

Patrick

-----------

William Childs Thu, 10/08/2009 - 02:38

d-schuemann,

Who/ where is extension 150? What happens when you send all calls to the AA without ringing an extension first? Do you hear the AA? Will it let you dial an extension from the AA? Does the light for the corresponding port on the SPA400 light up when the call comes in? What is the status of the light on the SPA400 when you hang up the phone? Does it stay lit or go off? Can you make or recieve a call after you hang up? Also go into your SPA400 and verify that the ip address of the SPA9000 is correct. In the first posting of your config, it shows the ip address of the 9000 to be 192.168.1.100. In these configs, it shows the 9000 ip address of 192.168.9.2. The easiest way to verify IP addressing is correct, go to the status page of the SPA400 and verify that it is registered.

Bill

d-schuemann Thu, 10/08/2009 - 06:28

Extension 150 is the incoming hunt group.

I will try to switch it to auto attendent first.

The lights blink while a call is coming in. Outgoing calls work fine.

The only way I can get calls to be accepts is by rebooting the unit.

The ip address is setup to discover automatically.

biggles69 Fri, 10/23/2009 - 08:39

Meant to reply back but kept forgetting. After a complete reset of the system and bringing each component back on the network in turn it is all working.

Adam

Patrick Born Tue, 11/03/2009 - 14:06

Adam,

Great. Thanks for letting the Community know.

Regards,

Patrick

-----------

Actions

This Discussion

Related Content