Cisco IP Communicator desktop phone not working via wireless connectivity

Unanswered Question
Sep 24th, 2009

I use the Cisco VPN client version to VPN from home into my company's network. Once connected, I use the Cisco IP Communicator desktop phone v 2.1. If I'm using a hard wired connection, everything works fine. However, if I'm working wireless, I cannot get the IP Communicator to work. It just sits there 'registering', but never connects. I have edited the preferences and change the NIC from the wired to wireless card as well as unchecked the 'Optimize for low bandwith' checkbox. Any ideas on what else I can do to make this work?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
runningboy01 Thu, 09/24/2009 - 11:29

Was your ethernet connection the one you orignally used? If so, it is likely that only the MAC address of it is configured in Call manager to work with your IP communicator. I believe your wireless card has a different MAC address which would need programed in Callmanger in order to work.

big_pappie Mon, 09/28/2009 - 19:48

I checked with the PBX admins and they said they cannot add individual PC MACs to Call Manager. They said they only use the MAC of the IP Communicator that is generated when interfacing the with connection method.

This is a frustrating issue because it works when hard wired, so technically it should work wirelessly.

Anyway, thanks for the response. Any other suggestions?

JASON BOYERS Sun, 10/04/2009 - 18:24

If you are using CM 5.0(1) or later, you can configure a device name for IP Communicator that is independent of a MAC address. I've used ones like IPCJBoyers before, and it worked fine. They would need to change the device name in CM to match what is configured in IPC. This works well for your scenario, where you're not sure if you are going to connect via wired or wireless.

truthseeker88 Thu, 06/10/2010 - 12:26


I faced the same problem, but then i tried disconnecting the wireless network, starting the ip phone, then connecting again to the network after starting the ip phone and it worked fine. Try this and give us your feedback.

mpoyser Wed, 07/06/2011 - 09:37

I'm having this same problem on 3 different models of HP laptop.  If I plug in a cheap USB wireless adapter it works fine (even over VPN).  I'm using CIPC 7.0.3.


This Discussion