High CPU usage in Router

Unanswered Question
Sep 24th, 2009
User Badges:

Hello,

I have a Cisco 2651 router running 12.2x IOS. I get this error message in my log some times and at that time i cant reach the router at all

-----------

%SYS-3-CPUHOG: Task ran for 11507 msec (0/0), process = Load Meter, PC = 803F22E8.

-Traceback= 803F22EC 803F475C


I cant find this error message in the internet and not sure what could be. Also checked Cisco Bugtrack tool and couldnt find. Can some help me to isolate this issue?


Is this is related to wrong or faulty code or???

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
simontibbitts Fri, 09/25/2009 - 01:31
User Badges:
  • Silver, 250 points or more

Hello.


This message appears when something hogs the CPU for some time (11507 msec) in your case. It can sometimes be caused by people running large commands like show parser.


Check your logs to see if anyone else was on the router. 'show process cpu history' will give you a good idea on CPU load of your router.


This link will help you understand:

http://www.cisco.com/en/US/products/hw/iad/ps397/products_tech_note09186a00800a6ac4.shtml


Simon

simontibbitts Fri, 09/25/2009 - 01:43
User Badges:
  • Silver, 250 points or more

Hello again.


Just seen that it gives the process which caused the high CPU 'Load Meter' which is described as:


Computes the load average for the different processes every five seconds, and the five minute exponentially-decayed busy time.


So, could well be a bug yes. Might be worth doing a search on the bug toolkit for it.


Simon

trackme Fri, 09/25/2009 - 01:51
User Badges:

correct, since its happening recently and at random intervals. What i will do is do more research on this and also try to reboot the router since some times rebooting a router might fix too :)

Actions

This Discussion